update issues


Last update won’t set up and load, it keeps quitting, which means nothing works and can’t listen to anything.Would like to know hat I can do to fix this.

2019 macbook sonos app keeps quitting

2009 G5pro sonos app spinning wheel of death does nothing but keeps spinning

iphone 11, sonos app last one to quit

8 replies

Sure sounds like there’s something on your network that is blocking the ability for all devices to reach out to the Sonos servers to get the updates necessary. 

Are you running any VPN, virus protection software, port blocking software? Have you tried rebooting both the router and your Sonos devices? Have you called Sonos Support?

Userlevel 7

I agree with @Airgetlam. If none of your devices are able to communicate with the Sonos server there is definitely something going on with your network. The problem is with the settings on your router or your ISP is having issues.

Antivirus loaded on your PC would not affect your other devices. A local device VPN would not prevent your other devices from reaching out to the Sonos server. On the other hand if a VPN is router based it would affect all devices. 


Airgetlam and AjTrek1

I’ve had this system and app for years, everything worked great until the new updates for the S2 came out.

No VPN, antivirus or port blocking software of any kind has been installed, haven’t changed anything. This also isn’t the first time I’ve had issues when it to Sonos updating their apps. Pretty much at the end of my rope with this stuff.

Userlevel 7

I get it that you’re upset. However there was no need to print mine and @Airgetlam community names in BOLD print as if you are screaming at us. That’s very rude.

That saiid your profile shows you have a Play 5 (Gen1). Are you running a “split” Sonos system _ S1 and S2? The latter is not compatible with the Play 5 (Gen1) as shown in the link below. 


You can set a “split” system by following the link below.  




@AjTrek1 are you kidding, I just copied and pasted and that’s how both you and @Airgetlam handles came up, so lets drop that. No, I’m not running a split sonos system, S1 stopped when I installed S2 which has been glitchy ever since. I appreciate both of you offering to help, I really do, but Sonos does not make it easy to trouble shoot and figure out a system that started off as an easy plug and play app.

Again thank you for your feedback.


Userlevel 7

OK…try removing the Play 5 (Gen 1). See if that resolves your issues. The Play 5 (Gen 1) is not compatible with the S2 controller. 

Note also that while you may not have changed anything, that doesn’t mean that nothing has changed. There are a multitude of things that can update in the background without a users knowledge. 

I’ll leave you in @AjTrek1 ‘s capable hands. 

Userlevel 7
Badge +18

Hi @Irv98 

Welcome to the Sonos Community!

It looks like your Play:3 is now up-to-date, but if you continue to experience any problems, I recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.