"Unable to connect to sonos, Lets fix it" on new phone, old one still works

  • 18 December 2022
  • 10 replies

Ik have a couple of "IKEA Symfonisk” speakers some wired to my home network some on Wifi both have the Android app version 14.20.1.

On my old phone (Android 11) I can use the Sonois system as I did before.

My new phone (Android 13) keeps coming with "Unable to connectto Sonos. Let’s Fix It”.

Even after removing and re-instralling the Sonos App on the new phone an trying to join an existing system it fails to find my system with the erro "There was a problem connecting to the Sonos system” with only a try again button.

Somehow the entire Sonos system cannot be found on my new phone, while on others (older phones) it seems to work flawlessy.


Best answer by Reink 21 December 2022, 16:36

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

Mesh network?

@Airgetlam  It is not a "mesh” network. There are more than one accesspoint but they are all wired to the network an do not mesh with eachother the accesspoints only communicate with the wired router.

Both trhe working phone (Android 11) and the non working phone (Android 13) both use exactly the same network.


Depending on how these ‘access points’ work, it’s possible that your phones are on a different subnet of your LAN from the Sonos devices. 

Try powering down all of the ‘access points’, leaving only your base router up, and see if your new Android phone connects, as a test. If so, this is probably why Sonos has put on the FAQ that ‘Networks using wireless range extenders’ are unsupported. 

If this test does work, you may want to call Sonos Support directly to discuss a way to set up these ‘access points’ so that they are using the same subnet. 

The problem was VPN software wich was active on the new phone (Removed/Disable dthis software and Sonos started working again)

On my old phone this software did disable itself when the phone was on the home network that didnt seem to work on the new phone.

I am having a similar problem on a google mesh network. One iphone 14 working.  One 14 max pro find the system and then cannot connect.  I’ve unplugged and restarted everything including the phone. 

Hi. Do you have a Sonos speaker wired to the primary Google puck?  If not, please do so.

This is just a troubleshooting experiment. You may need to power your Sonos devices off and on again.

That will take some moving around but I’ll do it.   To be clear, connect to the network, power all off and on including bouncing the network, connect?  Then I should be able to disconnect the speaker I connected to the puck?

By the way, since my original post,  it randomly reconnected but that happened earlier and it didn’t hold. 

Thank you all.  It turned to be that my Boost was set up separately from the speakers.  I can’t say when or how this happened, because the system has been in place for years, but it did.  The first tech I spoke to at Sonos tried to convince me that I didn’t have a problem because I was connected *at that moment.*  After 55 minutes, I managed to strong-arm my way to a Level 2 support agent who spotted the problem in 10 seconds flat.  It took another 10 seconds to fix.

Same problem. New phone (15pro) finds system but can’t  connect. System works fine with my husband’s phone; checked new phone VPN/device management and it’s all disabled. Network is Amazon Eero, but how can that be the issue if everything worked/works perfectly except on the new phone? This is more frustrating than early self-checkout kiosks. Any ideas would be appreciated!