"Unable to connect to Sonos Fix It "

Userlevel 1

My Sonos app suddenly stopped playing and will not connect to my players. 

The app screen has this message that I've not seen during 5 years of consists use and many troubleshooting adventures, "Unable to connect to Sonos Fix It " 

I've completed all  the troubleshooting recommendations I can find, and many improvisations. 

Please help, I need my music, it creates my ambiance!

Thank you. 


Best answer by Chris 7 May 2020, 03:19

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

29 replies

Userlevel 7
Badge +22

What happens when you take one of your sonos units and hook it by wire to your router.  Give it a few minutes then try in your app to connect to existing system.

Me either,Today's morning I can't use SONOS
And my iphone spotify cannot connect to SONOS 
"Unable to connect to Sonos Fix It "
but airplay is working
I restart my wi-fi and all SONOS device,but still same problem
Thank you

Userlevel 7
Badge +22

I would start a new thread with your issue.


But sounds like entire system is working except Spotify Connect from your iphone.   Have you restarted your iphone.

Userlevel 1

What happens when you take one of your sonos units and hook it by wire to your router.  Give it a few minutes then try in your app to connect to existing system.

Thank you Chris!

You helped me resolve the problem. 

One of my players was connected to my router, and had been for months, because of a previous connection problem. 

Upon your suggestion, I disconnected the ethernet cable, reset the Sonos app, and reconnected the player via ethernet ... connection problem solved. 

Thank you, 


Userlevel 1

Sonos has posted a music services status notice regarding connection issues with Spotify, on 

Recent updates to this notice indicate that Sonos is working with Spotify to resolve this issue. 

They’ve fixed it!  Thank you!

Badge +2

Only in the last month have I had a consistent problem with Sonos connect to my Wifi-----I keep getting “unable to connect to Sonos fix it.” Never got this before….now every evening when I try to play music I get that notification and have to turn my phone on and off once or twice or three times until it finally connects. What is wrong??

The Iphone is connected to my Wifi so I know it’s working okay.


Thank You






It may be the connection between the speakers and your router that’s the issue, not the connection between your phone and the router. I’d recommend starting with a simple network refresh.

Unplug all of your Sonos devices from power. Reboot your router. Once the router comes back up, plug back in your Sonos devices, and give them a minute or two to boot back up, and then test. See if that helps. 

If it doesn’t, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this issue, and contact Sonos Support to discuss it. 

I usually suggest the phone folks, they have more tools available, and are available Monday through Friday during business hours. Twitter support folks are available 24/7.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution. 

Badge +2

Thank you---------

I have the Sonos one plugged into an outlet in my kitchen. Each evening we unplug it and go outside to our Tiki Hut where I replug it back in. I wait until the light stops blinking and it connects and then I try to go into the Sonos app and connect with Amazon music---this is when I have the issue----never had it before until recently, The Iphone shows no issue and it shows being on the Wifi network-----Turning off and on the Iphone finally allows it to connect and play music. 



That sounds like it could certainly be wifi interference from an outside source, like a neighbor with a new router using the same channel, or some such.

But I’d still do the process I outlined. It’s possible that your router is holding on to a bad IP address for the Sonos, since you’re not rebooting it while the Sonos is unplugged. If that’s the case, the Sonos would just reconnect to the “bad” IP address when you plugged it back in.  

Badge +2

Thank you Bruce.


Bill Carey

I have been having problem "unable to connect to Sonos Fix it" everyday since Jan 2020 (after I own it about 4 years). My home network works well, every devices connects to network properly, except my sonos Play 3. It always lost connection any very often and I did following all of trouble shooting guide line what Sonos suggested however the problem cannot fix/solve permanently. 

Please advise.


Thank you





I’d recommend the same procedure recommended above. 

I have 2 Sonos amps and I’m getting this disconnected from Sonos issue. Router connectivity is great, restarted both Sonos amps no dice.


Last time this happened (2 month ago) I called support and had to make a wired Ethernet connection to update my Sonos Amp as others have done in this thread. Now I have 2 amps and this is pretty annoying as I have to disconnect the speakers, HDMI, power on each, cart them upstairs to the router and down again which is all fine. But how often am I going to have to do this?


Clearly Sonos is pushing out bugs or incompatible versions of software. Does anyone have strategies to minimize the impact of their screw ups? I’m wondering if there’s any way to perform updates on my own schedule. Another solution would be a WiFi to Ethernet adapter at each amp since the Ethernet port continues to work after these broken updates hit. 

Here’s hoping the upcoming “OS” refresh comes with more reliability.

Userlevel 4
Badge +3

I have the same problem.  Used Sonos for 7 years, no problem.  On almost a daily basis, i open the iOS app and get the dreaded “Sonos cannot connect” message.  I have 3 components (Sonos Control Gen 2, Sonos Control Gen 1, Playbar).  The fix is to unplug the Sonos Control Gen 1, let it reboot and everything works, until tomorrow (Groundhog Day).  Btw, the Gen 1 Control is ethernet wired, everything else is WiFi.

I believe the issue is related to the Sonos Control Gen 1 (only S1 compatible).  This is the unit I originally set up my Sonos system with, the other 2 components were added later.  I am on hold for Sonos support now, haven’t been able to find a fix in the forums or online.

I wonder if either of these 2 options would work:

  1. Wipe my Sonos network, use by Sonos Connect Gen 2 to set up the new network, and keep the Gen 2 ethernet wired.
  2. Hard reset to factory defaults for the Gen 1, i’ve held off on doing that for now…

Any thoughts from you techno-wizards?  According to all the notes I’ve seen, my system should work on the S1 app, but should not be continuously crashing.


Userlevel 4
Badge +3

I went ahead and did Factory Resets to all 3 of my zones and setup my System again.  So far no disconnections, I will report back with update(s)...

I’ve had about 7 or so interactions with support at this point. I was happy to see S2 arrive because I thought maybe due to random luck something would be fixed. Upgraded both Amps then the next day they were disconnected again. Here’s what I’ve learned:

  1. The last support person recommended that I split my 2.4 and 5GHz bands into 2 SSIDs. Sonos only uses the 2.4 band.
  2. I only need to wire one of my devices to the router to get both devices operating again.

I’m also thinking about assigning static IPs to the 2 Sonos devices just to see if that changes anything 

I’ll split my network SSID to see if that helps but makes me a little sad that my other devices won’t be able to seamlessly switch bands to trade off speed and range.

Userlevel 4
Badge +3 after I restored to Factory settings I once again received the “Sonos cannot connect” message again.  I started to think, perhaps this is an Ethernet connection issue for the Gen 1 Control.  Perhaps the various software upgrades over the last 5 years have focused on WiFi at the expense of the Ethernet configuration. Maybe not. 

In any case, I set up the Sonos system to go over WiFi only, and so far the system is working well with no resets.  I am also able to access my music library without difficulty. We will see...

Same issue. Doesn’t matter whether I try and connect to my Sonos network through Apple Music AirPlay or through the Sonos app. More often than not it can’t find my Sonos network. This is a new issue in probably the last 3 months or so. But it’s the worst. Suddenly all music just stops playing and the app can’t even find any of my speakers. Nothing I can do about it but wait. Try again in an hour or so and suddenly it works fine again. It’s incredibly frustrating. 

Userlevel 4
Badge +3

Unfortunately the WiFi set up still resulted in multiple disconnections when streaming from the music library. I stopped using the v1 Sonos Connect and hardwired via Ethernet my other Sonos Connect and Sonos Amp. Using a playbar as well, no music disruptions anymore.  

something in the S1 software impaired the ability stream from music library’s, in particular with first generation components.  

Userlevel 4
Badge +1

Count me in as well as a new user with this problem. Been using Sonos for years, and now all of a sudden in the last few weeks all I get is ‘Unable to Connect to Sonos’, both from the iPad app and the Android app. When it first happened, I didn’t use my Sonos system for a couple weeks. Finally followed the troubleshooting, and the restarting WIFI/router (my unit is an XFinity all-in-one) did the trick. I have had to do it basically every other day for the last week. Now today, that trick isn’t working either. 

Why does everything else on wifi work fine: Google Home, Google Home Hub, iPad, Android phone, laptop, Chromecasts...but not god d*** Sonos. I am so tired of this product.



Moderator Note: Modified in accordance with the community guidelines.

Userlevel 4
Badge +3

The S1 gift from Sonos is 1st Gen components cannot stream a music library via WiFi without crashing the network entirely.  Those components need to be hardwired.  Part of the plan to get everyone eventually to upgrade to S2 components

Userlevel 1

Adding to this. Unchanged wifi network, everything working fine. For the past few months at least same issue.  Using the Sonos P1 app on iOS “Unable to connect to Sonos”. Strangely in Settings, the sections for Account, System and Services & Voice are all greyed out. None of the normal troubleshooting techniques has worked. I have connect the devices to my router with Ethernet and none of them are showing up. This really seems to be a major bug after years of reliable service. 

Same problem here. Switched from S1 to S2 and spotify did not work anymore when trying to play a song. Nothing helps, reauthorizing, remove/add service, restarting everything etc. This must be a bug of S2, because directly after updating it stopped working. This can’t be a problem with the WLAN, Bands, ect.

Here my confirmation number of a the diagnostic report, if sonos is really interessted in solving this problem: 150945804.

Userlevel 5
Badge +14

Hi @j.a.z.

Welcome, thank you for reaching out to Sonos Community.

Sorry for the inconvenience but can you try to submit another diagnostic report the first one doesn't seem to be working properly.

IIf you need help with any other information, please be sure to let us know.