Answered

Sub mini not connecting since update


I haven't been able to connect to my sub mini since the latest app update and have tried factory resetting/reinstalling numerous times.

The app recognises there's a sub but won't do the final part of connecting it to WiFi. 

I'm guessing I won't be the only one experiencing this problem.. 

icon

Best answer by Waldor 12 May 2024, 10:18

View original

85 replies

Userlevel 1

I’ve been having similar issues. Everything had been working find for several months, then last week, the Sub Mini went to crap. I did a factory reset and after much struggling, I got things to reconnect a couple times when I plugged the Sub Mini directly into my router, but it wouldn’t reconnect wirelessly. Last night, I did a factory reset on my Beam Gen2 and the Sub Mini, in hopes that resetting everything might help. I set my router to reject the Sub Mini’s Mac address from the 5 GHz signal to make sure that wrong signal wasn’t an issue, and I set static IPs for both. This seemed to temporarily work, as I was able to wirelessly set up the Sub Mini for the first time ever since owning it. However, this morning the Sub Mini was no longer showing a network connection in the app, and I couldn’t get it to reconnect.

I’ve been fighting with the Sub Mini the past few hours trying to get it to connect again. I can go through setup, but then the sub doesn’t show. I had to call it quits for now because my wife has a remote job, and I can’t keep messing with the Wi-Fi while she’s trying to work. I never have issues with the Beam Gen2, but overall, my experience with the Sub Mini has been pretty bad.

Do people have these problems with the regular Sub? Regardless, the price of Sonos products is TOO premium to constantly be having quirky connection issues. This is seriously pitiful. Sonos need to do better and quit sucking so badly.

Having exhausted re-setting sub, re-installing the app, turning off router etc.. I eventually re-set the sound bar as well. 

Although this didn't work first time, it did the second time of asking. 

I would add that throughout all of this, the app changed it's mind regularly as to whether I had already set up a system/speakers or not. 

Now having finally got both to work again, I find that neither Amazon Music or Soundcloud are working on the app...

 

Userlevel 1

There have been messages popping up on this site about the Amazon Music account issues, so it would appear that Sonos is aware of it and hopefully working on it.

I’ll have to wait until later to try working on reconnecting the Sub Mini again.

Edit: I noticed the Sub Mini appeared in the app after everything simmered for a bit, so I hit the button to register it. Once it registered, it failed to pair a couple times. Eventually the prompt to add it to a room came up and it finally worked. Hopefully this is the last time this happens with the Sub Mini. I’m finding that it needs time to “simmer” before it will work. It took me a day and a half to figure that out when I first got it and tried to set it up.

Just received my mini sub and app will recognize the sub to connect but then will pop up connection error at the final steps of connection. The sub will then be shown on the app as not registered. 

Yeah I was getting that all day yesterday.

The app isn't even sure this morning whether I have a system set up at all. 

Still no use of Amazon Music or Soundcloud. 

What an absolute shambles. 

Did you ever have an issue before the new app update? 

Not in the slightest (other than usual user struggle when first setting up). 

Seems like a lot of folk are reverting back to previous version of app but yet to tackle that process.. 

 

 

How would you reverse back to old app? 

There are some guides on reddit specifically off the back of the new shambles of an app. 

Meanwhile, my mini sub has disconnected and won't connect again... 

Userlevel 1

Mine has been pretty solid since I managed to get it reconnected. It seemed like letting it sit for a while before trying to reconnect it worked. I’m sure tweaking my router settings to block the Sub Mini from potentially trying to use the 5 GHz Wi-Fi signal helped, but I don’t know that trying to lock it to a static IP was a help or a hinderance. The Beam Gen2 is fine with a static IP, but the Sub Mini didn’t seem to like it, so I set it back to the regular DHCP setting on my router.

Not been able to connect to sub again. Just coming up no network.

Will probably have to tackle going back to previous app. 

https://www.apkmirror.com/apk/sonos-inc/sonos-for-android/sonos-for-android-16-1-release/

 

Make sure you turn off updates.. 

Userlevel 1
Badge

Same here. I bought Sub mini today and there is no way on earth to connect it to the system. I tried everything, really everything apart turning off and on the electricity in my flat and nothing worked. I just can’t register it, it will stay some time on the adding screen and then just message that it can’t be done. What I also noticed that my Beam gen 2 was not registered when I removed it from the surround setup so I registered it, then it said successful but still showed as unregistered in the app. Since I am able to play the Sub mini sound when connecting sub to the surround I think that the sub itself works and is in fact connected but the problem is in the Sonos app.

I contacted customer support and they confirmed that there is a known issue for latest app, and they are fixing right now. If you have android device, download the apk from below link and it works for me.

 

https://update-software.sonos.com/software/nvasc21FQF/Sonos_78.1-51030_64bit.apk

Userlevel 1
Badge

Thanks for the info, unfortunately I’m on iPhone. I have to wait for an update.

I contacted customer support and they confirmed that there is a known issue for latest app, and they are fixing right now. If you have android device, download the apk from below link and it works for me.

 

https://update-software.sonos.com/software/nvasc21FQF/Sonos_78.1-51030_64bit.apk

Unfortunately this Apk didn’t work for me, I have and android as well and tried it but same issues with iPhone app. Sub mini won’t connect still.

It is honestly frustrating having to pay such a price for these systems and sitting several hours trying to add the sub mini with no luck, now the mini just sits there as decoration, hopefully this is fixed ASAP! The previous software worked just fine and a new S2 update was not necessary!!!

Userlevel 1
Badge

These things happen regardless or product price but what fascinates me is how this all was tested before launch and given a green light 😂

New SUB mini today and and same issue. Very disappointed can someone update on this please?

Userlevel 1
Badge

Nothing other than it’s a known issue and you can either revert to older app version on Android or wait for an update on iOS.

Same here. My Sub Mini hasn’t been able to connect since the latest app update. I tried connecting it via ethernet and no luck. 
hopefully they’ll release a fix soon

Yep same here, just plugged my new sub in and it won’t Assign. 

 

 

Badge

On hold for 75 minutes to get help. I might lose my mind 

I just got my sub mini Back home 6 hrs later and lots of firkling about still no go . maybe I should leave it til the am(difficult). will they sort out the app soon ???

Then all deep joy possibly 

Reply