Spectrum problem

  • 14 February 2023
  • 43 replies
  • 5854 views

I have spent almost 11 hours on various telephone calls with Sonos tech support trying to get my Sonos One speakers working.  Technicians have told me that I must label my 5G and 2.4 with different names.  Spectrum tells me their routers cannot do this.  Are there cures for this problem?


43 replies

I had this same issue trying to set up two new Era 100s (my first Sonos products) - I called spectrum and had them manually switch my phone to the 2.4 gigahertz band so I could finish the setup but as soon as he switched it back to 5 the app could no longer find my system (even though the Era 100s allegedly work on both bandwidths. I bought a new router to plug into my spectrum modem (NETGEAR R6020, was $36 on Amazon) and renamed the network to my original network name, and everything immediately worked - I didn’t even have to create separate networks for each bandwidth!

Badge

I’m still having issues where the system loses the network and I have to unplug all my speakers and search for the system. I’m looking at this router: WiFi Router 1200Mbps, WAVLINK Smart Router Dual Band 5Ghz+2.4Ghz. Will this be a good option?? Tired of the constant disconnects with the Spectrum router! 

Just replaced my spectrum router this past weekend because Sonos customer service mentioned it’s a known issue with Spectrum routers; I always had at least 2 speakers missing! When I added two Sonos era 100s in December, the situation only got worse. I was really getting ready to return them. I have 5 Sonos speakers and was suuuper frustrated.
 

 I tried the NETGEAR router mentioned in this thread, but it didn’t work for me! Maybe I got a dud because I bought used from Amazon.

I caved and bought an Eero router fr Best Buy and omg, I wish I did this sooner…returned rented router to spectrum today. Good riddance!!! 

Badge

Just replaced my spectrum router this past weekend because Sonos customer service mentioned it’s a known issue with Spectrum routers; I always had at least 2 speakers missing! When I added two Sonos era 100s in December, the situation only got worse. I was really getting ready to return them. I have 5 Sonos speakers and was suuuper frustrated.
 

 I tried the NETGEAR router mentioned in this thread, but it didn’t work for me! Maybe I got a dud because I bought used from Amazon.

I caved and bought an Eero router fr Best Buy and omg, I wish I did this sooner…returned rented router to spectrum today. Good riddance!!! 

What model etc? 

 

Hello,

There are known Wi-Fi issues with Spectrum routers. See Incompatible hardware with an available solution

The general resolution is to use Sonos in a wired setup."

"Wired" is not a good solution! Results in poor, limited speaker positions.

That’s why I use a Sonos BOOST. It can sit close to the router, without sacrificing a speaker.

Userlevel 7
Badge +22

I’ve found it fairly easy to wire several Sonos here, in particular the Arc and Beams since I already had Ethernet to the TVs.

A Sonos Boost is also a good option to get off WiFi IF you don not have any WiFi only Sonos Era speakers.

We travel a lot. This Spectrum router incompatibility was just another disappointment. Guess what, Roam doesn't work with hotel wifi. Last year it took 2 calls and 3 hours of Support time to make our SL One speakers work in an Airbnb. Sonos product is just too fragile. Big regret I bought it. It won't play Amazon music, can't "find" the music yet the same music plays via Bluetooth to the Roam. On and on. 

Been having similar issues ever since we got a new Spectrum router.  All three Sonos devices appear to be connected to the router, but fall in and out on the app.  Seems very random, with constant “connection” issues… at least as it appears on the app.

Tried this today and so far it seems to have fixed the problem!

In the My Spectrum app, clicked on Router and Advanced Settings.  There is a setting there called UPnP (Universal Plug and Play), which “enables devices on your network to find each other and communicate”.  This setting was disabled… enabled it, and after the router reset now everything works!

Hopefully it continues, but so far its working consistently.

I did this (enabled UPnP) and thought it was working for a bit, but then started having the same problems. Then I saw on another post, and remembered from issues I had years ago, that the best and easiest fix is to plug one (yes, it works with only one) of your Sonos speakers into your router with an Ethernet cable. Your Sonos system will create its own network, and just like that, all your router problems solved!

Folks, the easiest fix for any router issues is to plug one of your speakers into the router with an Ethernet cable. Your Sonos system will automatically create its own network and, just like that, all router related issues are solved. Of course, you need to have your router near enough to one of your speakers, or run some cable through your house. But for me, it was a much easier and less expensive fix than having to buy a new router. And yes, you only have to connect one speaker, not all of them. 

BTW, my issues were caused by a new router from Spectrum.

Folks, the easiest fix for any router issues is to plug one of your speakers into the router with an Ethernet cable. Your Sonos system will automatically create its own network and, just like that, all router related issues are solved. Of course, you need to have your router near enough to one of your speakers, or run some cable through your house. But for me, it was a much easier and less expensive fix than having to buy a new router. And yes, you only have to connect one speaker, not all of them. 

BTW, my issues were caused by a new router from Spectrum.

Per the support, this will not work for Era 300s

The older SONOS product will build its own private wireless network, SonosNet, when one or more units are wired to the network. The newest units, such as the ERA’s or any of the portable units do not support SonosNet. Using a SONOS USB network adapter, you can wire the ERA’s and MOVE 2. Otherwise, the newer units must use WiFi and, if you search, there lots of Internet “fires” burning around the SPECTRUM router.

If it was my system, I’d disable the SPECTRUM’s WiFi as much as possible or ignore it and install my own router. Actually, I’d avoid SPECTRUM if possible.

I connected my Netgear router to the Spectrum Modem/router, and did as @buzz suggests. Never had an issue, other than Spectrum dropping more frequently than I preferred. AT&T DSL was way more steady for me. 

@Airgetlam, can you Bridge the SPECTRUM?

I think it depends on which one you get. The version I had, 4 years ago, yes. I’m not sure that version is still available, but I haven’t checked, I’m happy not to have to deal with Spectrum any longer. That being said, I’m really hoping fiber gets to my location in the next several years, right now CenturyLink is the only wired possibility, and they failed four attempts to install over three months, I have too many trees to go with a satellite option, so I’m stuck with a 5G offering from a cellular company. Living in the sticks does have some connectivity restrictions. 

At least you don’t have much WiFi interference. Currently I’m in an urban area. I have fiber — that’s great. On the not so great side — at times I can see about 70 access points; a combination of home mesh systems and a medical facility next door. There are a few “smart guys” who are using channels 8, 9, & 10. I suspect that some of these are “auto”.

Replaced my Spectrum SAX2V1S with a TP Link AX1800 ($85 cost) and my Sonos connectivity issues disappeared.  Not sure what the problem was with the Spectrum router but cost of new router was way worth the time saved in fussing with the Sonos app on speakers disappearing.

Hi,

   As of 5/15/2024 the problem persists. I went with a inexpensive AX1500 and Sonos Beam,Sub Mini,2sl wireless . All working fine as of now.

 

Reply