Sonos Players DNS Problems. No Update and no music playback possible

  • 15 March 2023
  • 9 replies

Hi together,

I’ve had this issue now for some weeks when the Sonos players denied to playback music.
I tried many troubleshooting from the support websites with no results.
After talking to the german hotline support for 3 hours with 3 guys, we found out via the http://<IP>:1400/tools page, that the players cannot resolve any addresses. So I guess it’s some DNS Issues here.
Unfortunately the support couldn’t help with this issue as my router-config looks good.
We tried using googles DNS in my router settings and also cloudflare dns won’t help. I also have reset the router and the speakers several times. A factory reset for the Play:1 didnt help either as I cannot add it to the Sonos Controller App anymore because it cannot contact the server.


Further Info: All my speakers are first generation (Playbar, 2x Play:3, Play:1) They are connected via WiFi currently, but I also tried an ethernetcable connection. 

Any suggestions from your side?

Thanks & Kind Regards


Best answer by Belly M 15 March 2023, 08:22

View original

9 replies

Refrain from any additional Factory Reset without further consult.

Describe your network for us, including model numbers. Which controller are you using? Have you changed anything? Updated anything?

Network is started by ISP Vodafona Kabel Deutschland going in to our cable router AVM Fritz!Box 6660 Cable. 
Currently all Sonos players are connected via WiFi excluding the Play:1 from the last factory reset that the support on the telephone suggested as we tried to connect it to my iOS Hotspot (which didn’t work). 

In the past I used a Sonos Bridge but someone suggested not using it anymore to use the S2 Controller App and Update all players. Unfortunately the players can’t update because of the DNS issue. The players remain visible in the network and via Spotify App (but cant connect as there is no DNS for the Sonos Players).

Updates are not available for me although I tried.

From the working status to not working I didn’t change anything in my network. It just “happened”. 

AVM have been rolling out major firmware updates, I have a different model Fritz!Box but there were significant changes and I had to factory reset mine about a week ago, luckily I don’t use any of the telephony features so there was not much to reconfigure.


I would suggest looking at the Fitz!Box logs to see if anything shows in there and then perhaps look to see if a factory reset is possible without wiping all your info and loosing the internet. As yours is a cable version you might want to check with your ISP about a reset before doing it.


Edit yours may not have have updated or even an update available so if that’s the case don’t worry about the Fritz!os version but do still look at the logs.

Edit yours may not have have updated or even an update available so if that’s the case don’t worry about the Fritz!os version but do still look at the logs.

Unfortunately the Box doesn’t save logs after restarting. And I restarted it several times the last days as the support suggested.

But maybe it has to do something with the box as my PC has problems with getting DNS from the Box’s DHCP… I had to configure it manually in the network settings. My Iphone whatsoever does not seem to have this problem.

Have a chat to your ISP and tell them about the PC not getting DNS from the DHCP server, ignore the  Sonos issue for now and hopefully they will either get you to factory reset or even send you a new Router as pretty certain this is the issue.

I agree with Belly M: this is most likely a router issue. It’s too much coincidence that both the PC and SONOS are struggling with DNS.

Userlevel 7
Badge +21

Very frustrating that we do not have access to basic Sonos internal info like the resolv.conf DNS server list.

Working around that did you try the “Tools for debugging network issues” page? It won’t tell you which servers you are using only that they are working or broken. replace the with your Sonos’s IP address.

The pings should resolve the name/IP and show the result. Odd that Ping gives a v6 answer as does Ping6.

running /bin/ping -c 3 google.comPING (2607:f8b0:4007:819::200e): 56 data bytes64 bytes from 2607:f8b0:4007:819::200e: seq=0 ttl=117 time=20.815 ms64 bytes from 2607:f8b0:4007:819::200e: seq=1 ttl=117 time=23.234 ms64 bytes from 2607:f8b0:4007:819::200e: seq=2 ttl=117 time=22.090 ms--- ping statistics ---3 packets transmitted, 3 packets received, 0% packet lossround-trip min/avg/max = 20.815/22.046/23.234 ms

Things can get weird. In my case there is an issue on my PC motherboard that wrecks IPv6 LAN support.-- sometimes -- and for some reason particularly on SONOS sites. I changed ISP’s and the new ISP’s Gateway uses IPv6 by default. Once I figured this out, disabling the Gateway’s IPv6 LAN support resolved the issue.

I can imagine a Gateway update could enable IPv6 support, causing pain on certain LAN’s..

Hey guys,


sorry for the late reply.
I managed to solve the problem based on the information I had from the support (dns for sonos not working). Seems that my Fritz!Box had an update or something that denied giving the crucial DNS info to the boxes (had that problem on my pc, too but not on my iphone or android devices)

So I removed all manual configuration for DNS in my Router config and set it back to default. Also removed my DynDNS (as I dont even use it anymore).

One reset of the Testspeaker (Play:1) later and it worked. It can resolve addresses and communicate with the SONOS Cloud and with spotify again. I reset all my speakers and configured them in the S2 Controller and upgraded them. Everything is working fine again. Hopefully that helps someone else.