Answered

SONOS Play 5 Gen 2 won’t finish wifi connection (Eero)


After a Eero Pro firmware update my machine won’t connect. I’ve tried everything including full reset, and hardwire set up - it won’t find and connect my WiFi network. The setup reaches the very last step (connect to my network) and errors out and says no connection is possible. This is driving me NUTS

icon

Best answer by controlav 14 March 2022, 14:20

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

When you connect it with an Ethernet cable, are you doing so to the ‘base’ Eero device, rather than one of the extenders?

Any chance you’re running any VPN, virus/Trojan protection, or ‘work profiles’ on your controller device?

I’m surprised that an Eero firmware update trashed the system, but dumb things can happen. Your SONOS unit or controller may have signed on as a Guest.

Refrain from SONOS Factory Reset without further consult. Usually, this simply causes extra work and, while there may be an accidental, temporary improvement, this is not not a permanent fix.

Describe your SONOS system for us. Is it wired or wireless? What else is on your network?

Userlevel 7
Badge +23

Check the Eero notes here:

 

 

When you connect it with an Ethernet cable, are you doing so to the ‘base’ Eero device, rather than one of the extenders?

Any chance you’re running any VPN, virus/Trojan protection, or ‘work profiles’ on your controller device?

Yes, the base Eero device. I’ve owned the Eero Pro system for 3 years. Only after a recent Eero update did the system start acting like this

I’m surprised that an Eero firmware update trashed the system, but dumb things can happen. Your SONOS unit or controller may have signed on as a Guest.

Refrain from SONOS Factory Reset without further consult. Usually, this simply causes extra work and, while there may be an accidental, temporary improvement, this is not not a permanent fix.

Describe your SONOS system for us. Is it wired or wireless? What else is on your network?

The system is one machine, Play 5 Gen 2. Aside from that, other electronics are on the system (computer, phones, tvs). I also disabled (temporarily) the 5 GHz network in hopes that a single signal (2.4 GHz) would make it easy. Sonos machine still won’t connect

Check the Eero notes here:

 

 

I disabled the 5 GHz band and it still won’t finish the connection

I just want to make sure you all understand. The Play 5 Gen 2 is literally getting to the final step of wireless connection (“connecting to your network”) and just won’t finish the connection. I’ve probably tried to do this 20 times now.

Userlevel 7
Badge +23

I just want to make sure you all understand. The Play 5 Gen 2 is literally getting to the final step of wireless connection (“connecting to your network”) and just won’t finish the connection. I’ve probably tried to do this 20 times now.

Cant you just temporarily hard-wire it to get through Setup?

I just want to make sure you all understand. The Play 5 Gen 2 is literally getting to the final step of wireless connection (“connecting to your network”) and just won’t finish the connection. I’ve probably tried to do this 20 times now.

Cant you just temporarily hard-wire it to get through Setup?

The hardwire set up works, but then it won’t find nor connect via wireless. It’s as if I would have to leave it in via ethernet forever. 

Userlevel 7
Badge +23

I just want to make sure you all understand. The Play 5 Gen 2 is literally getting to the final step of wireless connection (“connecting to your network”) and just won’t finish the connection. I’ve probably tried to do this 20 times now.

Cant you just temporarily hard-wire it to get through Setup?

The hardwire set up works, but then it won’t find nor connect via wireless. It’s as if I would have to leave it in via ethernet forever. 

Oh, so it sounds like the wireless card has died, which is not uncommon with those. Call Support.