Sonos Play:5 disappeared from Sonos system and cannot get it back with Wireless Setup (password incorrect)

  • 14 February 2021
  • 5 replies



My Sonos play:5 device dissapeared overnight from my Sonos system. I also own a play:1 device which operates normally. 

I tried using an Ethernet cable and Play:5 has been brought back. However, with the Ethernet cable connected to the Play:5 I am unable to connect it to the Wifi as the error "Incorrect Password" keeps showing up. (System > Network > Wireless Setup > ‘chosing my home network verification fails with Password incorrect’)

Just to note:

  • I am definitely keying in the correct password.
  • I never changed any settings on my router
  • My router 802.11 mode is mixed 802.11b/g/n

Also tried:

  • Changing my home network router password.
  • Factory reset to my Play:5 as suggested in other topics

Any clues of what to do next?







Best answer by Xander P 15 February 2021, 16:20

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies


Things got even more frustrating…

  • After having used the ethernet cable to bring the device back to Sonos system, I tried some time later once more to connect it to WiFi via System > Network > Wireless Setup.
  • This time the process succeded but my joy did not last. As soon as I removed the ethernet cable from the device, it again dissapeared from Sonos system!
  • After this, I cannot add the device to my Sonos system even if I use the ethernet cable!
  • I tried even a factory reset with no luck…

Almost half of my weekend was lost dealing with this. Result of all efforts is having a nice big polished black brick in my bookcase (ok, there is a green light flashing on it).  


Userlevel 7

Hi @panhal 

I suggest you submit a diagnostic and post the reference ID in this thread. You can wait for a Sonos moderator to respond or call Sonos Tech support. Ruling out wi-fi interference or non-Sonos hardware failure the Play 5 may have a failing Network Interface Card (NIC).

Userlevel 7
Badge +23

What router (hopefully not a newer ASUS) ?

No. It’s a ‘Speedport W724V’ supplied by my carrier.

However, I am on this setup (Sonos system and this router) for ~4 years without issues so far.

Btw, the ethernet port works finally. It seems I used a faulty cable. Now, at least the device is usable with wired setup. But I am back on the ‘password incorrect’ state with no ability to have the speaker working connected to WiFi...



Userlevel 6
Badge +15

Hi @panhal 

Glad you’ve got the Play:5 working on Ethernet for now. As @AjTrek1 mentioned however, it does sound like there may be an issue with the Wireless Card inside the unit - I’d recommend getting in touch with the Support Team via chat or phone so they can take a closer look :)