Sonos Play:1 won't connect after Wifi change

  • 17 March 2023
  • 5 replies

I setup a new router with a changed WiFi Id. I tried to update the network using Sonos 2 app but it couldn't find my speaker. I tried connecting the speaker directly to the router using ethernet and it still can't find the speaker. In the settings menu the System option is greyed out so I can't change the network settings manually! Why is sonos so bad at handling routine changes to the network!! How can I get my speaker connected?


Best answer by Airgetlam 17 March 2023, 19:29

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

If you’ve tried wiring it to your router already, then something’s odd going on, assuming that you were using the S2 app before hand.

If the PLAY:1 had been using the S1 app before, it will need the S1 app to connect to it now, and then you can upgrade it to S2. Then the S2 app will connect to it, and you should be able to change the network settings, and disconnect the temporary ethernet cable. 

I've used it for some time with the S2 app. 

Seems odd, then. Although extremely rare, it’s not impossible for electronic devices such as the PLAY:1 to fail. Have you tried to call Sonos Support directly to discuss it?

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network. 

No I haven't tried calling support, frankly I'm at the end of my patience! Perhaps later…

Thanks for your help.



This is a very late reply but for the benefit of anyone searching for a solution, you'll need an ethernet cable:


My new ISP provided me with a Fritzbox router.  Of course, next time I opened the Sonos S2 app on my Android phone my Sonos Play:1 couldn't be found.

Following the steps to 'Let's fix it' on the app didn't help. It found my speaker and said it would connect to a temporary SONOS network to set it up.  Then it couldn't find the speaker.  A cheery 'Let's try something else' message then hold some buttons down and fail to get the chime and flashing lights I'm supposed to get.  An occasional system error message.  I tried this over and over again, over several days, but the app could never find the speaker - even after telling me that it could see a Play:1 along with the serial number and whatnot. 

As a last resort I factory reset the Sonos and reset the app.  Connected the Play 1 with an ethernet cable to my router and the app found it fine.  Joy!  The next stage - unplugging the ethernet cable and setting it up wireless?  Exactly the same problem as before.  The app can never find the Play 1, even after finding it.  Why on earth is there no way to just enter the WiFi settings manually?!?

But I did.  When I originally set it up using (what's now) the S1 app.


Factory reset the speaker (unplug, wait for a bit, hold down the play/pause button while you plug it back in, and keep it held down until the light flashes white/orange), connect it via an ethernet cable to your router, and set it up as a wired speaker using the S2 app.  

On the S2 app, if I recall correctly, when it asks you to create a new sonos group or add to an existing one, at the bottom there's an option that you can select to downgrade the speaker to S1.  (I'm a little uncertain of that bit - I should really have paid more attention but after spending hours again trying to get the thing set up I was getting a bit jaded).  

Downgrade the speaker and when that's done unplug it from the power and make sure it's connect it to the router.  Wait 10 seconds or so and power it back up.

Download the S1 app and go through the setup procedure there.  When you're finished you should be able to play music on your 'ethernetted' Play 1.  Good so far.

Next, on the S1 app go to System / Network / Wireless Setup.  This is the bit where you chose your WiFi network and enter the WiFi password.  When you've done that the app says that you can disconnect the speaker from the router.  I did that and found that it worked fine on WiFi again.

After that just run the upgrade to S2 following the prompts, and you're back in business.  (Though you will have to set up all your services again from scratch!).

SONOS!  Please fix this.  Your automated WiFi setup on S2 doesn't work for rather a lot of people.  Having a fallback to just entering the WiFi details manually is surely a simple fix?