Answered

Sonos ARC update (today) broke eARC


My Sonos ARC was updated today and since the update the sound cuts out (not small drops, full drop).  The App shows it is receiving a signal and the volume can be raised and lowered.  The problem is nothing is coming out of the speaker.  The TV shows it connected, and the ARC shows a connection.

It is using 80.00.05-release+20240510.78d060b

Not sure what else to do???

 

icon

Best answer by GuitarSuperstar 20 May 2024, 01:21

View original

13 replies

Userlevel 7

Try this:

Disconnect everything from the TV and unplug the Arc and TV from power for a couple of minutes. Plug everything back in but keep everything disconnected. Make sure CEC is enabled in the TV settings. Run TV Setup in the Sonos app and follow the app instructions. When the app instructs you, connect the Arc to the TV’s HDMI ARC/eARC port using the Sonos-supplied HDMI cable. After the Arc has been successfully connected, connect your other devices to the TV.

It has worked perfectly for months now.  Nothing else changed.  It works for about 5 minutes, then the sound drops.  I will give it a whirl when I can kick the kids off the TV.  Thanks!

Re-running the TV Setup seems to have stabilized the system.  The sound is working and hasn’t dropped all day.  Yesterday it would either not be there or drop after a few minutes.

Same issue here. I followed all the steps described in @GuitarSuperstar post, it works for few minutes and then it happens again. So those steps dont work for me. Only workaround is disabling eARC feature on the tv, but I know this would compromise sound quality/Dolby Atmos features (even though the app reports Dolby Atmos audio when I play some Netflix movies).

Please patch the firmware ASAP!

Userlevel 7

Same issue here. I followed all the steps described in @GuitarSuperstar post, it works for few minutes and then it happens again. So those steps dont work for me. Only workaround is disabling eARC feature on the tv, but I know this would compromise sound quality/Dolby Atmos features (even though the app reports Dolby Atmos audio when I play some Netflix movies).

Please patch the firmware ASAP!

Do you have a Samsung TV?

Actually it seems to happens as soon as I watch some TV channels or play YouTube videos. It doesnt happen with Netflix/prime (I didn't test with max/star+/paramount) - both uses more resources-demanding codecs. So can this be related to some particular audio codecs?

Same issue here. I followed all the steps described in @GuitarSuperstar post, it works for few minutes and then it happens again. So those steps dont work for me. Only workaround is disabling eARC feature on the tv, but I know this would compromise sound quality/Dolby Atmos features (even though the app reports Dolby Atmos audio when I play some Netflix movies).

Please patch the firmware ASAP!

Do you have a Samsung TV?

Yes I do. I have 3. I am currently using the ARC+2 ones+gen 3 sub connected to a UN65tu7000. I have 2 frame 75 as well. Tomorrow if I have some free time I will test with one of those.

Userlevel 7

Same issue here. I followed all the steps described in @GuitarSuperstar post, it works for few minutes and then it happens again. So those steps dont work for me. Only workaround is disabling eARC feature on the tv, but I know this would compromise sound quality/Dolby Atmos features (even though the app reports Dolby Atmos audio when I play some Netflix movies).

Please patch the firmware ASAP!

Do you have a Samsung TV?

Yes I do. I have 3. I am currently using the ARC+2 ones+gen 3 sub connected to a UN65tu7000. I have 2 frame 75 as well. Tomorrow if I have some free time I will test with one of those.

Make sure you keep the Digital Output Audio Format setting on the TVs set to Pass-Through, not Auto.

Same issue here. I followed all the steps described in @GuitarSuperstar post, it works for few minutes and then it happens again. So those steps dont work for me. Only workaround is disabling eARC feature on the tv, but I know this would compromise sound quality/Dolby Atmos features (even though the app reports Dolby Atmos audio when I play some Netflix movies).

Please patch the firmware ASAP!

Do you have a Samsung TV?

Yes I do. I have 3. I am currently using the ARC+2 ones+gen 3 sub connected to a UN65tu7000. I have 2 frame 75 as well. Tomorrow if I have some free time I will test with one of those.

Make sure you keep the Digital Output Audio Format setting on the TVs set to Pass-Through, not Auto.

Unfortunately such option is disabled and I can only set auto... Thanks a lot for your help btw!

Userlevel 7

Same issue here. I followed all the steps described in @GuitarSuperstar post, it works for few minutes and then it happens again. So those steps dont work for me. Only workaround is disabling eARC feature on the tv, but I know this would compromise sound quality/Dolby Atmos features (even though the app reports Dolby Atmos audio when I play some Netflix movies).

Please patch the firmware ASAP!

Do you have a Samsung TV?

Yes I do. I have 3. I am currently using the ARC+2 ones+gen 3 sub connected to a UN65tu7000. I have 2 frame 75 as well. Tomorrow if I have some free time I will test with one of those.

Make sure you keep the Digital Output Audio Format setting on the TVs set to Pass-Through, not Auto.

Unfortunately such option is disabled and I can only set auto... Thanks a lot for your help btw!

The Pass-Through option is greyed out if you are only using the TVs native apps. But if this is the case, then you don’t need HDMI-eARC Mode enabled to get Dolby Atmos audio. Enabling eARC is only necessary for some external media devices like an Apple TV 4K or Xbox.

Same issue here. I followed all the steps described in @GuitarSuperstar post, it works for few minutes and then it happens again. So those steps dont work for me. Only workaround is disabling eARC feature on the tv, but I know this would compromise sound quality/Dolby Atmos features (even though the app reports Dolby Atmos audio when I play some Netflix movies).

Please patch the firmware ASAP!

Do you have a Samsung TV?

Yes I do. I have 3. I am currently using the ARC+2 ones+gen 3 sub connected to a UN65tu7000. I have 2 frame 75 as well. Tomorrow if I have some free time I will test with one of those.

Make sure you keep the Digital Output Audio Format setting on the TVs set to Pass-Through, not Auto.

Unfortunately such option is disabled and I can only set auto... Thanks a lot for your help btw!

The Pass-Through option is greyed out if you are only using the TVs native apps. But if this is the case, then you don’t need HDMI-eARC Mode enabled to get Dolby Atmos audio. Enabling eARC is only necessary for some external media devices like an Apple TV 4K or Xbox.

Thank you very much sir! with no doubt you are an authority on this topic.

On my Sony TV, after Sonos update to S2, the eARC was not working. Went through all the troubleshooting tips  and nothing help. Finally after performing a hard reset on the TV the eARC is now working

Same here.

 

Updated because I got a new phone.

eArc broken.

 

Apple tv

Beamer eArc

Arc

 

I followed the instructions. It worked

but very annoying still

Reply