Sonos App Greyed out, Can't connect to my Sonos 1

I have a Sonos Play 1 which I control on my network with my Android phone.

Sonos App is 11.1 which I think is the latest version

Android is 9

Sonos 1 is: Play 1

There are no network changes.


I lost connection to it recently.

I notice in the Sonos App that a number of options are greyed out. These include



Services and Voice

Which means I can't even log in or out.


I reinstalled the I Controller App and factory reset the speaker. When I tried to connect the speaker it wasn't found.

I connected via Ethernet and managed to get it to work with my phone.

However, when I pulled the Ethernet cable out, the speaker was disconnected again and the app greyed out again.


There is also a message across the top of the app which says:

"Unable to connect to Sonos Fixit"


What on earth is happening? 


Best answer by meld51 11 May 2020, 12:47

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

19 replies

Hi. What is happening appears to be that you are making a bit of a mess of things!

You had probably only updated the app or the system rather than both.

But the real mistake was the factory reset. Is this your only Sonos speaker? 

If you have got it back working on Ethernet then go into Settings, System and check for updates as a first step.

Then in the Network settings tap Wireless Setup and follow the prompts.

Thanks, This doesn’t work.

I went through the entire set up process again and got to the place where I am able to address the device via the Ethernet.  At this point you can do the wireless set up, which went OK.

Checked for updates. “No update required”

Also checked the various system parameters:

App Version 11.1


WM 0

Sonos ID 117487126

Build 56076060



Anyhow. I pulled the Ethernet cable out and it can't be seen over the wireless.

I looked at the connected devices on my router and it is not there!


So still unable to access via WIFI


Well I made it work, not sure how. I reset my router, maybe that did it but I’m not sure…


I am having the same issue. Setup works but then options are greyed out and no wifi. 

Same Issue here, this is absolutely unacceptable!!!

Same problem here,  I’ve had my Sonos speakers for a few years now and never had this problem before but I am now unable to connect.   I have manage to get connected again by unplugging the speakers and re plugging them but they eventually end up the same with the app not finding them and me having to unplug and replug them to use the system.  What a pain!!





Userlevel 5
Badge +14


Welcome, thank you for reaching out to Sonos Community, We appreciate your time and effort in posting your concern here in our community.

Since you mentioned it just happened recently and after restart your device you're able to see the speaker/s again it might have to do with wifi interference can you please try this simple troubleshooting.

I’d also be tempted to do a network refresh, by unplugging all Sonos devices, then rebooting the router. When the router comes back up, plug back in the Sonos devices. 

Let us know if it works. If you need help with any other information, please be sure to let us know.

Hi Mark. 

Unpluging and plugging back in is what I do now to the Sonos speakers.  That seems to work however  I don’t think it is reasonable to have to do that everytime I want to listen to my system.   

thanks for your input.   


Most likely the reason is your wifi network and not Sonos. Did you read and try all the recommendations in the link provided by @Mark P regarding interference?

Also, to refresh your network you should do it as described by Mark P, i.e. both router and Sonos and in the correct order.

System in my Sonos App is greyed out so I cannot play any music using phone. But It works when I use my PC? Please advise?

It’s possible that one of the two controllers and speakers have been updated, and the one that is showing grayed out op has not been. Worth double checking from that controller for updates. 

This has recently started happening to my Spotify connect as well. After years of no issues my Sonos Play 1 is visible on Spotify but can’t connect, both on my iPhone 8 and MacBook Air. 

I have so far:

Updated to S2 

Updated Spotify/iOS/Sonos system 

Rebooted router (did this before speaker as seen in other troubleshooting directions)

Rebooted speaker 

Deleted and redownloaded Spotify and S2 app

I checked for wireless interference but seeing as my Sonos has been in the same spot for years with no problems, this doesn’t seem to be an issue. 

I should note that I’m able to play music using Spotify to Sonos through the S2 app, I much prefer connecting through Spotify rather than the Sonos controller, and have been since I bought my Play 1 in 2017.

Please help! Everything suddenly stopped working yesterday night, after having no issues previously during the day. I have a Bell Home Hub 3000 in Ontario Canada.



Diagnostic is 414395841

please help!

Userlevel 6
Badge +15

Hi @ed888, and welcome to the Sonos Community!

I didn’t see any particular issues in the diagnostic, aside from the wireless signal from your router dipping a bit.

Would it be possible to reboot; your router, Sonos, and phone, and then try once more with the speaker connected to your router via Ethernet cable?

Let us know how you get on :)

SOLVED! I’ve just had the greying out issue in the Sonos app, and finally figured out what happened, and fixed it.

I recently changed wi-fi connections to the NBN. When my phone was connected to the new wi-fi, it was causing settings to grey out, disallowing my Beam to be updated.

After many attempts to try and connect the new wi-fi, I re-connected my phone to the old wi-fi (thankfully, still connected), which allowed me to open settings again. I deleted the old wi-fi in Network, and selected the new wi-fi.

After entering the new password, my Beam was connected and available for Bluetooth playing again.

Hope this helps everyone.

Thank you LeighW! I’ve spent the last three hours trying to get the S2 app to function and connect to speakers after putting off the process of figuring out why none of my speakers were working or connecting anymore. Almost everything was greyed out. Switched back to the old wi-fi and now at least I can navigate! 

We have same grey out issue.

What changed was wireless hardware...same said name and password. The ip address network has changed. All other devices in house came back online...with minimal effort of restart or reconnect.


On the Sonos app it does find arc, sub and two sl players. The wizard makes me pick one of the device to configure...when it tries to configure and save it at some point it gives up. I repeat with other devices and same issue.

I did restart arc and sub which would have picked up new Ip address.

We are at a loss. Any advise is appreciated.




Userlevel 7
Badge +17

Did you try to connect the Arc temporarily by cable?

Thanks for replying.

Yes I tried it. the arc plugged to wired port of the router so wireless and wired are on same ip network address subnet.