Answered

ONE SL - Does not reconnect when TV turned back on

  • 24 December 2023
  • 29 replies
  • 237 views

Badge

Hi All,

I read all the posts here including “can’t connect again” and none of them are identical to my question or issue.
 

  1.  My pair of One SLs work fine in connection with my Play 1 and Sub, until …
  1. I turn my TV off (the two SL units always stay turned on as they are on separate electrical outlets/circuits in different parts of the room
  1.  Whenever the TV is turned back on for any watching, the Playbar and Sub connect just fine but the One SLs never reconnect.  Never.
  1.  The only way to resolve this is for me to completely unplug all devices, let the TV sit one minute without electrical power to it, the turn on the TV then the two One SL units right after.  A few minutes later all is synced up and works fine.

One might argue that this is an IP address issue or network issue but it’s not.  It’s consistent every time.  I can sync up all the units just fine if all are unplugged and plugged back in.  But once the TV alone is turned off (only the TV), when it’s turned back on the One SLs will not resync.  
 

seems like a terrible design and I regret purchasing them.  Am I missing something?  If there is a way to resolve this I am all ears.  
 

thanks so much!

icon

Best answer by Airgetlam 25 December 2023, 00:24

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

29 replies

Badge

While they could be incorrect, I am sure that Sonos support indicated multiple times that (pre-boost) the Playbar issues the IP addresses to all the devices.  It is an original Playbar 1, maybe that is why?  in fact, during one communication, they wanted me to hardwire the play bar to see if that solved the issues, but that was not a feasible option for me, and would defeat the purpose of the wireless functionality of the device.
 

this may sound strange, but in essence, when the TV was off the Sonos one SL‘s go into a sort of rest mode or hibernation mode, and the 5 GHz band from the Tri band Router floating around in the airwaves could interfere with the 5 GHz radio of the one SL speakers, and cause them to unsync. The issue never occurred when the TV was on because the play bar was in demand and required to keep up the issuing accurate IP addresses 

 

the diagnostics showed some DHCP anomalies so originally they thought the router might have DHCP turned off but in fact, that was incorrect. The DHCP setting was always turned on from day one so their theory changed. In the end, it became a combination of Playbar struggles and or 5 GHz band airwaves conflicting with the 5 GHz radio when the speakers were in some sort of rest, or hibernation mode
 

 

There are a number of confused and confusing statements above.

Playbars don’t issue IP addresses. A DHCP server does, commonly embedded in a home router. What happens in WiFi mode is that the Playbar is required to proxy the IP address requests from the satellites to the DHCP server. In some routers this causes problems when the requests arrive over WiFi. When a Playbar has a wired connection to the router, either directly or over SonosNet, such issues don’t arise.

The IPs don’t change when in idle mode. What does change is that satellites’ wireless connection to the Playbar switches from 5GHz back to 2.4GHz. As soon as the Playbar starts playing anything again (TV or music) the satellites transition to 5GHz for normal operation. 

The Playbar’s own WiFi connection to the router is always at 2.4GHz.

Badge

Well I am certainly not an expert, but I can say all of the above information that I provided came directly from tier 2 support, and it’s in writing. Granted, it did have to be escalated to an even higher level, and finally reached the highest engineer level, so perhaps tier 2 level was incorrect? The high-level engineer that resolved the issue  stated that the boost is its own network and it will issue all of the IP addresses now.  that appears to be true because all of the hardware devices now show WM0 . At least it’s fixed! Yay! Once again, thanking everyone and wishing everyone a great one

Again, the Boost doesn’t issue the IP addresses. The DHCP server does. 

The Playbar is now talking to the Boost over SonosNet. The Boost is wired to the router. 

The IP requests pass from the satellites to the Playbar, over SonosNet to the Boost, and enter via a wired router port. This is why the router is now happy issuing IPs.