Answered

I am unable to add my Play:1 using the Android Sonos app when my phone is connected to 5GHz

  • 14 March 2024
  • 3 replies
  • 66 views

Badge

I have a local network that has “smart connect”, meaning that the Wi-Fi SSID (and password) is the same for both the 2.4GHz and 5GHz networks. A device, if 5GHz-capable, will connect to the 5GHz Wi-Fi by default.

The problem seems to be that my phone, which is 5GHz-capable, will always connect to the 5GHz network, with no option to alternatively select the 2.4Ghz network.

When this happens, attempting to add a new Play:1 (2.4GHz only) using the Sonos Android app will hang and never complete, I am assuming, due to the fact that my phone is on the 5GHz network.

Disabling “smart connect” and naming the 2.4GHz network differently than the 5GHz network so that I can explicitly connect to that radio will be too disruptive to my IoT devices and everything else in my home that uses Wi-Fi. I do not have access to a device with only a 2.4GHz radio that I can use to configure the speaker either.

Does anyone have any suggestions? Also, when did this become so difficult, Sonos? Why can’t you make the app, running on the same Wi-Fi network, just on the 5GHz radio configure a speaker on the 2.4GHz network?

icon

Best answer by controlav 15 March 2024, 14:30

View original

3 replies

My mobile device is using the 5Ghz band on the local router and both the 2.4GHz and 5Ghz bands have the same (smart) SSID/credentials - I have no issues setting up any device (including Sonos products) on either band - my thoughts are that there is an issue with your router. Maybe consult its user-manual, or speak to the manufacturers customer support desk. The network needs to meet the Sonos System Requirements shown here…

https://support.sonos.com/en-us/article/sonos-system-requirements
 

Userlevel 7
Badge +22

Same here, no problems with 2.4 and 5 GHz inter-operation. I’d suspect your router is not providing a transparent connection between the two bands.

Userlevel 7
Badge +23

You are using a sketchy router which is not working correctly, you need to fix its configuration or get a better one.

 

Reply