Error Code 6 when trying to update Sonos One

  • 30 November 2022
  • 13 replies

My Sonos One speaker fails when updating. Its a 2019 Gen 2 model. 
the unit has a wired connection to home router, and definitely has internet access since Alexa voice assistant is working ok. It stopped playing spotify song requests recently. So I opened the Sonos S2 App and it wont let me do anything except apply the latest update. The update gets to final stage and then fails with an Error code 6 

 I followed all the troubleshooting hints from Sonos support article regarding error updating :
1. Set static IP 
2. Rebooted my router and fiber modem (I have a TP-Link Home Mesh router system )
3. I have powered the unit off/on  multiple times.

I have tried several times to do the update, but it fails every time. 
Have successfully done updates before, I never had an issue. 


Any suggestions how this can be resolved ? 

See attached images.  





Best answer by mberger 3 December 2022, 12:08

View original

13 replies

Userlevel 1
Badge +2



si possible utilisé un smartphone ou une tablette pour les mise a jour.

sinon un reset de l’enceinte et sa réinstallation serais la meilleur solution.




Mod Edit: adding translation from Google Translate




if possible use a smartphone or tablet for updates.

otherwise a reset of the speaker and its reinstallation would be the best solution.



xav7814, thanks for the quick reply. 
I already tried several times on both Android app and Windows app (S2 version for both)
I get same error. 

Worried that if I do a reset it will stop working completely. (At least now I have alexa digital assistant ) ...

Userlevel 1
Badge +2
frankly it's been since the beginning of sonos that I sell these products and provide their 99% of cases the reset fixes a lot of problems.this allows you to really check if it is a breakdown of the speaker or not.but in your case I recommend the resetCordially

Thanks, xav7814, I am going to hit the reset. configuration only a 15-30 min job so not too bad. 
FYI, just finished a chat with Sonos tech support , they say Error Code 6 is usually for beta versions only.  They asked if I am a beta tester which I am not. so they are also saying I should reset.  will let you know if that fixes it. 

After the reset, the update still fails:
Reset the device. went from flashing orange to flashing green. my mobile app found the new device and immediately told me it needed an update. it applied the update and I got the same error. 

I cant continue to configure it until the update is done. the App wont let me proceed. So now my Sonos One is total non-functional!!





Userlevel 1
Badge +2


have you also reset the sonos S2 application see the uninstall of the smartphone? in this case if SONOS tells you that you are in beta in this case uninstall the app reset the speaker again, install the app via play store or app store. and redo the install one last time. if it happens again, contact sonos support again

I installed the app on an Ipad. It found my Sonos (existing system, not a new setup) and then asked me to log into my sonos account. it then took me directly to the update procedure again. The update ran and failed. Same error code 6. 

Am now on my 3rd chat with Customer service!

Puzzling. You’re probably more likely to get data directly from Sonos, after submitting a diagnostic, but there is one thing that causes thought. You say this device is wired, and state that it is to the ‘home router’. Is that the TP-Link, or the fiber modem? Are both devices serving DHCP information, perchance?

The config of my home network as follows: 
Fiber Modem <=> TP-Link Deco 60 router (master) <=> TPlink 8-port dumb gigabit switch <=> Sonos One  (all these are wired connections) 
I then have 2 TP-Link Deco ‘slave’ units which extend my wifi mesh network. these are not connected by wired and I have double checked none of them work as routers, only the master unit works as a router. 
There are no other routers or devices on the network serving DHCP info. 
I also tried connecting the Sonos One directly to the TP Link Deco Router (only has one port for Lan connections ) , and then tried to update it. same result. 
I have some basic networking knowledge , been working in IT for 25 years. I am pretty sure the home network is fine. The Alexa assistant on Sonos One was working fine up till the reset I did earlier today. I could ask it the weather tomorrow and it could answer, so it was definitely online. 


However after the Reset it has stopped working completely. I cant apply the update it keeps failing with Eror code 6 (tried from multiple mobile devices). 


OK, not everyone has as much knowledge as you, and I was concerned about a potential double NAT or invalid IP address from the wrong DHCP server, but that seems to be under your knowledge and control. 

And you’ve done the test that I would have thought would have addressed it, by connecting the One directly to the TP-Link…

Oh...something that tickles my memory a bit, but I’m unsure about. Have you checked your DNS settings on your router? I’d at the least, change it temporarily to (Google’s DNS data) to see if that makes any difference. Change it back to what you have normally if it doesn’t. I’m shooting in the dark, and since I don’t have anything else to offer, will need to sit back and watch this thread, in the hopes of learning something.

Hi Bruce,

DNS issue was something I never considered, but just in case I did try set routers primary dns server to  The update failed again, but at least we checked that off the list so we know its not dns l. 

I spoke to Sonos support again via their chat (3rd time that day) and they say are unable to help me and asked me to call the support hotline and quote my support ticket #, they will arrange remote access to see for themselves. I guess they do this because many home users will miss something obvious which supprt will pick up when accessing remotely. I'm pretty confident they wont find anything that's been missed on my side and then go back to drawing board and finally escalate to a senipr support person to take a deep dive into the diagnostics report. 

My suspicion is that somehow my account or my device has been flagged as a beta tester and they are trying to push a a beta version to my device. online tech support people said  error code 6 is only related to Beta testers.

Will ask them to check again that I am not a beta tester (i have never signed up as far as I can recall).



I’ll keep watching this thread to see what I missed. It really isn’t supposed to be this hard. 

Good luck!

Finally figured it out! 😄

I removed the wired connection, reset the Sonos One device and ran through the setup again on the app. This time it asked me to press the button on the back of the speaker which never asked me to do with the wired connection. Following that the setup completed and the upgrade downloaded and applied successfully. 

Summary: to resolve error code 6 when updating a Sonos One device from a wired connection, remove the wired connection, reset the Sonos and use the app to find  your sonos as a wireless device. Then run the update. 


I also figured out how to fix Spotify which had stopped playing via Alexa. Need to first go into to Spotify mobile app and set it as default player for Alexa. Spotify then opens the Alexa mobile app which then  shows the spotify 'skill' as linked and you then set spotify as default music service.   Heres the thread for this fix :