Constant problems with a Play 1

  • 1 March 2021
  • 6 replies

I’ve been using Sonos for 10+ years. However the product has gone downhill lately. Currently, I’m having problems with a specific Play 1. It constantly keeps having an issue and then causing music to stop in all the zones. When I try to restart the music or even remove the Kitchen from the group, the controller says “Unable to connect to Sonos product”

Any idea what is causing this?

No updates recently

No changes to system setup

Tried rebooting but it keeps happening

Usually comes back online after 5 minutes or so



This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Perhaps see if this helps to improve things for you…

  1. Set the main routers 2.4Ghz WiFi channel to ‘fixed’ channel 1, 6 or 11 and set the channel-width to 20MHz
  2. Only if the above doesn’t help, then Wire just one Sonos device direct to your router. Then go into the Sonos App and do the following two things:
  • Goto “Settings/System/Network” and set the SonosNet channel so that it is at least 5 channels away from your chosen router channel in Step 1 above.
  • Whilst in the Network Settings in the Sonos App, goto ‘Wireless Setup’ and reset/remove your routers WiFi credentials, as these are not required when running your system with one Sonos device wired to the router.

See if that then improves your Sonos connectivity - if not, go back and try a different Router-WiFi/SonosNet channel, but if using SonosNet always keep the two at least 5 channels apart.

If issue still then keeps occurring with just the one device, then just try moving it closer to the router temporarily to see if it still then has the same issue, whilst set in a different location.

I still don’t understand what could be happening. I listen to music all day. This has happened to this same Play 1 today 7 times. It eventually comes back on without me doing anything. Is there anything is the logs that would help debug this?


Userlevel 7

Have you tried any of the suggestions from @Ken_Griffiths?

I’m using a Google Nest Wifi router and couldn’t find a selection to fix the channel. That prevents me from do either one of the suggestions. This has been working perfectly for multiple years, just started happening yesterday for no logical reason.

Userlevel 7

Have you tried rebooting your router? If all else fails, you could try resetting the Play:1 by following these instructions:

Thanks, I will try a factory reset on that one speaker