can not link the device


I installed the new play 3 device and connected it to wifi

now linking the device

on device white light is on

requests : password for my account

playing sound on device : now linking

msg : there was a problem linking your play 3 to your account

if i open the app in system : I do not see wifi connected although pw was entered

pressing network : let’s finish adding you play 3 to your system

same scenario and message

please advice

best regards, Guy


Best answer by przytula 5 June 2023, 15:54

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies


in sonos system info i see

play 3 kitchen


serial nbr B8-E9-37-D5-F4-CE:4

sonos os s2

version 15..4 build 773041050

hardware version

series id A100

ip address :

WM : 1


Sounds like an incompatibility issue with your 2.4Ghz WiFi signal and security mode.. ensure the router meets the Sonos system requirements stated here for the wireless network:

Supported WiFi modes and security standards

All Sonos products can connect to wireless routers or access points that support 802.11b/g WiFi over 2.4GHz. Additionally, all Sonos products can connect to WiFi networks that use WPA1 and WPA2 Personal security standards, as well as unsecured WiFi networks.


I had one ssid for 2.4 and 5G wifi

now disabled this and have different ssid for both

I can see the sonos is connected to router on 2.4G

the security is set to wpa2 in the router

from my pc I can ping the sonos box on indicated ip

restarted the sonos and try to link : same msg

best regards, Guy


the mode for the 2.4G is or

802.11 gn


802.11 g

currently it is 802.11 gn


I also tested to set to 802.11 g

reset of sonos and link : same msg

Userlevel 7
Badge +19

To try to get things running, can you attach an Ethernet cable temporarily? Once it’s on the network and running in your system properly, then sort the wifi link (if it doesn’t resolve when connected for a few minutes). 


connected ethernet directly to router

same scenario : sound-press 2 buttons- linking to account : same error msg

best regards, Guy


i also tried on phone to link - same problem

best regards, Guy

Userlevel 7
Badge +17

Maybe it’s time to contact Sonos to have them take a look at this.


yes, monday at 10am they are available, I will call

The device received a software update, so internet connection is ok.

I also installed the app on IOS device and same msg

many thanks for all info

best regards, Guy


sonos contact

device factory reset - app reset - account reset

restart installation/connections..

now all ok

many thanks for all answers

best regards, Guy