Answered

access point mode on router not working on sonos one.

  • 15 December 2022
  • 30 replies
  • 1109 views

Userlevel 1
Badge +2

I have been battling this issue now for almost a year. I have 2 routers. The primary router is where the internet comes into my house. From there, I have an Ethernet cable that runs approximately 125 feet into my garage and connects to another router (R6900v2). I have problems with my Sonos speakers dropping connection in my garage. In my opinion they are trying to grab the signal from the primary router in the house. I have contacted Sonos, my ISP, and Netgear. No one seems to help. Sonos says put the garage router in Bridge mode. I have tried, but am not tech savvy enough to trouble shoot. When I’m bridge mode, I can not access internet. The last time I asked the Netgear community, I was told to run in access point mode. I have asked a few different techs at NETGEAR.  They confirm to put router in access point.  This does not work either. My speakers play for about 20-30 minutes and then drop. My ISP is no help at all. Can someone please help?!?!?  

icon

Best answer by Ken_Griffiths 20 December 2022, 21:35

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

30 replies

Userlevel 7
Badge +18

Hi @jellikit 

Thanks for your post!

Sorry to hear you’ve been fighting this for so long! I’ll see what I can do to help.

First of all, Bridge mode and Access Point mode are roughly the same thing - Bridge mode (or wireless bridge mode, as Netgear call it) will use WiFi as the backhaul to your internet connection, Access Point mode will use the ethernet cable instead. It is very important that one of these modes is used - if not, you are creating a separate network, isolated from the first. One thing you will need to make sure of is that the ethernet cable going to the second router should be plugged into it’s Internet/WAN port, not one of the standard ports.

Your system is using SonosNet - this means that if the Garage speaker can pick SonosNet up, it will prefer it over any WiFi connection. It sounds like this isn’t likely due to the distance and the Garage speaker will need to connect to WiFi.

It looks like at least part of the problem was that the Garage speaker was not set up as part of your existing system, but was in fact forming a new system of it’s own. You’ve already fixed that, which is good.

You say the speakers play for 20-30 min? Please submit a support diagnostic while they are playing and report the given number here. I’m not sure if “and then drop” just means they stop playing or if they disappear from the app, but please submit another diagnostic at this point too. Thanks.

 

 

Userlevel 1
Badge +2

Corey-

 

Thank you for taking the time to help.  
 

yes, the Ethernet cable is connected to the WAN port on the secondary router.  
 

the garage speaker is running Wi-Fi from the garage router.  But, there is a weak signal coming from the primary router in the house.  Can this be the issue?  
 

I spent 2 hours on the phone with Sonos.  I believe they set up the garage speaker separately.  But, when I open the primary router settings, the MAC address for the garage speaker is listed in those settings.  Not sure if this is because of the access point mode of the garage router or not?

when the garage speaker “drops out”, it quits working.  Then the light flashes white.  But it is a brighter, stronger flash as compared to when you reboot the speaker.

I submitted diagnostics.  Here is the number 1523545283

 

do I need to provide any information?

 

your help is greatly appreciated!

 

thank you


 

Corey-

 

Thank you for taking the time to help.  
 

yes, the Ethernet cable is connected to the WAN port on the secondary router.  
 

the garage speaker is running Wi-Fi from the garage router.  But, there is a weak signal coming from the primary router in the house.  Can this be the issue?  
 

I spent 2 hours on the phone with Sonos.  I believe they set up the garage speaker separately.  But, when I open the primary router settings, the MAC address for the garage speaker is listed in those settings.  Not sure if this is because of the access point mode of the garage router or not?

when the garage speaker “drops out”, it quits working.  Then the light flashes white.  But it is a brighter, stronger flash as compared to when you reboot the speaker.

I submitted diagnostics.  Here is the number 1523545283

 

do I need to provide any information?

 

your help is greatly appreciated!

 

thank you

 

Can’t you simply use the routers MAC address filtering feature to get your products onto the required access point, so that all in the garage are using the nearby router etc.

I would just ensure too that both routers are broadcasting the same subnet with identical WiFi SSID/credentials, channels and channel-width (20Mhz only is recommended for the 2.4Ghz band).

By the way I can’t personally see how both routers can be on the same local subnet if using the WAN port unless the router specifically has a ‘bridge mode’ setting that turns that into a LAN port for ‘switching’ purposes, but definitely keep both devices (AP’s) so that they use the same LAN subnet, rather than using double NAT.

Userlevel 1
Badge +2

This is where it goes over my head…….

do you recommend I call Sonos and pass this along to them so they can walk me through? I have literally talked to 5 -6 

different techs and none of them have suggested this.  I do appreciate your help, but do not know how to set this up…….

Userlevel 7
Badge +18

Hi @jellikit 

Thanks for the diagnostic. Your Garage speaker is connecting to SonosNet via the Kitchen speaker, and therefore ignoring available WiFi alternatives. As far as the speaker is concerned, the settings of the second router (and the fact that it exists at all) is irrelevant. The Sonos app may see things differently when you are in that area, however - to it, the second router may well be important. If the Sonos app can connect to your Sonos system while your phone is on the second router’s WiFi, all is working well.

As for the Garage speaker, I can only really recommend trying to shorten an imagined straight line between the Garage and Kitchen speakers. If you can try to also shorten the amount of that line that is going through a wall, that would also help (a signal going at right-angles to a wall has less matter to penetrate than one approaching at a shallow angle).

I would also recommend checking the Kitchen speaker’s location for any sources of interference or signal blocking (thick materials, especially metal).

Moreover, your Sonos system does not know any WiFi passwords, so even if the Garage speaker could not connect to SonosNet, it wouldn’t know how to connect to either router. An option you have, therefore, is to give the Sonos system the credentials to get on to your WiFi (both, if the routers have different credentials - the first router first, then the second. I recommend having the same credentials for each), then disconnect the ethernet cable going to the Playbar. This will put all your Sonos devices on WiFi, and the Garage speaker should connect to the second router’s WiFi with a better signal strength that is currently found on SonosNet.

  1. Open the Sonos S2 app for iOS or Android.
  2. From the Settings tab, press System > Network > Manage Networks.
  3. Press Update Networks and follow the prompts to connect Sonos to your Wi-Fi network.
  4. Once the wireless setup is complete, disconnect the Ethernet cable from any Sonos products wired to your router.

I hope this helps.

Userlevel 1
Badge +2

I appreciate all of the information.

so…….just to make sure I fully understand:

 

I can not move my kitchen speaker any closer to the garage, nor can I move either speaker to improve the angle of transmission.  So, I need to get the garage speaker to connect to the second router, which is in the garage, correct?

In order to do this, I need to give both routers the same credentials.  Does this mean the same SSID and password for the garage router?  What other credentials do I need to duplicate?

 

Then, disconnect Ethernet cable from the play bar, and finally follow the directions you gave for updating the network?

 

Lastly, if both routers have the same credentials, and garage is an access point, after updating the network the Sonos app should work seamlessly for the house and garage systems?

Userlevel 7
Badge +18

Hi @jellikit 

So, I need to get the garage speaker to connect to the second router, which is in the garage, correct?

Yes - from your response, it sounds like it.

 

In order to do this, I need to give both routers the same credentials.  Does this mean the same SSID and password for the garage router?  What other credentials do I need to duplicate?

These are what I refer to as credentials - hopefully, you won’t need to adjust other settings. So, yes - keep the SSID and password the same across the two routers.

Then, disconnect Ethernet cable from the play bar, and finally follow the directions you gave for updating the network?

You’ll want to keep the ethernet cable connected until the Sonos system has been told the WiFi credentials - the app will in fact tell you when to remove the ethernet cable. Please follow the instructions at Connect Sonos to a new router or Wi-Fi network.

Lastly, if both routers have the same credentials, and garage is an access point, after updating the network the Sonos app should work seamlessly for the house and garage systems?

Yes, though they are not, nor will they be, separate systems. Expect to see all your speakers in the app at one time as you do now (when Garage isn’t misbehaving), regardless of which router your phone is connected to.

I hope this helps.

 

 

Userlevel 1
Badge +2

I will try it for a day or two and let you know.  Thanks again!

Userlevel 1
Badge +2

I did everything you suggested.  Music plays in garage from anywhere from 10 minutes to two hours, then stops.  Speaker then flashes a slow, bright white flash.

 

I ran another diagnostic.  Here is the number. 460693807

I did everything you suggested.  Music plays in garage from anywhere from 10 minutes to two hours, then stops.  Speaker then flashes a slow, bright white flash.

 

I ran another diagnostic.  Here is the number. 460693807

Do you perhaps have QoS, or ‘Airtime fairness’ enabled on your router? If so, try disabling those features. If not done already, set the 2.4 GHz band to use either channel 1, 6 or 11 and set a channel-width of 20Mhz only. The settings should be the same for both AP’s as they are presumably using the same subnet.

Userlevel 1
Badge +2

Airtime fairness is not turned enabled on either router.  The channels were set to 4.  I changed both to 11.  The garage router was set to run on 20 ghz and 40 ghz.  I changed that to 20 ghz only.  
 

will try again and let you know if this works. 
 

thank you so much for your help.  This has been a year in the making!

 

Userlevel 7
Badge +18

Hi @jellikit 

The Garage is missing from that diagnostic, unfortunately, so I can’t see what happened to it.

It does sound like it lost connection momentarily - I can see it is online right now. So, @Ken_Griffiths’ advice fits very well!

If it happens again, please wait until the Garage has stopped flashing it’s light and the speaker responds in the app (try changing the volume or playing again) before submitting a diagnostic. Thanks.

Userlevel 1
Badge +2

Corry P and Ken_Griffiths, you solved my problem.  Seems to be working great.  Thank you so much for the help!  It has been quite the process.  I have literally struggled with this for quite some time…..back and forth between the router manufacturer to the speaker manufacturer, to the ISP.  I just needed to talk to the right people.

 

thank you again…….

Userlevel 7
Badge +18

Hi @jellikit 

Glad to hear you’ve got it fixed - thanks for updating the thread!

And you are very welcome!

Userlevel 1
Badge +2

Well.  My system worked for a couple of days.  Now the garage speaker only plays for about 5 seconds.  🙄
 

here is the latest diagnostic. 352807248

Userlevel 7
Badge +18

Hi @jellikit 

Well, that’s disappointing!

The Garage speaker is reporting that it has not lost it’s connection to the garage router once in 5 days. The other speakers are reporting lost AP (Access Point) connections, however. 

What exactly is happening when the Garage speaker stops playing? Is it part of a group? If so, please test the speaker on it’s own to evaluate it properly - grouping brings other rooms (and another router) into the equation, and I’d prefer to know if the garage speaker performs okay on it’s own. Are you using AirPlay? If so, please test with another source - as AirPlay is also dependant on the source’s connection, it’s not the best way to test the Garage speaker, specifically. An online source would be ideal.

Please also submit a diagnostic when everything seems to be going well - I’d like to see one without speakers missing! Thanks.

Userlevel 1
Badge +2

Yes……I was trying to airplay from my iPad to the garage speaker while in the garage.  Does this mean my iPad wasn’t actually connected to the garage Wi-Fi?  It had full reception while trying to do this.  Right now I am playing an internet station to only the garage speaker.  It seems to be working fine.  Here is the diagnostic number. 453937846
 

Here is the diagnostic with all speakers running on same internet station. 743893169 

 

I am in the house giving you this info.  Do I need to be doing something different?

Userlevel 7
Badge +18

Hi @jellikit 

Yes……I was trying to airplay from my iPad to the garage speaker while in the garage.  Does this mean my iPad wasn’t actually connected to the garage Wi-Fi?  It had full reception while trying to do this.

That would be my best guess. If internet music plays without issue and AirPlay does not, I would look to the iPad’s connection. Perhaps toggle the iPad’s WiFi off and on again when going into the garage to ensure it’s connecting to the close-by router. I can’t confirm in 453937846 which AP the iPad was connected to, but in 743893169 it was connected to the main router. I’m assuming you don’t carry your iPad around when it’s AirPlay-ing, but just in case you do, AirPlay would probably be “happier” if the iPad were to stay relatively still (though there doesn’t seem to be much interference in the Garage, unsurprisingly, so perhaps not). Technically, it should not matter which router your iPad is connected to - other than with the quality of the signal, that is.

It may also help just to reboot the router in the garage by switching it off for at least 30 seconds.

 

Incidentally, the other speakers are not reporting any more disconnects - I think what I saw before must have been to one of the router’s rebooting. There was some kind of event I am seeing residues of that happened 14-15 hours before you submitted 453937846, but it looks like it was a one-off.

I am in the house giving you this info.  Do I need to be doing something different?

If, when grouping, you experience issues, try putting different rooms in change of the group (selected first) - this can make a huge difference to how things perform.

Incidentally, but importantly, you really don’t want to have any WiFi-enabled devices within 1m of either router - including anything that has “hub” in it’s description. WiFi devices closer than 1m to each other will interfere and I’ll see little sign of it in the diagnostics. This could go some way to explaining the AirPlay issue.

I hope this helps.

 

Userlevel 1
Badge +2

Thank you so much for the help and advice.  I truly appreciate it.  

Userlevel 1
Badge +2

Actually,  could you please explain further your suggestion:

“If, when grouping, you experience issues, try putting different rooms in change of the group (selected first) - this can make a huge difference to how things perform.”

 

The Master Bathroom, and garage speaker are the only two that are in separate areas from the other speakers.

 

Thanks!

Userlevel 7
Badge +18

Hi @jellikit 

When you group rooms to play together, the first room selected (before grouping is performed) is designated the Group Co-ordinator (GC) and is responsible for fetching the music stream from the source, whatever it may be. Once it has the stream, the speaker buffers it and prepares it for synchronised playback. The stream, along with sync info, is then distributed to the other rooms in the group - this results in the GC utilising a lot more bandwidth than a speaker playing on it’s own, and the entire group’s playback performance relies on the GC’s connection. Therefore, the choice of which device is put in charge of a group can be an important one.

I would avoid putting Garage in charge of groups due to the fact that all the other rooms are relatively close together so direct communication from speaker to speaker (avoiding the router) will be more reliable, and I would also avoid putting TV Playbar in charge of a group due to it always using slower 2.4GHz WiFi, as opposed to the 5GHz WiFi that all the other devices are using. Having said this, your system now looks in fairly good health, so unless you are grouping every room in, it probably won’t make much difference which speaker is doing the leg-work.

Going back to AirPlay, a garage is typically a place with a lot of metal in it - the iPad may be struggling in a particular spot, or only when someone walks past it, for example. And, contrary to dismayingly common thought, right next to a router is not a good place to get a strong signal for a device. I recommend more testing of online sources so you can gain confidence that any subsequent interruptions are due to the iPad’s connection. Finally, it may not actually be the iPad’s connection, but it’s CPU usage or background services that could be the source of interruptions - try rebooting the iPad, or test with another Apple device.

Again, you are most welcome, and I hope this helps.

Userlevel 1
Badge +2

Thanks!

Userlevel 1
Badge +2

Corry…….or any other Tech Wizards (See thread please)

You gave me some help a month or two ago. What you did seemed to help until today.

my garage speaker is acting up again.

I checked all settings on both routers, and all credentials are the same.

I made sure all software on all devices were updated.

I reset both routers, all Sonos Speakers, and phone.

 

My Garage speaker plays anywhere from 5 seconds to 10 minutes.

 

Here is the diagnostics from when the speaker just quit:

2137363955
 

Here is the diagnostic while system is playing:

2093436052

 

Please help.  Please.  I just want my system to work properly before I go buy a different brand of speakers……

 

thanks!

Userlevel 7
Badge +18

Hi @jellikit 

I’m sorry to hear that you’re still having issues with this speaker!

The diagnostic indicates that the speaker was only on for 1 minute prior to the diagnostic being submitted - this means that the reason the Garage speaker cut out is because it was rebooting. As to why it was rebooting, that’s harder to discern. Certainly worth checking is that the power to the speaker is reliable - all plugs fully in sockets, no damaged cables, etc. Perhaps there’s another power socket you can try?

The next time it happens, please immediately check the speaker’s light - if it is flashing white, then it is rebooting.

You could try swapping the Master Bathroom and Garage speakers around - if there is an issue with the speaker itself, then the issue will follow the speaker. If it is related to the location, the issue will stay in the Garage.

I hope this helps.