sonos roam

  • 26 December 2021
  • 5 replies

I have just tried to set up my sonos roam, I have play one speakers in the rest of the house. It immediately asked for me to run an update which wouldnt run, there were no internet issues. eventually the device was not showing on the app at all.

Error code 30 came up and we did everything to over come this via install app and chat bot but nothing worked. 

can anyone help?


5 replies

Error 30 is a failure to download the update file. 

Roam requires S2. Has your system been updated from S1 to S2?

Hi thanks so much for the reply, yes its updated to S2

Are any of your other speakers wired to the network, or is everything wireless?

You could try temporarily moving the Roam close to your router and checking for system updates (Settings->System->System Updates).

If it doesn’t show up in the controller app power it off by pressing and holding the power button for 5+ seconds. You should hear a chime as it shuts down. Then restart it by pushing the power button again.

hi Ratty 

thanks, we have tried moving near to the router, all the other speakers are wireless. We have also shut it down and restarted. 


I’d suggest you factory reset ( just the Roam. Restart your controller app and have another go at setting it up. 

Make sure your phone/tablet is connected to the same WiFi as the rest of the Sonos system.