Sonos Play:5 and a disappearing line-in signal, a mystery'

  • 24 December 2022
  • 3 replies

Wonder if anyone can help out here.
I am sending a signal from the Google Home speaker to a group of Sonos speakers via a Chromecast Audio going into the line-in of the Sonos Play:5 speaker. Since some time now the line-in signal would mysteriously disappearBoth Chromecast and Sonos claim the signal is going through but no audio is heard on the Sonos Play:5 speaker. If I reboot the Play:5, the signal returns back, but then it will disappear again after a week or two.
I don't quite know what to do here and how to troubleshoot this


Best answer by Airgetlam 25 December 2022, 00:25

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Not 100% sure, but it could be a duplicate IP address issue causing the Sonos speaker to disconnect from your router. At the least, I’d recommend a network refresh, by unplugging your Sonos devices from power, and rebooting your router. Give the router a couple of minutes to reboot before plugging back in your Sonos devices. And of course before testing, give your Sonos devices a couple of minutes to reboot and reconnect. 

However, if this doesn’t fix the issue, I would recommend that you submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.


Maybe try some, or all, of these things mentioned below..

  1. Goto the Play:5 line-in settings in ‘Settings/System/[Play:5 room name] and set the source name to ‘Airplay device’ once chosen you can rename it to Chromecast or a name of your own choosing. This will increase the buffer size.
  2. Next goto the ‘Audio Delay’ feature and set this to ‘max’ 
  3. Finally goto ‘Settings/System/Audio Compression’ and set it to ‘compressed’ 

See if any, or all, of the above three suggestions help to stop the line-in audio dropouts.

Thanks for these ideas.

I forgot to mention that, while the line-in signal stalls, I am still able to broadcast to the Sonos Play:5 speaker via the Chromecast protocol, i.e. the speaker is also connected via the Google home app. So, I know the speaker is still connected to my wifi network and is properly recognized.

I will, however, send a diagnostics report, as recommended, and see if this gets me anywhere with Sonos support.

Thanks a lot!