Sonos and BT smart hub 2 the fix

  • 4 December 2022
  • 1 reply
  • 252 views

If you wish to know why your Sonos sound system keeps losing connection with your BT hub 2 The answer is pretty simple? How do I know. I tried every single possible configuration in order to resolve, with no effect, until I began to replace everything.

I decided to purchased brand new Sonos SL play speakers at great expense, as mine were a few years old. Guess what! I had exactly the same connection issues.


I disabled the 5ghz Wi-Fi frequency on the original BT Hub 2 router and  consequently my Sonos speakers started working. Not exactly an ideal solution but still a bit flakey

I then bought a new unused BT hub 2 router on eBay. Updated the firmware to  v0.31.00.10253-BT

Once setup, everything worked perfectly. No wi-fi or Sonos issues. Even with the 5ghz band enabled no wi-fin issues whatsoever.

Plugged in my old BT hub2 . Yep most things worked as normal, but Sonos again started to dropped out. Swapped back to the new hub and then all fine,

I can only deduce that BT hubs have an inherent design fault . It would seem that he 5ghz chipset causes problems either through gradual electronic failure or software updates.

The fact remains, the only way I was able to resolve, was by replacing the detective BT router.

I hope this information helps.


1 reply

Userlevel 7
Badge +22

BT routers have always had a bad rap for Sonos compatibility, eg

https://support.sonos.com/en-us/article/bt-homehub-3-compatibility

Reply