Sonos affected by Wireless Access Point hardware change

  • 21 August 2020
  • 62 replies

I recently swapped out my 2011 access point in my bedroom used for WiFi there, and I am seeing some Sonos anomalies.

In the bedroom I have a Boost that is also root bridge, wired back to the main router in the common area, that has a Connect Amp also wired back to the same main router. I was using Airport Express in the bedroom, ethernet wire connected to the other ethernet jack on the Boost using the switch feature on Boost, to successfully obtain high speed WiFi in the bedroom - with the single band AEX set to work in access point mode, creating a 5 GHz network there. No issues with Sonos then, using either the phone or the Mac in the bedroom for control.

I replaced said AEX using a dual band TP Link access point as a drop in replacement. Now, at times, the Connect Amp disappears from the Controller as well as from the Matrix. Getting it to reappear needs a Connect Amp reboot, that works for some time.

I can’t see any logical reason for this - and when I brought the AEX back for a test, the problem disappeared.

Any reason why Sonos/TP Link are not playing nice all the time? The bedroom Sonos is supplied wirelessly from Boost, and there is no issue with that unit. Nor are other bedroom units like Firestick/Echo Show affected by the change.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

62 replies

And a perhaps related question: Invoking the matrix - now and earlier - sees wildly fluctuating response times: as low as less than a second to even a minute, or even no response at times. Why does that happen?

Userlevel 4
Badge +14

When invoking the matrix, it calls all players and asks for a snapshot of the current signal state. If one of the players have a poor connection, this page will take longer to load. 

Which TP-link access point did install?

Is that access point hard-wired to the Boost? 

Are they in close proximity with each other?

Does your Connect:AMP show no green box against the Boost in your network diagram (meaning, it is actually using the wired link?)


Since the Connect:AMP is wired, wireless interference shouldn’t show this behavior, but you need to verify that it is actually using the hard-wired link.

The TP Link RE 205, configured to work in access point mode.

It is wired to the boost and is therefore effectively also wired back to the main router. 

Distance between the two is 6 feet.

Connect Amp shows no box to show any wireless connection to the Boost - it is therefore using the wired link.

And as stated, the issue of the Connect Amp disappearing was not there for the Airport Express for which the TP Link is a drop in replacement - electrically and physically.

Userlevel 4
Badge +14

Ok. I have used that repeater (in repeat mode) and it had some strange issues for me. But, in access point mode it might fare better (i had trouble with the wireless link between the router and the extender).

Some worthy notes though:

The default IP for that device is, make sure that is not conflicting with any of your devices (mainly the Connect:AMP). Configure the extender to get ip via DHCP if not already. Even so, I think it defaults back to said address if it doesn’t get an IP from DHCP.

This device also has a builtin DHCP-server. This is odd both from a range extender point if view, but as an access point equally weird. It is on by default apparently, and needs to be shut off. It has some auto setting which I assume would identify if there is another dhcp server on the network, but I wouldn’t trust it. The only sensible setting here should be Off. 

Where is the Connect:AMP and the Boost connected? To a switch? 

The TP link itself worked flawlessly from the start, but I only used in in AP mode - so no issues in any wireless back connections to the router since I never even investigated that aspect.

I have set a reserved IP address for it in the Apple Time Capsule router, as I had for the Airport Express that it replaced. Tp Link is now picking up that address every time. The Connect Amp has its own reserved address, as do all my Sonos components.

Connect Amp is connected to a switch, while the Boost is connected to the router. The switch is connected to the router, so in effect, both are connected by wire to the core network. 

The strange thing is why all of the above was/is not an issue with the AEX. 

I will investigate the DHCP server thing and revert.


Userlevel 4
Badge +14

Obviously the culprit here is the TP-Link device, which for unknown reasons are hampering the network connectivity for your Connect:AMP.

Try moving the TP-link device (connect it directly to the router, and then via the same switch as your Connect:AMP) and see if the problem still occurs. Another test that might tell something would be to daisy chain the TP-Link into the Connect:AMP.

If the TP-Link is doing something odd with ARP discovery and confuses the router and the switches about the path to your Connect:AMP, I would expect everything to work if it is daisy-chained with the Connect:AMP. If that is the case, I would return it immediately :)


This device also has a builtin DHCP-server. This is odd both from a range extender point if view, but as an access point equally weird. It is on by default apparently, and needs to be shut off. It has some auto setting which I assume would identify if there is another dhcp server on the network, but I wouldn’t trust it. The only sensible setting here should be Off. 

Screenshot shows that server is off; I don’t remember what it was set to before I reserved the 10.0.*.** address in my router for the TP, but it seems to be in the right state now. 


**Moderator Note: Please censor personal information when posting.**

Userlevel 4
Badge +14

It looks like it is in the “Auto” setting, but decides that it should be off. Not sure when it might re-evaluate that decision, and personally I would set it to permanent “Off” just to be safe. I can’t see any situation where you would want it to act as a DHCP server (unless you deliberately want that). 

The words Auto Off are not clickable unlike others that have settings/information attached to them; I tried to do just that!

The words Auto Off are not clickable unlike others that have settings/information attached to them; I tried to do just that!

It’s in the Network section.

However, in my experience -- albeit with a different TP-Link extender/AP -- disabling the DHCP server also disabled the DHCP client. I just set the IP to static.

Userlevel 4
Badge +14

Seems like they removed that possibility in the v3 hardware, in v2 it was part of the settings:

See section 3.4

Also found some people that actually had DHCP trouble on their forum:


Ah yes, I have a couple of RE2xx devices -- not in use -- and that rings a bell. 


Also found some people that actually had DHCP trouble on their forum:



I have found a workaround of sorts. I have moved the RE 205 to replace another AEX access point in my son’s room, where there is no Sonos, and moved that AEX to my bedroom where there is Sonos and Firestick/Macbook. 

All is now working fine in both rooms. 

A question: if I need to replace this AEX in future, what are recommended replacements that will be a drop in such that Sonos will not be affected? All I need is a AP that can be fed by the second port of a connected to main network via wire Sonos unit, such that WiFi signals in the room are 5 GHz and stable/fast.

That is what the AEX is doing, set up in access point mode.

I’ve had mixed results with the TP-Link RE2xx units (which is why they’re out of use). 

There have been no issues using the older (single-band) TP-Link WA850RE, or a small ASUS RP-AC52, hung off a wireless Sonos unit. In both cases I disabled the back-up DHCP server.

Thanks gents, for all the inputs.

A question for access points in general. If one was to buy an access point that works only as that when wired back to the router - assuming that such devices exist - can one assume that if it is added to the core network via a wire from a Sonos unit wired to said network, it can be assumed safely that it will work without any hiccups in Sonos?

Keep in mind that the SONOS network ports are 10/100. 

@buzz yes, but that has not been a constraint in the six months that I am using them to extend wired internet within a room. I consistently get speeds of 50 Mbps broadband per my plan from the access point so wired, just the way I get these speeds from the main router. Firestick HD Video streams are solid and there is no effect on Sonos music play. I suspect the missing gigabit port feature is one that is rarely needed in domestic environments in practice.

The problem with Sonos raised its head only when I replaced the Airport Express with the TP Link as the wired from Sonos Port WiFi propagator in a remote bedroom.

PS: Note that Sonos net is not in use here, the Sonos unit is being used just as simple switch where the access point is concerned. 

The Connect Amp dropped off again, and I suspect this happened after the TP Link on the other side of the wall was powered on by my son on his arrival. 

Very frustrating. The system as is consists of the Boost and few other units including the same Connect Amp wired to the core network. The TP link just has the one wire running back to the router anchoring the core network, no connection to any Sonos unit except via being connected to the same router/switch. To avoid WiFi interference from the TP Link, I have even disabled WiFi on the Connect Amp. 

As soon as it was rebooted, the Connect Amp came up again, and perhaps it will now stay that way until the next time the TP Link is power cycled!

A possible clue?

I find that invoking the matrix takes time ranging from less than a second at times to over a minute at other times; sometimes it takes a second click to get it to start the process. 

This, from the same device/location, in the bedroom, with the Mac host signed on to the AEX access point.

When there is a delay, often the information about the Sonos units does not show up in the Sonos controller, under the about my system.

Is this related to the topic issue?

Userlevel 7
Badge +15

Does the AP also broadcast a 2.4GHz signal too?  I have a TP-Link Re650 that broadcasts both 2.4 & 5GHz (although it doesn't give me any issues) - but allows the channel to be selected. (sorry if already covered, I only speed read above).

Yes, TP is a dual band device, broadcasting on both frequencies at the same time. Unlike the AEX which has dual band, but only one at a time, and that is set to 5 GHz.

Userlevel 7
Badge +15

Have you tried switching the 2.4GHz off (or at least moving it further from the Sonos Channel)?

No, because the Connect Amp that dropped has its radio turned off and is running on a wired connection to the core network. 

So the TP link radios should not be a factor but as good practice the 2.4 is set on channel 1 and 20 bandwidth while Sonos is on 11.

Userlevel 7
Badge +15

Still worth trying IMHO. If only to eliminate simple WiFi interference.

I’m wondering whether the DHCP server in the TP-Link unit might be activating, perhaps just for a short while.

In “automatic” mode it’s supposed to spring to life if the device can’t see a connection to another DHCP server (in order to allow clients to continue to connect to it). If, for some reason, it thinks its backhaul has dropped the DHCP server might be starting and, for a while at least, handing out IP addresses that are in the wrong subnet.

If by chance a Sonos unit picked up one such address it would effectively vanish.

I think I’d start by digging in the TP-Link unit’s system log.