Only works with Ethernet

  • 16 January 2016
  • 33 replies
  • 37275 views

Userlevel 1
I am frustrated with SONOS. If the router changes or if a new network is used it is virtually impossible to have SONOS working smoothly. I own a pair of Play 1s, but the system only works if one of them is plugged in directly to router via ethernet. I have attempted to reset, reboot, re-install, and nothing works. It cannot be this difficult to set up the system. Getting ready to return. Nice sound but very flawed.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

33 replies

Thank you all contributors on this thread. I'm a technical support person myself. My experience was that you do indeed have to do it with each speaker if they are Play1 speakers. I'm sure that's not what's supposed to happen, but I spent an annoying hour getting a new set of speakers working on different WiFi after testing on my home WiFi before installing them at a local community centre. All working now but my experience for someone who wants to cut their time down is to ethernet to the new router, make sure you are on the right WiFi on your controller (= phone for normal mortals), then set up the Wifi for the first one in advanced settings, unplug ethernet and restart. Check it connects once no longer on ethernet. Then repeat this process for all speakers. Not a very nice arrangement but that's the answer.
Thanks for clarifying! I didn't interpret them that way but see my response may have seemed like it. Was more just reiterating that Sonos instructions could work harder. Really love Sonos and that was my first issue ever. Now exploring the Amazon Alexa integration...
@Salmon island. My comments were not directed at you but at the user I quoted, and largely because of the aggressive and unreasonable tone of his comments.
Yup once the main speaker was up the other fell in line! I DID "read the instructions" but it was not easy to find on SONOS help...I followed all of their suggestions for fails and nothing revealed that solution, nwstf it might be available if you know where and what to search for!
And incidentally it should not be necessary to do the wireless setup for each speaker, as was suggested by @Zerrlyo. Powering the others off and on should be the most that is needed, once the first is up and running.
HOW THE HECK WAS I SUPPOSED TO KNOW THIS WITHOUT TEAM MEXICO HELPING ME w/ THE ABOVE ???



SONOS --- honestly --- you support is garbage and I am sure that you know it.


Yes this was difficult to find. You would have had to go on to the Sonos Support home page and searched for 'boost to standard'. Or done a general Google of 'Sonos boost to standard'.

Either would throw up this page

https://sonos.custhelp.com/app/answers/detail/a_id/3319/~/switching-your-system-between-a-standard-and-boost-setup

For a wider picture you could search for 'change router', and get this:

https://sonos.custhelp.com/app/answers/detail/a_id/1072/kw/change%20router#setup



Both links are listed if you search Sonos Support for 'disconnect Ethernet'.



I'm sure Sonos would appreciate your thoughts on how they could make this information easier to find.



"If all else fails, read the instructions"
Thanks Zeerylo - I'm savvy and had Sonos working for two years until I switched routers than pure mayhem. Worked, then inexplicably did not and tried everything unsuccessfully to reconnect. You had the missing clue and it fixed all!
I was as frustrated as some of you, and surprised with the support as some of you too. Found how to fix the problem. Without going step by step in detail what I can say is that once you have your speakers playing while is connected to the local Ethernet (cable) in the Sonos App GoTo Settings > Advanced Settings > Wireless Setup. Took me 4 hours to find out this fixes the issue. I had to do the same for each of the speakers and then all of them were working OK.



EXTRA: Speakers won't start playing immediately, you gotto Group them or select them in the Music section, this is in the main Album / song selection, on the very top of the screen (ROOMS).



Hope this works for everyone. Viva Mexico!




THIS WAS A GIGANTIC HELP TO ME



HOW THE HECK WAS I SUPPOSED TO KNOW THIS WITHOUT TEAM MEXICO HELPING ME w/ THE ABOVE ???



SONOS --- honestly --- you support is garbage and I am sure that you know it.
Hi

Just wanted to drop a note to say thank you. My sonos was doing this and after much connecting, reconnecting app changing, hair pulling and even thinking it was the wifi providers fault, all it had done was drop the wifi password! D'oh!!



Thanks for the help x
You did have SonosNet. It's set up automatically when you wire any Sonos unit.



And directions for changing the WiFi details from a PC controller are included in the FAQ.



Sorry, but you're simply in error. Lurkers should not be left with the incorrect impression.
Hi Ratty, I agree that having to connect and enter the wifi password for multiple speakers is time-consuming and ridiculous. However, I don't have a BOOST adapter or Sonosnet. I'm also using a PC, not a smartphone. The instructions I shared are what worked for my two speakers. The other solution, as you mention, is definitely much better if you have the resources that I do not have. There may be better solutions, but I wanted to share what worked for me.
Sorry, but this is totally misleading. You do not need to repeat the entry of WiFi details on every single player in the system. For an extensive system of multiple units this would be utterly ridiculous.



Wire one unit to the router. Wait until all the units are visible in a controller. (They will take a few minutes to connect via SonosNet.) Enter the new WiFi credentials at Wireless Setup. They will propagate to all the units. Job done.



The Ethernet cable can then be removed. Again, wait a few minutes while the units switch over to the new WiFi. The system is then ready.
I also own a pair of Sonos Play:1 speakers. Recently, I changed my wifi router and wanted to reassign the speakers to the new router. It was a VERY frustrating process, taking over an hour because their online instructions were not conclusive. If this helps anyone else, this is what worked for me:



1) Follow the instructions on https://sonos.custhelp.com/app/answers/detail/a_id/1072/kw/change%20wifi%20router#setup for Speaker 1.



2) After successfully connecting Speaker 1, unplug the Ethernet cable that you used during Step 1 (Ethernet cable should be connected to new router). Play some music to ensure Speaker 1 is working without the Ethernet cable.



3) Connect Speaker 2 to Ethernet. Unplug both speakers. wait a couple of secs, and plug them back in. Both should blink and then the lights turn white.



4) Try to play some music. You should hear music from both speakers. This is a positive sign!! However, if you unplug Speaker 2 from the Ethernet cable, it will stop working.



5) With Speaker 2 connected via Ethernet cable, go to the Wireless Setup settings. You should be able to enter a password for the wireless settings (just as you had to do for Speaker 1). After doing this, you should be able to unplug your Ethernet cable and it, too, will work using the new wifi router!
Cheers thanks for your help
Can you achieve the same result with a second router ?

No, it has to be a Sonos component.



Go to eBay and you'll find new BRIDGEs for much less. BRIDGE is the precursor to BOOST. It only has SonosNet 1.0 -- which has less range and resilience than the 2.0 that's in all recent components -- but it might do the job.
Wow !!

£99

Can you achieve the same result with a second router ?
OK thanks
Is there something I can purchase that I can plug into my router which sets up a Sonos network separate from the wifi without having to keep one of the speakers plugged in to the router ?

That's what BOOST is for.
Hi

I had the same problem after installing a second Sky Q box but, thanks to visiting the forum I resolved the issue by following the instructions above. The problem is that now my Sonos speakers have knocked my network printer off the network. I have now resolved the issue by plugging one of my Sono speakers back in to the router and reinstalling the printer. Is there something I can purchase that I can plug into my router which sets up a Sonos network separate from the wifi without having to keep one of the speakers plugged in to the router ?



Ta
You say "controllers stop responding". Can you clarify what you mean? One possibility (just a possibility) is that your controllers are connecting to your router's 5GHz band. This has the potential to cause connection problems when operating in fully wifi set up - it will with some routers, not with others. Worth at least checking out, and forcing your controllers to connect to the 2.4GHz band if only as an experiment.
having the same problem.

have tried all the above. as soon as i unplug ethernet....controllers stop responding..... plug it back in .....it starts.

have gone into advanced....wireless...... reset....everything is on same wifi..... no new router...... all firmware updates done.....

what other options?
Badge
I was as frustrated as some of you, and surprised with the support as some of you too. Found how to fix the problem. Without going step by step in detail what I can say is that once you have your speakers playing while is connected to the local Ethernet (cable) in the Sonos App GoTo Settings > Advanced Settings > Wireless Setup. Took me 4 hours to find out this fixes the issue. I had to do the same for each of the speakers and then all of them were working OK.



EXTRA: Speakers won't start playing immediately, you gotto Group them or select them in the Music section, this is in the main Album / song selection, on the very top of the screen (ROOMS).



Hope this works for everyone. Viva Mexico!




Thanks Zeerylo, this is the only thing that worked for me after trying everything else..!!
Thanks Ratty and others!!! Had to change my router/time capsule setup and could NOT figure out why Sonos quit when I would disconnect the unit I'd used for re-setting up my system. Appreciate the info.
I was as frustrated as some of you, and surprised with the support as some of you too. Found how to fix the problem. Without going step by step in detail what I can say is that once you have your speakers playing while is connected to the local Ethernet (cable) in the Sonos App GoTo Settings > Advanced Settings > Wireless Setup. Took me 4 hours to find out this fixes the issue. I had to do the same for each of the speakers and then all of them were working OK.



EXTRA: Speakers won't start playing immediately, you gotto Group them or select them in the Music section, this is in the main Album / song selection, on the very top of the screen (ROOMS).



Hope this works for everyone. Viva Mexico!
Userlevel 7
Badge +26
If I'd got here first you'd have seen the true power of sarcasm young "Jedi"...



The sarcasm can definitely get a bit strong around here, but that's part of the charm sometimes as long as it doesn't go too far.



I know we've got two threads going with this same discussion and same posters, so I'll be closing the other one, might as well keep it all in one place. The other thread is here and has some good suggestions from ratty already.



In most cases where the system works well on SonosNet but not on your wireless it's due to problems with that wireless, the network credentials, or the network access devices.



Just to make sure we're all on the same page, when you have a Sonos device wired to the network, your mobile controllers all work fine. You've gone into Wireless Settings and added the network credentials for your network (confirming that they're correct). Then you go to unplug the wired device and all of your Sonos players drop off. From that point, does restarting any of them bring anything up?



If you were to wire the unplugged device back into the network, what other steps do you have to take to bring the units back up? Or do they come on their own after a couple minutes?



If the players will reconnect on their own, can you follow those steps with disconnecting the wire, give the players a couple minutes, then wire it back in if they didn't come on wirelessly, and wait for them to come back up. Once you've got that going, can you submit a diagnostic from your Sonos system and reply back with your confirmation number?



Also, I know you mentioned none of the network settings had changed, do you know if any of your network devices had updated recently? Was there a firmware update for your router that was just installed? What is the model number of the router as well?



Stick with us a bit, the community is a great resource and we'll do what we can to help.