Changing name of wifi network has broken Sonos

  • 23 September 2016
  • 11 replies

This is an odd one. I had my Sonos system connected up to a wifi network, all running fine. Then I changed the SSID and password of the wifi network, and tried to reconnect Sonos. But now the advanced settings won't connect, and my Sonos controller is telling me my wifi isn't compatible with Sonos. But IT WORKED FINE before I changed the name. It can't have suddenly become incompatible just from changing the access details, so what's going on and any idea how to fix it?? Thanks.

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

11 replies

Follow this link:
Of course it can't work if you change the access details.
You've changed the ssid and password of the network and haven't told Sonos what the new ssid and password are. Why would Sonos still work in that case?
Userlevel 7
Badge +22
yea best way is to hard wire one Sonos unit to your router to get access then re-run settings...advanced...wireless setup.

As LHC said - why would this seam odd - you changed your wifi so Sonos wouldn't know how to access.
To be clear, I have told the Sonos the new details. The issue is that Sonos is now telling my my router won't support Sonos, and rejects the new details. Yet it clearly is compatible, since it was working fine previously. So the question is, why would Sonos reject a perfectly adequate wifi network, just because I've changed the credentials?
Userlevel 7
Badge +22
It shouldn't try again with Sonos wired to router then go to controller, settings, advanced, wifi setup.
Userlevel 7
Badge +22
one other thing - can't be 5ghz network trying to connect to.
So the question is, why would Sonos reject a perfectly adequate wifi network, just because I've changed the credentials?
It's not a BT SmartHub by any chance? If so, try splitting the bands onto separate SSIDs and disabling Band Steering.
Thanks folks. Update: I turned all the various bits off and on again and it still didn't work. Then I left them for several hours and now it's working. I have no idea what could have changed so all I can think is that either Sonos was giving me a false error, or the router was misbehaving. So I guess chalk this up to an intermittent error, and if other people have the same problem, give it a few hours and it may settle down. Thanks for the help folks!
I have a similar issue - I did not change the name, but upgraded to a new router. Now I have the Play 3 plugged directly into the router, but when I try to go through Wireless setup to get everything going without being plugged in again (per, in the iOS app it does not see ANY networks. If I enter the name and PW manually, it gets a connection error. It is a dual band router, but so was the old one, and the name of the network I'm using is for the 2.4 Ghz band, so it shouldn't be confused anyway. Help!
For anyone else who encounters this issue - I ended up changing the settings on my router to accept "Legacy" 2.4 Ghz connections. This allowed the app to see my wireless network. Once the Play 3 was connected through setup, I could connect wirelessly. After that, I put the settings on my router back to "Auto" and the Sonos would still connect. All-in-all, I spent probably 3+ hours on this. Serious pain.