Problem with IFTTT on iPhone


Badge
Hi, I'm trying to setup "Start Sonos When I Come Home" in my iPhone, but after I press the turn on button, in the configuration screen I can set the zone where I want it to detect that I'm near home and the "Include grouped rooms" options, but the other two options (What favorite ... and Where do you ..) combos, are not being populated with my Sonos information, so without that information, the applet can't be saved. Am I missing something?

Thanks in advance for your support

9 replies

I do have the same issue but I'm on Android. Favourites gets populated when using ifttt but the rooms drop-down stays empty. Anyone has an idea how to fix this?
Badge
Hi, where should I look assistance with this? Isn't this one the correct place?
I'm having the same issue. Attached a screen shot for reference.
Badge
Guys I have the same problem someone have the solution for that?
You perhaps need to reauthorise the IFTTT access to the Sonos API..

In the IFTTT app, under 'my applets' goto your services tab, search/select Sonos.

Select the settings icon in top right corner and choose to 'edit' the connection to reauthorise and accept the Sonos/IFTTT sharing agreement. Once the settings are saved then try the IFTTT Applet again. Hopefully it should then work.?
Hi All,

I have the same issue. From the one day to the other Sonos Cloud (Siri Shortcuts combined with IFTTT) stopped working.
When I tried changing the config, the rooms listing did not refresh anymore (empty list).
I removed the Sonos account from IFTTT and re-installed it, but still no luck.
After that I installed the app Yonomi as an alternative to IFTTT; but that app faces the same issues as IFTTT which makes you believe that the Sonos API is the source of the issue.

Does anyone know how to debug or test; even better, how to resolve this?

Thanks!
Badge
Dears finally I find out a way to exit form these F**** nightmare!

I had reset my principle router and now perfectly works.

Thank you all for your collaboration.

BR.
Not that it matters, but I have been having similar problems with IFTTT apps, not just from the phone, but the apps just running and not able to edit them. When I would edit an app I would see the message "error accessing the service" at top of computer screen. I would also see errors in activity: Applet Failed. Restarting my router fixed this. thanks @PARISBALA for the idea!
Badge
🆒

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings