Question

HomeKit Room Integration Question


Hi!

 

New owner introduced to the Sonos family as of this weekend, picked up a pair of One SL’s to be used in the garage. Previously I’ve been an all HomePod guy. 
 

So here is my issue, and let me know if this is simply just not a feature of non-Apple speakers via AirPlay. With my HomePods, I have each designated to specific rooms - and to play I hit the AirPlay button, scroll to select desired room, browse music and play. By this method, all sound is completely separated from my phone, IE: if I wanted to pull up YouTube the sound will go through my phone and the music will be uninterrupted on the speakers. Also, adjusting my phones volume with the buttons will do just that, adjust my phones volume and not the speaker volume. I figured this would be exactly how it would work on a non-Apple speaker when connected to HomeKit. To my dismay, my ‘Garage’ room completely disappeared from the AirPlay toggle once I removed my HomePod from that room and added the two Sonos One’s. The only way to play music on the speakers is to select them individually without being able to select them from a designated ‘room’, which binds some phone audio to the speakers. Within the HomeKit app both Sonos One’s are assigned to the Garage room. I’ll attach a screenshot below. In this screenshot you’ll see that my Garage ‘room’ does not appear, like my other rooms with HomePods do. Any help would be appreciated, as I’m questioning my purchase decision at this point. Thank you. 

 


11 replies

Userlevel 4
Badge +10

Hi @diz714 ,

 

yes you can assign them to rooms and have them appear in Airplay as “Rooms”

 

in Sonos app do you have the Sonos One SL’s set up in Different Rooms?…. Say Garage and Kitchen?

 

if so you can go into the HomeKit app and assign the speakers to the appropriate room in HomeKit. 
 

the issue I have found is the way HomeKit and Sonos use names for speakers and rooms it a similar way and it is a little confusing when you then go to use AirPlay.

 

To get around this in the Sonos App I call the rooms things like “Kitchen Sonos” instead of “Kitchen” then in Airplay it is displayed as “Kitchen Sonos”… instead of what you are seeing “Sonos”… who’s confused me at first.

 

but yes…. from what I think you are after, it is possible to do.

 

Can somebody please help me? Thank you.

I am not a Homekit user, but does this article help at all?

https://www.google.com/amp/s/9to5mac.com/2018/07/11/how-to-update-sonos-speakers-for-airplay-2-homekit/amp/

I am not a Homekit user, but does this article help at all?

https://www.google.com/amp/s/9to5mac.com/2018/07/11/how-to-update-sonos-speakers-for-airplay-2-homekit/amp/

I appreciate your response. I read through this article and it shows operating the Sonos speakers the same way shown in the photo I attached. Part of HomeKit is the designated Room feature, which I can assign the Sonos speakers to, but their assigned Room doesn’t show up in AirPlay as my other Rooms with HomePods do (as also shown in the photo I attached). That’s what I’m trying to figure out, and if this is not possible then Sonos speakers won’t work for my desired setup - and I’d be forced to stick with an HomePod setup.

Userlevel 4
Badge +10

Here is my set up, I think you want something similar?…..

 

 

Badge

I don’t have a HomePod, but I think that is one of its advantages. I think you are asking if you can have music playing on your Sonos speakers without it streaming from your phone (or computer). You can, but not with airplay; you have to use the Sonos software.  You can’t do much interaction with the Sonos speakers through HomeKit unless you are airplaying to them. Note, I don’t have an Apple Music subscription, maybe that is different. What you can do with airplay and Sonos is the following: if my wife is airplaying music from her phone to a speaker, I can see that in Home or in the airplay Control Center  interface.  I can also stop, skip tracks, and change volume.  Also note, that doesn’t work if I am airplaying from my Mac (10.14), only iOS devices.  An Apple TV operates a bit more like the HomePod in this case.  I can play music from it, send it to any airplay speaker, and it shows up in Control Center on my phone.

 

If I start a song from the Sonos software on my phone, and turn off the phone or leave the house, it will keep playing. If I airplay to my speaker (Siri, play xxx in the living room), it will stream from my phone.  If I turn off my phone then, the music stops. 

I don’t have a HomePod, but I think that is one of its advantages. I think you are asking if you can have music playing on your Sonos speakers without it streaming from your phone (or computer). You can, but not with airplay; you have to use the Sonos software.  You can’t do much interaction with the Sonos speakers through HomeKit unless you are airplaying to them. Note, I don’t have an Apple Music subscription, maybe that is different. What you can do with airplay and Sonos is the following: if my wife is airplaying music from her phone to a speaker, I can see that in Home or in the airplay Control Center  interface.  I can also stop, skip tracks, and change volume.  Also note, that doesn’t work if I am airplaying from my Mac (10.14), only iOS devices.  An Apple TV operates a bit more like the HomePod in this case.  I can play music from it, send it to any airplay speaker, and it shows up in Control Center on my phone.

 

If I start a song from the Sonos software on my phone, and turn off the phone or leave the house, it will keep playing. If I airplay to my speaker (Siri, play xxx in the living room), it will stream from my phone.  If I turn off my phone then, the music stops. 


About what I’m attempting. I’m just unsure as to why with HomePod & HomeKit, when a HomePod is assigned to a room, it gets its own room dropdown via AirPlay (shown in photo above) - but when adding a Sonos speaker and assigning it to a room, it does not get its own dropdown. That is what I am trying to achieve, ultimately - that way there’s zero phone audio integration (volume buttons controlling the speakers audio rather than my phones loudness, being able to jump into YouTube on my phone without the audio redirecting to the speakers, etc [this is achieved with the room dropdown with my HomePods]).

 

Side question. Is there a way to group Sonos speakers within HomeKit, that way I don’t have to manually select each speaker every time I initiate play? I see this is an option within the Sonos app, but that does not translate to HomeKit. Wondering if I delete both Sonos speakers, group them in Sonos, then hit add accessory in HomeKit, rather than both speakers being found separately, maybe they’ll be found as a group?

Badge

I don’t think you can do what you want. At least I haven’t figured out a way to. My Sonos speakers only show up like you want when I am streaming to them from an iOS device. When I first start airplaying to a speaker, I have to select it in under the iPhone area. And the audio is always dependent on the device airplaying to it. 

Here is my set up, I think you want something similar?…..

 

 


Thank you for reaching out!

 

So, it’s not quite the naming that I’m having an issue with - it’s the separated room designated within AirPlay/HomeKit that I’m having an issue with.

 

I have both of my Sonos speakers each named One SL within the Sonos app, which technically is considered a ‘room’ name - which is indeed weird. I have them named exactly the same within HomeKit, however, I have them designated to the Garage ‘room’. I can voice command Siri, “play music in the Garage” and it’ll play music from both Sonos One SL’s in the garage just fine. Voice control works just fine. It when I want to control from my actual phone that it gets a bit cumbersome. I have to hit AirPlay, scroll down and select both Sonos speakers individually and then play music. In my screenshot on the original post you’ll see AirPlay’s drop down of my Bedroom, Entertainment Room & Living Room. This is what I am trying to achieve with the Sonos/HomeKit. When I originally setup the first One SL, I had a HomePod in the ‘Garage’ - so I did get a dedicated Garage dropdown, but as soon as I removed the HomePod, the Garage dropdown was removed despite the One SL’s in the Garage room within HomeKit - and the only way to get music going is selecting each speaker from the top individually. The only ‘workaround’ I have is by selecting one of my other rooms from the room dropdown, enabling both One SL’s, disabling the HomePod in that room - and there I have it, the control that I want. But obviously this is a makeshift workaround as I have to disable the One’s whenever I want to use the HomePod that’s in that room for normal use. I’ll attach a photo of the workaround.

 

Reply