Question

Group Non-Airplay Products not reliable

  • 13 November 2020
  • 3 replies
  • 250 views

Hey Sonos Community. 
 

First post. I’m sorry if it’s a duplicate. Tried to search first. 
 

For a while now I noticed that the “Group Non-Airplay Products” setting is lacking reliability. Since iOS 14.2 and the new AirPlay interface on iOS devices it seems completely broken: music playback initiated via iOS device via AirPlay 2 does not integrate my non-AirPlay Sonos speakers (a play:1 and a play:3) even though I have a host of devices that support AirPlay 2 (a Play One, and two sets of the IKEA speakers) and the setting is definitely set to “group non-AirPlay products”

 

am I doing something wrong? Am I misunderstanding what this feature does? Ideally I’d like to completely ignore the Sonos app, but it’s not possible currently. 


3 replies

Userlevel 5
Badge +14

Hi @sebrichter, welcome to the Sonos community, and thank you for letting us know about your concern. Let me help you out with this.  

You can group any other Sonos speaker with an AirPlay 2 compatible Sonos speaker for multi-room playback. If you’d like your non-AirPlay compatible products to stay grouped together with other products when you start playing AirPlay audio, go to the Settings tab in the Sonos app for iOS or Android, tap System > AirPlay, then enable Group Non-AirPlay Products.

I'd like to ask questions to isolate the issue so we can create a path towards resolution.

  1. When you stream AirPlay only on your Sonos One, did it work?
  2. How about adding one speaker with your Sonos One, did you experience the same when you stream AirPlay?
  3. Have you tried rebooting your network and Sonos devices?
  4. Have you tried streaming AirPlay on another iOS device (only if available) with software version11 or later?

Please submit a diagnostic report from your Sonos system for us to check. Just include the confirmation number in your response so that we can look up the information.

If you need help with any other information, feel free to reach out. We'll wait for your reply.

Hi Rowena

thanks for your reply. 
 

  1. doesn’t work
  2. doesn’t work
  3. doesn’t work
  4. doesn’t work

here’s the diagnostic code: 1148345599

Thanks

sebastian 

Userlevel 5
Badge +14

HI @sebrichter, thank you for your response and for answering all the questions. I appreciate you for providing the diagnostic report. As per checking, there are audio dropouts due to sync errors and your Sonos speakers are losing connection to your WiFi network. 

Let me suggest the following steps to see if it will work for you.

  1. Do you have access to your router? There are settings that you need to check in your router to ensure that it will work with Sonos. You can also ask your Internet Service Provider for assistance.
    • The auto channel must be set to Off
    • Choose the best non-overlapping channel (1,6,11)
    • Set channel bandwidth to 20MHz
    • Both 2.4GHz and 5GHz should be enabled
    • UPnP should be enabled
    • 802.11 bands should be set to b/g/n
    • Airtime Fairness should be disabled (if applicable)
  2. Relocate the affected speaker(s) to determine if it is a wireless range issue.
  3. Hardwire one of your Sonos speakers to your router

If you’re still experiencing the same issue, It would be best to contact our Sonos Customer Care support to perform further troubleshooting steps and prepare the list of your network devices including the make and model to check the information and understand your network setup. Please feel free to reach out in the future if you have any other questions. The Sonos Community is always here to help.

Reply