Question

Sonos Arc not detecting WiFi or cannot connect via ethernet

  • 22 November 2020
  • 5 replies
  • 91 views

I received my new sonos arc 2 days ago. Initially it work fine for a day. Next day, I was not able to connect to the network !. I did reset the arc, reinstalled the sonos app, tried with another iphone, restarted the router , still no success ! 

How can I get help, am not located in USA calling sonos support over phone and talking for an 1-2 hour will cost a lot ! 

Any suggestions please ?


5 replies

Exactly the same situation here mriyaskr.

Did you manage to find a solution?

Hi Brad

No solution . Waiting for Monday for their telephone support . Don’t know how it’s going to work. It was such a high end hardware runes by poor software. 
will let you know if I find a solution . Please update me if you are successful. 
Riyas

Thanks Riyas. Still no go here after another run at it.  Cheers

Hi Brad .

i got news for you . I got solution . I was not able to see the same network which used to setup arc at first time . So I did a reset of the modem to remove the arc from router memory . Then gave the network a different name and password , then set up arc and it worked .

you may please try that.

thanks 

Riyas 

Userlevel 4
Badge +13

Hi @Brad123.

Welcome, thank you for reaching out to Sonos Community.

Glad you manage to find a fix for your issue.

This might actually help in the future.

Connect Sonos to a new router or WiFi network.

If you need help with any other information, please be sure to let us know.

Reply