Answered

Using US-purchased ROAM and BEAM in Europe (Italy)

  • 30 December 2023
  • 3 replies
  • 57 views

Greetings.

I posted a similar question a few months back, regarding only my Sonos ROAM. None of the sensible advice has solved my problem. I sort of abandoned my quest to make the Roam work, but recently I received my Sonos BEAM from the States, and am running into the same issue: neither my Beam nor my Roam can be located by my Sonos app (S2). 

-I tried the factory reset on both

-I tried resetting the app

-both devices are powered on

-my home WiFI is not configured in any particular way (that I know of): no login page, etc…

-according to what I could learn online, I should not need to revert to the S1 app (even though my Beam is Gen 1)

One odd thing I noticed in the app: a few key functions are greyed out. Pic below/attached.

I also recently received an Echo Dot, which I was able to connect to my home WIFI with no problem. 

Any thoughts on this would be most helpful. 

 

icon

Best answer by Airgetlam 30 December 2023, 13:02

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Have you tried wiring your Beam temporarily to your router with an Ethernet cable?

A factory reset is a bad thing, it erases any data that Sonos could have used to help figure out your issue. The only time you should be doing a factory reset is when instructed by Sonos themselves. 

Those ‘greyed out’ options certainly suggest your S2 controller isn’t reaching the Beam, and you need to use the ‘add a device’ function, once you’ve temporarily wired the Beam. 

Thank you for this. I have not tried the Ethernet cable option yet. Will do so.
As for the factory reset, I get it. Not sure if this means the Beam is now inoperable or not. 

Userlevel 7
Badge +21

Thank you for this. I have not tried the Ethernet cable option yet. Will do so.
As for the factory reset, I get it. Not sure if this means the Beam is now inoperable or not. 

Factory reset will not have affected the Beam it’s just the action of last resort.