Answered

Spotify not connecting to Roam with either BT or Wifi?

  • 30 July 2021
  • 1 reply
  • 1644 views

Seriously I am about to throw this Roam through a window!

I have had UE, JBL, EV and other BT speakers and devices as well as WIFI audio streaming - this is the first time I have experienced this issue on anything.
The android phone is connected. I can play from the SONOS app ok ( so it works), but the app doesn’t support spotify podcasts - so I have to play from the spotify app.

Spotify shows the roam greyed out - “can’t play this right now”
Even when the android phone is connected via BT ( and this is verified in the settings, and the roam chime plays to say it’s connected), spotify says it’s connected and says it’s playing ( counter is going) - no sound comes out of the roam and the volume is up.

The issue occurs inconsistently, as in 90% of the time and occasionally with no logical reason works for a while- reinstalling the apps does not work to solve this at all.

 

Thoughts before I send this back and recommend everyone buys something other than SONOS?

icon

Best answer by Corry P 30 July 2021, 14:25

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 7
Badge +18

Hi @jonobailey 

Welcome to the Sonos Community!

First, I recommend you make sure both Sonos and Spotify are fully up-to-date on your device.

Next, I think a reboot of every device involved is in order - the phone, the Roam and the router. The phone can be rebooted (restarted) by holding the lock button for a few seconds then choosing the option on the screen. To reboot the Roam, disconnect it from any power source, hold the power button for 5 seconds to turn it off, and wait 10 seconds before turning it on again. For the router, please remove power for at least 30 seconds.

If you use any WiFi boosters or extenders, please turn and leave them off for testing. If you have a WiFi mesh system, please reboot it too, like the router.

Your results on Bluetooth are a bit strange, so I’m hoping the phone reboot will resolve that, if not the Roam’s. Due to the difference in how they operate, I have to assume that the similar results from Bluetooth and WiFi are unrelated. Please note that unlike with other Bluetooth speakers, the Roam’s volume and the phone’s Bluetooth volume are not necessarily linked, so you might need to make sure both are up.

It may even help to remove Spotify from your Sonos system and add it again - Remove a music service account from Sonos.

If none of this has helped, I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports about the situation.