Answered

Spotify Connect and Sonos Roam issue

  • 24 January 2023
  • 7 replies
  • 52 views

Hi

 

I have trouble using my Spotify account with 1 specific Sonos speaker.

I have several Sonos products (2 Play5’s, 4 Play 1’s, Playbar and Sonos Roam).

 

From my Spotify app or Sonos app I can start music from Spotify on all Speaker, but the Sonos Roam. This issue just started recently. If I try to start a Spotify playlist through the Sonos app on Sonos Roam it returns message “Spotify lost connection” (loosely translated from Danish). It works if I start on all other speakers.

If I use the Spotify I app – I can see all my speakers, the Sonos Roam included, as Spotify connect. Again I can start music on all speakers, but the Sonos Roam. If I choose that, it just try to start the music, but silently loose the connection/give up.

This happens regardless if I just my Samsung Android Phone, Apple iPad or Macbooc. Each with both the Sonos App and Spotify app.


But here’s the kicker: If I use e.g. my wifes Spotify account, it work flawless in both the Sonos app and Spotify app. The issue only persists when I use my own spotify account. I am therefore conviced, it must be a spotify issue (in the Sonos app we have Spotify accounts connected). So it’s not related to the devices I’m using (since it works on all of them with another account), and probably not related to Sonos Roam, since it also work on that one, when using another spotify account.

 

What to do – can I somehow on Spotify account level do something to fix this. I have tried searching the Spotify help forum to no avail.

 

I have tried uninstalling Spotify apps on devices, removed spotify in Sonos app, restarted internet ect.

icon

Best answer by Ken_Griffiths 26 January 2023, 12:41

View original

7 replies

If you play another source, such as Internet radio, which devices work with which speakers?

When you say that your wife's Spotify account works fine, is that using her controller device or yours?

Hi John

I can start internet radio just fine on the Sonos Roam. It’s only Spotify.

For clarification - I have added my Spotify account and her Spotify account in the Sonos app, so we have acess to both (only done this after the issue started).

My Wife can start Spotify on Sonos Roam either through her Spotify app on her phone (Spotift connect, not bluetooth), and through the Sonos app using her spotify account on her phone.

If she uses one of my devices, could be my iPad, we can start music on the Sonos Roam using her Spotify account in the Sonos app. If we choose my Spotify account in the Sonos app, it cannot start on the Sonos Roam (you can change in Sonos App though a little drop down menu which spotift account you want to use).

So the problem is solely related to when we try to start Spotify from my account, and so far only on the Sonos Roam,

@Martinpn81,

Just some things perhaps worth considering…

Did you add the two Spotify accounts to the Sonos App using separate mobile controller devices, it’s important to install your account to the Sonos App on your device and then use the Wife's mobile/tablet to install her Spotify account to her own Sonos App? - each device should be considered separately and have a different ‘native’ Spotify App installed on the respective device logged into that persons Spotify account.

Also, are you using a voice assistant on the Roam, such as ‘Alexa’ if so, I believe you need to ensure the correct user profile is in use for that voice assistant on each of your devices too and that each users Alexa App has their own Spotify credentials installed in their Alexa App and set as their default music service for their Alexa profile. The voice assistant can be used to switch user profile on the speaker eg. ‘Alexa switch to Martins profile’ (just as an example).

HI Ken

I don’t use voice assistant.

The problem persisted before I add my wifes spotify account to the Sonos app.

Before the explanation to clarify; My wife’s spotify account work through all the apps, and all devices. So as long we use her account to start Music it works through the Spotify App, Sonos App and on My Phone, her Phone, iPad and Macbook. But only her account.

When the problem started where I couldn’t play Spotify on the Sonos Roam using either the Sonos app or Spotify app on multiple devices (Android Phone, Macbook, iPad) with my account. 

We tried my wifes Spotify app on her phone. She was able to play music with spotify connect on the Sonos Roam  (Her account, her phone, her app). She has the Sonos App but was not able to start music on the Sonos Roam with sonos app, which at that time only had my Spotify account. 

Adding her account to Sonos app so we can Choose between the Spotify accounts in Sonos App, and choosing to start music on her account in Sonos app worked, and it works fine for me also using my Sonos app on either my Phone, iPad or Macbook. As long as I choose her account in Sonos App.
I have tried to remove spotify account and re-add the service in Sonos app ect.

 

@Martinpn81,
Maybe see if a Sonos App (only) ‘reset’ will resolve the issue for you… goto ‘Settings/App Preferences’ to reset it. Fully close App and on reopening, go through the App opening screens and select the option to connect back to the ‘existing’ Sonos system and see if that sorts it. If not, you are perhaps best to submit a system diagnostic and either note/post it’s reference back here and then contact/chat with Sonos Support Staff via this LINK  and see what the Staff can suggest to resolve the issue.

Hope you get it sorted.👍

Hi Ken

I will try that. I doubt it will work though, as the problem does not relate only to the app on one device but all devices, as long as the said devices are are using my exact Spotify account.

 

But haven't done it, so will try, and if not working, I have at least ruled out that possibility. Thanks for advice 👍

 

 

 

Hi Ken

I will try that. I doubt it will work though, as the problem does not relate only to the app on one device but all devices, as long as the said devices are are using my exact Spotify account.

 

But haven't done it, so will try, and if not working, I have at least ruled out that possibility. Thanks for advice 👍

I would in that case certainly go onto submit a system diagnostic and note the reference and then contact/chat with Sonos Support Staff via this LINK  and see what the Staff can suggest too to fix it.

Reply