Sonos Roam & Windows 11 - Speaker Connected BT but no audio

  • 29 August 2023
  • 11 replies

I have a Sonos Roam and I am able to connect it to my Windows 11 PC and see that audio is being transmitted to it, however no audio comes out of the speaker. 

I have tried unpairing and re-pairing, a factory reset, etc… 

I confirmed that the issue is not the speaker itself, it connects to my Win10 laptop and my Pixel 7 (Android) via bluetooth with no issue. I’m also able to connect my Sony XM5 headphones via bluetooth and a cheap bluetooth speaker to my Win11 PC. 

I am able to stream audio to the Sonos speaker via the Sonos App but this is clunky and I just want to connect it via BT directly to my computer. 

I ended up contacting Sonos support who told me it must be a Windows issue so I reached out to Microsoft support and we confirmed the device is detected and the drivers are all setup correctly. Next I tried reaching out to ASUS to check and see if there was a driver update and they pointed me back to Sonos. 

I got into a remote session with Sonos support and they were unable to figure out the issue other than to say that “Sonos Roam” is not compatible with Windows 11. Surely this cannot be correct? 

Again, the speaker shows as connected and setup properly in Windows 11 - device manager shows no issues with the device, the output device is set as Sonos Roam and you can see in the bluetooth settings that it is in fact connected and on the volume mixer you can see the audio levels bouncing indicating there is a signal being sent. 

Looking for anyone who has encountered this issue and knows the resolution, or confirmation that Sonos Roam is not compatible with Windows 11. 

Thank you


Best answer by Corry P 30 August 2023, 18:05

View original

11 replies

Userlevel 7
Badge +18

Hi @brookesrook 

Welcome to the Sonos Community!

I don’t think it is accurate to say that the Roam is incompatible with Windows 11 - I brought your case up in a meeting just moments ago and a colleague in the meeting was using a Roam connected to a Windows 11 PC via Bluetooth to get sound for the meeting, without issue.

Given all the other steps you have tried, the only thing I can think of that could be the problem is an incompatibility with the Bluetooth radio your PC is using, or it’s drivers.

Except for one thing - when you shutdown a Win10 or Win11 PC, it doesn’t do a full shutdown. Instead, it closes programs and then hibernates the operating system kernel. So, when you shutdown, the kernel (and therefore all the system drivers) are not fully restarting. Please instruct Windows 11 to restart the computer - that will make the kernel actually start up from scratch when it reboots, and could - hopefully - fix the issue you are having.

I hope this helps.

Hi Corry P, 

 Thank you for the response. It’s good to hear that the sonos roam is compatible with Win11 - I was in a remote session with Sonos Support and we did a full system restart in that troubleshooting, and we did the same when I was having Microsoft and ASUS troubleshoot. 

I don’t think it’s an issue with my computers bluetooth radio for a couple reasons, 1) It’s relatively new and 2) I don’t have any trouble connecting to any other bluetooth devices. 

I would love to get into a session with tier 2 support or something along those lines because at this point I’ve done everything except reinstall windows. 

Userlevel 7
Badge +18

Hi @brookesrook 

I don’t think it’s an issue with my computers bluetooth radio for a couple reasons, 1) It’s relatively new and 2) I don’t have any trouble connecting to any other bluetooth devices. 

As I understand it, Bluetooth is not nearly as standard as a standard should ideally be - there’s a lot of leeway permitted in the various specifications and device descriptors. This means that you get the occasional two models of devices that just won’t work with each other, for whatever technical reason. I’m not in any way saying that this is definitely what the cause of the issue you are having is, just that it’s the only thing I personally could think of.

I would love to get into a session with tier 2 support or something along those lines because at this point I’ve done everything except reinstall windows. 

As you have an existing case, and that we now know that Roam and Windows 11 are not incompatible, I don’t see any issue with you getting back in touch and requesting that the case get escalated to a higher level. Looking, I found 3 cases of your relating to this issue. I recommend you quote the case number of the most recent case to avoid starting from scratch with the team again. I’ll PM you your case number in case you don’t have a record of it, and put a note on that case with a link to this thread.

I just thought of something - you have repeatedly labelled your computer as a PC or a computer rather than as a laptop, despite mentioning a laptop in your opening post. I’ll assume, therefore, that it is a full sized PC. Where is the antennae for your Bluetooth radio, do you know? Is it movable? If it is a USB dongle, I’d certainly try it in some different ports. And, importantly, what is located on a straight line between the Roam and the PC’s antennae? The difference between your other Bluetooth devices connecting and the Roam not doing so may be down to which version of Bluetooth protocol is being negotiated, and how tolerant it is of interference. Roam supports Bluetooth 5.0.

If you are familiar with running Virtual Machines and if your Bluetooth radio is a USB dongle, you could try running Win10 in a VM and plugging in the dongle after it boots up and letting the VM have the device. That way, you could test the same hardware under a different OS. You might be able to do this even if it is not USB, by removing the device in Device Manager after booting the VM, but I’ve only just now thought of this and don’t know for sure if it would work. Similarly, you could also/alternatively try a VM install of Win11 on your laptop, to verify that that works with Roam under that OS. If you are not familiar with Virtual Machines, best skip this altogether.

If you haven’t already guessed, I’m really just throwing spaghetti at the wall here, but hopefully answers will come from what sticks. I hope this helps.

Hi Corry, 

 I am having issues connecting it to my desktop PC, laptop works fine. I have confirmed that my desktop does support Bluetooth 5.0. I tried your step of connecting and moving around my speaker to make sure it’s not a range issue, but to answer the question the bluetooth is built into the motherboard and it has 2 antenna that stick out the back and my sonos speaker is about 18” away from the antenna. 

I suppose I could try a virtual machine on my desktop - unfortunately my laptop doesn’t meet the requirements for the windows 11 upgrade. 

As for getting back with support I’m not sure what further steps they would be able to take, I’m pretty convinced at this point that it’s a driver issue but Sonos doesn’t load any specific drivers when it first connects to the PC (it just uses generic windows drivers). It may be nothing, but I noticed windows see’s the sonos speaker as headphones 

Here in bluetooth settings it sees it as a speaker 

Over in sound settings though it sees it as headphones also the provider and driver version there I have no idea where that is pulling from… 


Looking at the Bluetooth drivers installed on my PC I see: 


And then if I look at the Sonos Device: 


There is another driver for the speaker showing it here: 


Event log for the device shows it is starting: 

And again the event log shows that it has been started successfully: 


The only thing I can see is in the full system log here which indicates at one point there was an error when the device connected (as recent as now)


Userlevel 7
Badge +18

Hi @brookesrook 

I suppose an option would be to buy a USB Bluetooth adaptor and test it, but you shouldn’t need to spend any more money here - it should be working!

This, to me, is a bit concerning:

Namely, the provider details. I searched for them, and the top result on Google is a CNET page, and their link to Luculent’s homepage is dead. It does look like they provide drivers for Bluetooth devices, but I’d only expect to see Microsoft listed in that entry. I recommend scanning your computer for any and all Luculent software and removing it from your computer to see if it helps. If you are not familiar with the name or their products, I recommend you keep them uninstalled. A virus/malware scan may also be in order.

I don’t know for sure, but I imagine that if you were to escalate your case and speak to our L3 engineers, they might be able to garner more developer-level logging from the Roam to help decipher what’s going wrong.

I hope this helps.


Corry we did it! Removing Luculent from my computer got it working~


Userlevel 6
Badge +11

I would love to get into a session with tier 2 support or something along those lines because at this point I’ve done everything except reinstall windows. 


Have you tried the Windows 11 built in troubleshooters? There is a specific one for Bluetooth and another for Audio.

Also check the Windows mixer, if you have multiple speakers.

Check device manager, and expand Bluetooth, you should see 2 Sonos devices:

Roam xxx (SONOS xxxx)

Roam xxx (SONOS xxxx) Avrcp Transport

You should be able to hear sound through Roam, and also use the play/pause button on the Roam to control the PC when connected via bluetooth.

Edit: looks I was late to this party, glad its working 😀

Userlevel 7
Badge +18

Hi @brookesrook 

Corry we did it! Removing Luculent from my computer got it working~

Fantastic! Thanks for updating the thread!

I am having a very similar issue. :(

Userlevel 7
Badge +18

Hi @MckayCox 

I guess the first thing to check is whether the Roam has drivers supplied by Microsoft or not.

You say “very similar” but not “the same”. Please provide details.

I also could not hear any music on either my Sonos Roam or Move, when playing music on my Win11 desktop (using Windows Media Player), after successfully connecting via Bluetooth and selecting the Roam or Move using the speaker output selector (Airpods worked/connected via Bluetooth as expected, no problem).

I read all the blog posts, verified all the Win11 settings, allowed everything luck. Eventually, I realized that my Realtek external speakers were plugged into the speaker jack, and Realtek driver/speaker was hijacking the output. I unplugged the external speakers, and then immediately the Roam (or Move) could play music. Good. 

In the end, I only wasted an hour figuring out that issue (much less time and effort spent than the bloggers above...kudos to you), but glad I finally got it resolved. Otherwise, I was out of ideas.  Hope this helps someone.