Sonos Roam not showing system after setup

  • 22 April 2021
  • 6 replies

I installed a new Sonos Roam, selecting the "new system" option, since my other Sonos speakers are in a different location. My Sonos S2 app on my iPhone recognizes the Roam and I can connect it to the WLAN. At the end of the setup process, I get a message that the setup was successful and also a note that if the Roam doesn't show up immediately in "System", restart the Roam and it will appear in the "System" tab. 
However, restarting the Roam does nothing, it still does not appear in "System". System is grayed out in the S2 app and not clickable. I have already reset the Roam several times to factory default without any success. I always end up back in the same state.

What can I do? 


Best answer by Xander P 23 April 2021, 16:51

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 6
Badge +15

Hi @retob, and welcome to the Sonos Community!

If the Roam still doesn’t show up after a reboot, then I’d recommend also rebooting your router, and the phone/tablet that you have the Sonos app installed on.

If there’s no change, would you mind letting us know a bit more about the network? What make/model of router are you using, and are there any wireless extenders/mesh systems in place?


Hi Xander

I have restarted WLAN router and iPhone. But unfortunately it did not bring any success. The Sonos system is still not visible in the Sonos app.

I am using two Aruba AP-207 access points which together form a single WLAN network. Even if I turn off one of the two access points and all devices are connected on the same access point, but it does not work either. 

Here are two screenshots from the Aruba software with connection details. 

Does this help you?



Userlevel 6
Badge +15

Got it, thanks for that @retob

Aruba access points can require some additional configuration when used with Sonos - do you have access to the Aruba WebGUI?

I’ll post the steps we recommend taking below, however if you’re unsure about making these changes, or would like any assistance, feel free to get in touch with our Support Team via either live chat or phone call, or alternatively reach out to Aruba support :)


  1. Log in to the Aruba WebGUI.
  2. Select AirGroup from the left column (may be under More > Services as well.)
  3. Add a new service group labelled Sonos Services, and description Sonos.
  4. Using the Add section, add each of the following services one line at a time, clicking Add after each.


















    5.Check Enable DLNA and DLNA Media Service.

    6.Click Apply and then Save Configuration.

Hi Xander

I have a slightly different firmware on my Aruba AP-207 but I mean I set up the AirGroup as you described and enabled DLNA and DLNA Media. I have rebooted all devices again. 

Unfortunately, I still don't see the Sonos system. 

When I do a manually search for the system in the Sonos app, it always shows me my other Sonos speakers, but they are not in that WLAN / building at all.


Userlevel 6
Badge +15

Understood, thanks for trying that. If you check the settings for the Aruba, are there any options relating to Broadcast Filtering? If so, would you mind disabling the feature and checking if there’s any change?

The Broadcast Filtering option should be under Network > WLAN Settings > Advanced Options.

If this doesn’t help, then I’d recommend getting in touch with our Support Team via either live chat or phone call so they can take a closer look and perform some live troubleshooting with you.


Hi Xander

To disable the Broadcast Filtering has solved the problem. The Roam and my system is now visible in the Sonos App.

Thanks a lot.