Answered

Sonos Roam not connecting to Wifi

  • 30 April 2023
  • 4 replies
  • 7087 views

My Roam will connect to Bluetooth and the app will show it as connected to BT whilst playing. it will not connect to Wifi despite several resets and setup attempts. The setup works very well until I get to the ‚connecting to Wifi‘ part. 
i have UniFi access points and have made changes to settings suggested by other users. Allother Sonos devices on my network work well. Assume this is a faulty device i need to return?

icon

Best answer by Jamie A 1 May 2023, 14:52

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

4 replies

Userlevel 7
Badge +16

Hi @Ingo9, welcome to the Sonos Community!

The Roam would need to first be setup on Wi-Fi to be able to use Bluetooth, was it previously connected to your network and isn’t reconnecting? If you’ve reset the Roam, you’ll have to set it up again for both Bluetooth and Wi-Fi, so if you can still use Bluetooth then there’s a possibility it wasn’t reset correctly.

I wouldn’t recommend resetting the Roam, as we use that as a last resort. When attempting to add the Roam to your system by going to Settings → System → Add Product, do you receive any error message or error code during the setup?

You can also reach out to our support team for live troubleshooting, as they have the tools available to assist you in resolving this issue.

I hope this helps!

Hi Jamie

 

thanks! The unit was previously connected to the wifi and seems to have lost the connection when it was not in use (but charged). I’ve tried the steps you describe in your msg several times before posting my question here. 
 

When i reset the roam and re-install it the app finishes the setup and with a msg along the lines of ‘wifi may not work, power cycle the Roam and it should work’. That of course doesn’t work either. 
 

it seems the Roam is a sub-standard piece of Sonos kit. My first unit arrived with the top part not attached to the unit and the rubber part with the buttons literally falling of on first use…on the second unit the wifi stops working after less than 3 months…

 

 

How do you reset the Roam? Looks like I join good company as my Roam continues to drop the wifi connection as well. 

Doing a factory reset doesn’t often fix anything at all, as suggested by @Jamie A above. Have you called Sonos Support directly to discuss it?

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.