Sonos Move disappearing on Airplay

I have 2 Sono Move speakers.  One in the kitchen and one in my room.  In the last few days I have noticed that in the Airplay menu on my iPhone / iPad only one would show up and rarely both.  Both speakers however show up to be connected in the Sonos app.  I would have to shut the missing speaker down (long press the power button) and turn it back on to have it showing on Airplay.  I’ve not changed anything with my home internet network.  Anyone has the same problem?


Best answer by Airgetlam 27 April 2022, 14:24

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

53 replies

Same problem - logging so we have more clues.


I experience the exact same problem and have tried it on 3 different wifi systems (I’m in IT and test a lot of equipment). 

Google Wifi mesh (assumed that was the issue)
Eero Mesh (when it happened here, thought I validated that it was a mesh issue)

Now on Unifi. I can confirm, reserved IPs for all Sonos speakers including Moves. They are locked to a single access point so same channel. Latest iOS 15.5 on iPhone 12 Pro and iPhone 13 Pro - one move shows up but the Sonos app shows both moves on both iPhones. Same behavior on Intel and M1 Macs running Monterey (1 move on airplay, 2 moves on Sonos app).

I CAN however start airplay on one move and hold the “Play” button on the other and it will group but never shows on airplay. 

At this point, I think I’ve validated it is NOT the network. 

Other Sonos products on my network:
Stereo paired Ones
Stereo paired Fives + Sub


2 Moves (not stereo paired)

I’m in IT with loads of experience running Sonos in corporate and home environments. Completely happy to try anything you all can think of!

Oh and yes all Sonos firmware and apps up to date. 

Ok, here we go…  I had (and probably will have again) this same exact issue.  I have somewhat figured it out.  The problem is that  apple airplay is issuing the same ‘airplay’ address to both moves (or several or whatever).   This seems to only affect the moves as I have several other sonos devices that work perfectly with airplay.  Everything was fine on my system until I introduced the 2nd move.  I did all of the above steps, called a few times, had tickets opened and talked to at least 2 techs.  I had zero luck with the first tech and some luck with the second.  The fix with the 2nd fellow was a reboot of my phone that just happened to be due a patch from apple, and voila two moves on airplay, thanks goodbye, ticket closed.  A week later, only one move again.  The second tech did give me a tool (app) to use on my Iphone, in which you can see the duplicate addresses.   The app is called:  discovery - and it looks like below.  Load this up and on first screen click on local (under browsable domains), then look for Remote audio output protocol (AirTunes), click on this.  Then you will see 2nd screen shot.  In the screenshot you can see that the highlighted areas of my two moves are different, and guess what they both show up and work in airplay.  When the addesses are duplicated, we have the issue of only one working at a time.  I can almost guarantee you will see duplicates in this app if you have this issue.  I can’t exactly figure out how to get them to directly re-address- as reboots / resets of the moves does not do this.  I think this is stored in Airplay, and I don’t know how to directly change it, as this app is view only.  But - Big But, if you reset your network on you iphone, it ‘should’ pick up new airplay addresses, seemed to work for me.  It’s a little worrisome this network reset because you are in an area where you would normally reset your phone - like if you were trading it in.  But I pulled the trigger (only choose network reset - only network), and did it.  You have to provide your wifi logon again - actually you might have to provide that everywhere - not sure, but this little reset got my moves on different addresses.  Good luck.  This is a super annoying bug - all other sonos devices are fine on the airplay, but not the moves - something odd there… not sure...




That app is helpful!  As predicted, both my Sonos Moves are showing up in the Discovery App with the same Remote Audio Output Protocol address, despite different IP assignments and different MAC addresses.  Unfortunately, resetting the network settings on my iphone did not work for me. Both Moves still have the same AirPlay address.  I’ve also done a router reset and still, no luck.

I’ll try to look into how to better reset these airplay assignments, but if any Sonos officials or other forum members have a clue, please chime in! 


p.s. I currently have 3 Apple TV’s and two Ipads, two iphones, as well as iTunes on a PC all on my home network.  Perhaps those are keeping the RAOP address from being reset?  It’s going to be a pain to reset all network settings for every single device.  I am looking for a better option. Particularly since this all worked seamlessly a few months ago...

I would do the ipads and the iphones - i know painful, but I am guessing that one of them does the airplay assignments or did.  I was sure i added the moves with my phone, and I believe played airplay with my phone first...

Some stuff here on raop, but nothing terribly useful:

I would also reset one of the moves in the process somewhere - sorry, this is all just guess work for the most part...

I would also reset one of the moves in the process somewhere - sorry, this is all just guess work for the most part...

Maybe try this to fix the duplicate entries…

  • Remove the Moves from Apple Home(Kit) and remove any voice assistants from the devices too (if relevant).
  • Factory reset each Move, that’s as long as they are not your only devices in the Sonos HH, as you don’t want to lose your current system setup.
  • Leave them all off the system and check in the Discovery App that both are gone from the list.
  • Reset the iDevice controller Network Settings and reestablish its connection back to the local WiFi Network
  • Next, add the Moves back to the Sonos system one at a time with their chosen unique names.
  • Add back any required voice assistants SVC, Alexa etc. If using Alexa, check that each Move is correctly restored to its Alexa Enabled Groups (if using those groups).
  • Also add each Move back to the Home(Kit) App as an ‘accessory’ and put them into a chosen Room, as required. If HomeKit doesn’t find the Move as an accessory initially, try putting it in standby and then waking it up again (that usually fixes any discovery issues).
  • Check that each Move then has a unique address in the mentioned Discovery App.

Perhaps see if that resolves any Move device (re)naming issues.


I tried this routine and unfortunately, AirPlay still assigns them the exact same ID despite a factory reset of the Moves, a reset of the router. and a network reset of my iphone.  Again, I haven’t reset every device (ipad, wife’s iphone), because I need some of the other saved network settings.  But I did turn them off during the process.

Again, this all used to work just fine until either a Sonos or Apple update.  Can’t determine which.


If/whenever I very ‘occasionally’ encounter the issue, a factory reset of the Moves has always worked for me.. I follow the steps posted earlier, first removing the devices from HomeKit and voice assistants etc. and the RAOP ID switches between the ones shown in the attached images. So it’s unusual it didn’t work for you? Did you reset the device network settings between removal and restoring the devices?

Maybe give it another go and next time also reset the Sonos App App too from the option in ‘Settings/App Preferences’ in-between the removal and setup and see if that perhaps sorts it for you. I would even try resetting both devices that have the same ID.

Hi Sonos,

I have three Sonos Move speakers. I met similar situation that ahcl20 encountered. I remember that several months ago I could see three Sonos devices in Airplay list in my iPhone & iPad. But since June, I only see one of them in Airplay list. I want to see all of the three Sonos Move speakers. Could some Sonos engineer help me to solve the problem? 

Hi Sonos,

I have three Sonos Move speakers. I met similar situation that ahcl20 encountered. I remember that several months ago I could see three Sonos devices in Airplay list in my iPhone & iPad. But since June, I only see one of them in Airplay list. I want to see all of the three Sonos Move speakers. Could some Sonos engineer help me to solve the problem? 

Assuming you have already tried the suggestions mentioned in the thread here, then I would submit a Sonos diagnostic report from the ‘Settings/Support’ area of the Sonos App

Make a note of the reference number generated and perhaps post it back here.

Then, when available, contact/chat to Sonos Support Staff about the matter via this LINK and see what they can suggest to resolve the matter.

Diagnostic report → the number is “752886258”.

Additional information, if I cannot see the desired Sonos Move Speaker in my Airplay list. I will turn off and then turn on my WIFI & Bluetooth of my iPhone/iPad until the desired Sonos device showing up in Airplay list.

Hi. Is this still a problem for anyone else? I’m not sure if there was an update  for the Move recently, but I now see both my Moves as separate Airplay devices again. AND, they seem to be playing nice on my Wi-Fi extender for the first time ever! I hope these are actual fixes and not a fluke. 

Hi. Is this still a problem for anyone else? I’m not sure if there was an update  for the Move recently, but I now see both my Moves as separate Airplay devices again. AND, they seem to be playing nice on my Wi-Fi extender for the first time ever! I hope these are actual fixes and not a fluke. 

Sonos doesn’t support extenders, so that bit may be a fluke.

Unsupported network setups and devices

  • Wireless internet connections such as satellite, mobile hotspots, or LTE routers
  • Guest networks or networks that use a portal login page
  • Networks using wireless range extenders 2
  • Ethernet over Power (EOP) devices
  • WPA/WPA2 Enterprise


Userlevel 1

I am still seeing this issue and unlike others, no amount of Sonos Move, iOS network nor router resets have led to my 2 Move’s getting unique Airplay “deviceid”s.


What is interesting is that my Moves both get the “00:0C:43:37:90:D1” deviceid, like @jeremyrwc, which is not a MAC address of either device, although it is in the format of one. When @jeremyrwc got his Moves working, one of the Moves obtained what I presume is its MAC address, the other one kept the MAC-address-like deviceid - “00:0C:43:37:90:D1”. My Play5 gets a deviceid assigned corresponding to its MAC address. The Airplay convention seems to be to use the MAC adddress as deviceid as per:

The “00:0C:43:37:90:D1” MAC address is owned by Ralink Technology Corp which is a WiFi chipset manufacturer which perhaps Sonos use. The MAC address of all 3 of my Sonos devices are reported as being owned by Sonos so I can only guess that Sonos are using a default chipset based MAC address as deviceid in some circumstances, perhaps when assigning a stereo pair which needs a distinct airplay address. I did note that to from a stereo pair I had to sign into Sonos, so there could be some hangover in our Sonos Cloud account that survives factory resets. 


I cannot see how this is not a Sonos bug, their software announces the Airplay deviceid, they have complete control over it, but some of us (maybe all who have formed a stereo pair and later tried to use Airplay to each speaker?) seem to get stuck with.


I will try and log a support ticket again but hopefully this thread helps …


@Sonos, are you out there?

Userlevel 1

Alas, with Support I worked through a few troubleshooting steps (including switching to Sonosnet, enabling groups with the missing speakers etc) but it came to naught and they suggested I try again over the phone at a later time.



I’m so happy I’ve found this. I have the same issue. Tired everything including reaching out to support. And it only affects the Move’s. They blame apple, but all the other devices work. I wish they would fix this. It’s very annoying to deal with. 

OK, so suddenly, for the first time in months  my Sonos Moves are now both recognizable.  Looks like last week my Move speakers auto-updated to 14.14, and I’m guessing that solved the problem?  I’d love others to chime in to see if their problem is fixed, too.  I’m seriously pumped things work the way they used to, but I am a bit disappointed in SONOS blaming Apple when it was as SONOS update that both killed the functionality and then repaired it. After the 14.14 update, my two moves are finally showing different Remote Audio Output Protocol ID’s where-as before they were the exact same.

 Anyway, though they didn’t respond on this thread, and they were little help on support calls, it looks like (for me at least) the problem of being able to see my two Moves on AirPlay has been fixed.  I would love to have the hours and hours of troubleshooting back in my life, but c’est la vie.  Still love my SONOS system.  Just wish I hadn’t been gaslighted into thinking the problem was on my end when I didn’t change a single thing in my system other than allowing ‘auto-updates’ for my SONOS and Apple devices.

Let me poke @nowislife @graham1980 @jack_a @Robert62 @jshadow @Ken_Griffiths @ahcl20 @Robert62 to see if you guys’ problem is fixed.

Finally Happy (as long as it’s still working tomorrow...)



I reset both my Moves a while back, prior to the last Sonos update and all started working for me prior to that v14.14 release and each speaker had different remote audio output protocol identifiers and continued to work fine, so I’m not sure who fixed the issue behind the scenes. It might have been Apple, or Sonos, or both.

Both speakers have continued to work/airplay for quite some time and I’ve just checked and both RAOP ID’s have remained unique/different. 

I do believe that whenever companies fix these sort of issues they usually just include them as ‘bug fixes’ in the comments/remarks released with their updates  - neither Apple or Sonos (or other manufacturers/suppliers) tend to ever give a comment much beyond that.

I have an ongoing issue now for example, with (zoomed in) text selection on an Apple iPad Pro screen causing it’s display to often scroll to the top of the page, but Apple appear to not be keen to comment on that issue aswell.

All three of my Moves were accessible in the Airplay menu for about a week, but now they have reverted back to cloning each other. Still not fixed. 


Did you check the RAOP ID’s before/after the latest S2 updates @mullenjsm? Just wondering if you did ever factory reset them to ensure they each had unique identifiers to begin with, going into the update.

My two Moves have kept their unique identifiers (for a long time now) but I did have to put them right to begin with.

Happy I’ve found this thread but unfortunately, seems the Move might be playing up again. I’ve read through the thread and tried all suggestions but for the life of me I cannot get my Move to stream via Airplay from any iDevices via Apple Music yet I can stream via Airplay to my Beam (Gen 2) fine on the same network from all iDevices from Apple Music. 

The Move and Beam are setup fine on my Sonos account and both are visible in Airplay on Apple Music on my iDevices but no matter what when I cast via Airplay on any iDevice to the Move from Apple Music, the move hits me with ‘Unable to connect to ‘Sonos Move’’. To compound matters my partners android phone can cast to the Move fine and Spotify Connect works fine to the Move on all iDevices so it leads me think its some Airplay/Apple Music iDevice protocol issue. I can use Apple Music on the Move fine on my iDevices using the SONOS companion app. 

Move and Beam both updated to 14.16 and S2 - any suggestions before I drop-kick the Move into the stratosphere? 

Sure. Submit a diagnostic when you’ve experienced this issue, and contact Sonos support. Let them look at the diagnostic, and give you information about what the hard data is showing.

Maybe try this out; helped me with Moves going offline when moved around the house (different access point zones):

I have 2 Sonos Ones and a Sub Mini as my Living Room system. I also have a Sonos Move that I have to connect to the system separately. I recently got a new modem and so changed my network settings. Since then either the Living Room system, or the Move, or both constantly drop off Airplay. They are still connected to the app, but just drop off all my Airplay lists on all my devices.

When I unplug them and turn them back on, they reconnect for a couple of hours, then drop off again. It’s driving me mad! I’ve tried various sequences of unplugging the modem, unplugging the speakers, unplugging both, but nothing works for more than a few hours. Sounds like the same problem. Hoping someone finds a solution!