Sonos Move and Starlink 2nd gen

  • 16 November 2022
  • 9 replies
  • 184 views

So I had a Starlink 1st generation satellite in our previous home. I bought a Netgear router and was able to hook up the Move no problem. We sold the home with the Starlink. In our new home I bought a 2nd gen Starlink, purchased their ethernet adapter, hooked up the same Netgear router, and I cannot get the darned thing to connect. I split the 2.4 and 5 ghz channels and cannot connect to either one. I tried bypassing the Starlink router completely - still no luck. Each time I get as far as ‘There was a problem connecting yoru Sonos Move to “ “.


9 replies

I’m a little confused. Are you having issues connecting your Move to the Netgear router, or to the StarLink router? Or are you having trouble connecting the Netgear router to the StarLink router?

Apologies if I didn’t explain this well. Our only internet source is the Starlink satellite system. Sonos does not work with it so with our first Starlink I purchased a Netgear router, hooked that to the Starlink, connected Sonos Move to that and it worked. However, unlike the 1st gen Starlink, the 2nd gen satellite/router (which we now have in our new house) has no ethernet connection to plug into. So I purchased Starlinks ‘ethernet adapter’. Hooked up the Netgear router to that - internet works fine on it. But I tried to connect the Sonos Move to it and it will not connect. 

OK, thanks or the explanation, makes more sense now. I’m not sure what their “ethernet adapter” is supposed to do. Hmmm, let me go look it up. 

You’re talking about this device? https://www.amazon.com/Starlink-Ethernet-Adapter-External-Network/dp/B0B4KSBR7L

Based on what I see, it has an ethernet connector on it, that you’ve wired your Netgear to? 

Have you changed anything on the Netgear from the last time it was in use? Like, for instance, the SSID/Password, or maybe the type of signal it uses (AC, rather than b/g/n)?

Ideally, your Moves should connect to the exact same SSID and password that you previously had them set up to. Normally speaking, I’d suggest connecting one to the router with an ethernet cable in order to pick up any new SSID/password you may have set up, but the Move doesn’t have an ethernet port. 

If you’ve changed your wifi / network name (SSID) and password, you’d likely need to follow the instructions in the FAQ, I’ve not ever dealt with a Move in that fashion before. 

But there shouldn’t be anything unique about connecting to the Netgear device. The Sonos has no idea about your source of internet (the StarLink), it’s only concerned about the network being generated by the Netgear. I’d want, just in case, to be sure that those two devices are separated by at least three feet, so that they’re not causing any interference with each other, but I’m imagining that you’ve not got one sitting on the top of the other. 

At first I kept the same configuration and SSID/pw the on the Netgear  - this had worked on the gen 1 Starlink in our previous home. Tried both 2.4 and 5 ghz channels and Sonos Move could not connect. It finds it, it chimes but I get to the same spot every time: ‘There was a problem connecting your Sonos Move to “”. ‘ So I tried a factory reset on the Netgear, set everything up the same, still no luck. I reset the Sonos Move, still not connecting. I even tried a different wireless router (TPLink). Still no luck.

If the Sonos has no idea about the source of internet, why will it not work directly with the Starlink router? Something is not working and I am suspecting there is an issue connecting to the 2nd gen Starlink since this all worked fine with the 1st gen? The difference being Gen 1 had a built in ethernet connection while the 2nd gen does not and you have to purchase that ehternet adapter. 

To the best of my knowledge, it should ‘just work’ with the StarLink, assuming the StarLink is putting out a accessible signal for the Sonos to connect to (see here) .

I don’t, however, fully understand this comment on that page: 

  • Wireless internet connections such as satellite, mobile hotspots, or LTE routers

I do wonder if that’s a reflection of the potential number of devices supported by those ‘routers’. At least ‘unsupported’ merely means ‘may not’ and not ‘will not’. I’d certainly test it.

To my knowledge, my friend has his Sonos connected to his StarLink network in his vacation home. 

I have a positive outcome. I also have a Sonos Beam but i had not yet tried connecting to it because it is hard wired to our tv and thats all we use it for. However I attempted to wifi it on the Sonos app. I was able to successfully connect it to the Starlink router and it then updated the network settings in the app. It then updated the Move. I have both now working with the Starlink router, no Netgear router required! I can only conclude that the Move had an issue connecting to the satellite network on it’s own or the Starlink ethernet adapter causes an issue. 

Two different kinds of ‘wired’ for that Beam, but I’m delighted that you’re where you want to be ;)

That’s great news, did you use the Starlink ethernet adapter to connect to to the Starlink network?

Beam connected to Starlink via Starlink Ethernet adapter?

 Thanks 

Hi there, 

Actually no, I did not need the Starlink ethernet adapter at all. Initially, I could not get the Sonos Move to connect to Starlink any which way, it kept erroring out both wirelessly and through a router hooked up to the Starlink ethernet adapter. However, I was able to set up the Beam wirelessly to Starlink through the Sonos app. It must have fixed something because I was then able to add the Sonos Move wirelessly. 

Reply