Setting up Roam when you have an old S1 system

  • 21 April 2021
  • 3 replies
  • 5743 views

If you have an old S1 system and want the Roam set up as a separate system on S2, you need to swithc off all your product, while you set up a separate system, or you can’t setup your new Roam.

After setting up a new system in S2 app, your can switch your old products on again and access them in your old S1 app.

After setting up the Roam via network, you can switch on the bluetooth system.

Only that way you can get your Roam to work,

It took me a while to get it to work, but now it works fine.

SONOS please let your customers know this fix, or you’ll get unsatisfied customers.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 6
Badge +15

Hi @B9benny, welcome to the Sonos Community!

Sorry to hear you had trouble getting the Roam set up. What exactly happened when you tried to set up the Roam while the S1 components were powered on?

This should be straightforward to do, by choosing “Set up a New System" from the S2 app - sounds like the S2 app may have tried to connect to the S1 system previously? If this is the case, then an App Reset should have sorted it out.

When I have som problems seetting up my Roam on S2 app I have contacted the SONOS-chat in Denmark

They told me to turn off all my old components first.

Then I should reset the S2 app, power on my Roam and start the S2 app again.

This worked fine and I get Roam to work, both with the S2 app and Bluetooth.

Then I closed the S2 app and powered off Roam.

Turned on my old components and started my S1 app to see that my old components worked, they do.

After hours I would use my Roam in the bathroom, When I started the S2 app, now the S2 app tried to connect to my old component, but asked me to use the S1 app, I was unable to reach my Roam.

After some try and error, resetting the S2 app and chose to Set up af new system, I was able to connect to Roam, but unable to use Bluetooth.

I contacted the chat once, then they told me to change 7 parameters on my router, but I was not sure that this would be good. I was afraid that this would have bad effect on my network and all my PC’s and alarm setting

Then I talked with my dealer and he had other setting I need to change on my router.

I now have decided to skip Roam until SONOS have made a solution, so it will be plug’n play with 2 systems on S1 app for old components and S2 app for new components.

May be you can tell me the right solution,

I hope it will be fixed, I have a SONOS setup both in my home and my holliday home, and have been realy satisfied with SONOS until I tried to setup Roam.

I’m customer from Denmark and use one of the big teleproviders in Denmark, Yousee

It is possible that the S1 and S2 app get in conflict when the only component on the S2 app is Roam, which is not powered on all time. 

For your information, I’m not an IT-novice, I have worked with IT and programmering a lot of years

Looking forward to enjoy Roam and a lot of other SONOS components in the future, I hope you have a solution.

/Benny

Userlevel 6
Badge +15

Hi @B9benny, apologies for the late reply!

The Roam should wake up automatically whenever the S2 app is opened, however your point about possible confusion with the Roam not being powered on all of the time is interesting. We would likely need to perform more troubleshooting to see if this is a general issue or something related to your network however.

I’ll be sure to keep an eye out for any similar cases though.

Just out of interest, what settings on the router were you recommended to change? Most often issues connecting are related to the network itself, so my inclination is that changing those settings would have helped you to consistently connect.