Roam Stereo Pair issues



Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

63 replies

So frustrating! Just bought a pair of Roams today and already have had to re-pair them a few times - ridiculous. 

This has been deeply annoying for me.

https://support.sonos.com/s/article/1066?language=en_US

This article (now) says that powering off a Roam or a Roam going to sleep will break a pair.  What a terrible design choice.

So they are basically useless as a pair, since you will need to re-pair them all the time.

Badge +1

I am having same issue with dropping stereo pair as well. My roams are connected Wi-Fi, and seperate every time I turn them off. The do connect back without any issues. It is annoying but I do hope Sonos will address the issue. 

This has been deeply annoying for me.

https://support.sonos.com/s/article/1066?language=en_US

This article (now) says that powering off a Roam or a Roam going to sleep will break a pair.  What a terrible design choice.

So they are basically useless as a pair, since you will need to re-pair them all the time.

Thanks for pointing that out - truly frustrating. Add in that one speaker usually doesn’t play any sound, even though it’s close to the one it’s paired with - you’re right - useless as a pair. 

Same issue here, my Sonos Roams don’t play well with the new ASUS AX-86U WiFi 6 router. I tried both 2.4G and 5G with WiFi 6 turned on and off, same result! The Roam as the left channel works for a while, then out of nowhere stops producing sound, the Sonos app will show the Left channel as “Offline”. All the other Sonos speakers on the network work fine.

@Sonos, this is NOT Okay, we customers stay with Sonos because of your ecosystem and “supposed to be hassle free” experience. FIX THIS!!

@Sonos, this is NOT Okay, we customers stay with Sonos because of your ecosystem and “supposed to be hassle free” experience. FIX THIS!!

Consider the possibility that it’s not Sonos which needs to “FIX THIS!!” [sic], but ASUS. 

Did you disable Airtime Fairness as recommended?

 They are not intended as a fixed stereo pair

 

When I bought my pair of Roam’s, pairing was a specific feature that they supported.  It still says pairing is a feature on the product page today.

The thing that is not stated is “unlike any other Sonos pairing, you must go and re-pair your Roam’s every time you want to use them because they separate from the pair each time they go to sleep”.

I bought Roam because I can take them with me when I want, and also have them live most of their time in my study as a pair.  If I did take one away with me, and needed to re-pair, fine.  But thats not whats happening.

 

Consider the possibility that it’s not Sonos which needs to “FIX THIS!!” [sic], but ASUS. 

Did you disable Airtime Fairness as recommended?

Execuse my ranting comments, don’t usually use tones like that, trying to be the solution not the problem. I was frustrated after talking to the support rep for over an hour, we tried turning on and off some features on the Router, even switched between 2.4G and 5G with a fixed band, the problem persists. I have to point out though, Sonos’ support reps in China were very helpful, well trained and knowledgable, he tried his best helping with the problem. I submited the diagnostics from the app, unfortunately the rep couldn’t locate any problem except quoting that one Roam somehow fell “out of sync” from the other. 

Airtime Fairness was disabled the whole time, the first thing I tried. And I have an complete Sonos Arc + One + Sub setup running on the same network that works flawlessly.

 They are not intended as a fixed stereo pair

 

When I bought my pair of Roam’s, pairing was a specific feature that they supported.  It still says pairing is a feature on the product page today.

The thing that is not stated is “unlike any other Sonos pairing, you must go and re-pair your Roam’s every time you want to use them because they separate from the pair each time they go to sleep”.

I bought Roam because I can take them with me when I want, and also have them live most of their time in my study as a pair.  If I did take one away with me, and needed to re-pair, fine.  But thats not whats happening.

 

This is what the Staff have said about the Roam stereo pairing features (off its charger):

Obviously they always stay stereo paired when on WiFi and placed on a charger and work great when on the Sonos magnetic Qi charger base.

Badge +1

This is depressing!! I’d planned buying a second to add a stereo pair in the conservatory or outside. But they would be joining other speakers around the house. I thought they'd act as one speaker, my old Sony cubes worked similarly & brilliantly in stereo, and would join other easily. Is Sonos aware of this as it is a feature they promote?

Badge

Same issue here. It used to work (upon release date) but some update broke it for sure. Now IF the pairing succeeds I get only one speaker to work, and breaking the stern pair enables the other speaker. Yup, strange. But then when I change the volume from the source it only becomes effective on 1 speaker since it doesn’t have a stereo pair.

 

It just doesn’t work, also not in my other house (with different WiFi obviously) so that can’t be the issue. I’m going back to old school receiver and cabled speakers and play from CD. That always works since there aren’t any software updates.

 

Phil

Badge +3

I have a stereo pair of Roams which work perfectly in every way apart form when started by Sonos alarm. Every morning I have to press the volume up button on the RH speaker which immediately brings it to life (and increases the volume to the LH speaker slightly). Left on standby permanently and start as a stereo pair in all other circumstances.

Sonos seem to have become lazy at dealing with known issues which is disappointing.

As the owner of ~25 units in two houses I expect better engagement than I get.

I created an account just to share my experience with this and possible solution.  
 

Me: Sonos power user/brand advocate with setups in multiple rooms, in ceiling speakers, 3 Amps and 1 port total. iPhone 12 max pro with latest iOS, google fiber/mesh. 
 

Purchased 2 Roams with intent to pair for stereo. Went through same steps. Sonos confirmation audio in stereo. Tried to play music in Music app. Failure. Only 1 speaker played music. Tried reconnecting from other speaker, etc. I could select both speakers separately and they would play together but each in mono. That was not satisfactory at all obviously.  

THIS WAS LITERALLY MY FIRST EVER BAD EXPERIENCE WITH SONOS AND I WAS SOMEWHAT SHOCKED  

I just now randomly tried loading music through the Sonos app instead of iOS Music, which required me to authorize my phone on my Apple Music account (had no idea it wasn't authorized). I logged in, loaded My Library, opened a playlist and suddenly everything plays in stereo. 
 

Note this isn't a perfect fix. I went back to Apple Music app and stereo broke again. But I didn't have to repair the speakers again. I just had to back to Sonos app and load Apple Music in the Sonos app again and back to stereo. Not perfect but good enough for me. 
 

TLDR: if you're having issues using 2 Roams in stereo mode, try loading your music within the Sonos app (ie, use Sonos app to play music.)