Roam not working in Sonos app

  • 4 August 2021
  • 2 replies

We have a lot of Sonos products, and we have been using Sonos since we bought the first gen Play:5 many years ago. We are really fond of Sonos. Recently we bought a Sonos Roam, and this little box is a real challenge.

First it would not connect at all. We ran the usual setup, but after the setup the Roam did not appear anywhere and it just didn’t work at all. We tried all the usual things; turning off and on, resetting, adding again, and more. In the end we called customer service, and after a lot of debugging they found out that something had happened when the Roam was updated. It had not been added correctly to our Sonos account or something strange. The CS representative did some magic, and after a new reset, we were able to set up the Roam from the start again. Everything seemed ok.

I left the Roam to charge a little bit, and I moved it to the room it was going to be placed. I wanted to play some music, but again the Roam was gone from the Sonos app. I check my Macbook, but nothing there either. We use Amazon Alexa, and I tried talking to it - this worked! Also I brought it outside away from our Wi-Fi network, and also there it showed up and I could play music through Bluetooth. Back in the house - nothing works except Alexa. 

I have tried resetting, restarting, changing the Wi-Fi, but the Roam will not show up my app. I can play music from it, but just from Amazon Alexa. We have had the Roam for a couple of weeks, and now we don’t know what to do next.

Has anyone seen the same problem and found some sort of solution?


Best answer by Ken_Griffiths 4 August 2021, 17:17

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

If you are able to perhaps follow this suggestion …you could maybe try adding a fixed/static IP address to the Roam in your routers DHCP reservation table and (if your router supports it) you could also try filtering out its MAC address on one of your routers WiFi bands too, so it sticks firmly to one wireless band only.

Perhaps filter out the 5Ghz band to begin with, as that is less penetrating than the 2.4Ghz band, or if that doesn’t work try swapping the filtering on the bands. Only filter though if the DHCP reservation doesn’t solve the issue for you.

I called Sonos Support once again, and they gave me a list of settings to set in my Ubiquiti Unify Wi-Fi network. Everything was already according to their list, so that did not help. After that I tried @Ken_Griffiths tip about letting the the Roam have a static IP-address. THIS actually WORKED!

I had to reset the Roam once more to get it up and running, but after that it has never left the app. Everything works normal now, and finally we can enjoy music in our little home gym.

Thank you for your tip!