Answered

Roam not visible in app

  • 28 May 2021
  • 6 replies
  • 3377 views

Userlevel 1

Hi, I’ve been using Sonos since 2013 with few issues but I’m having a problem with my Roam that is frustrating, unpredictable and seems to have no solution other than to wait for it to sort itself out.

The Roam is visible as “offline” when it is switched off but is not visible in the S2 app when switched on. It’s clearly still connected to the network in some way as the app shows when it’s switched off (visible in the app) and it disappears when it’s switched on. It can also replay the last music that was played on it by pressing the play/pause button, and given that the current album is stored on the network it clearly still has access to the network. I have tried changing the channel, resetting the router etc. but the problem persists. I have tried on multiple devices and the same problem occurs. I am not using a mesh or range extender so this is not the issue. I’m using an ASUS RT-AC88U with no issues and strong signal throughout the house, including the rooms that I have tried the Roam in.

The problem sometimes goes away, in which case I’m able to change the music, but then it will come back and switching it on/off doesn’t help. I have had the same album playable for about a week with no way of changing it, and I don’t want to resort to bluetooth as to be honest if that’s what I was after I would have just bought a bluetooth speaker.

Any suggestions or solutions? Please don’t suggest resetting the router as it doesn’t help and I don’t want to have to reset my router every time I want to select a new album.

icon

Best answer by K13 28 May 2021, 18:55

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

If enabled, perhaps see if switching off QoS on your router resolves your issue.

Userlevel 1

If enabled, perhaps see if switching off QoS on your router resolves your issue.

Thanks for the response! Already disabled so not the problem, but thanks for the suggestion.

Okay. See if this sorts it then. Try changing the below in your router settings:

  • Under Advanced Settings, click LAN.
  • Select the IPTV tab.
  • Enable Multicast Routing (IGMP Proxy) and Efficient Multicast Forwarding (IGMP Snooping.)
  • Go back to Advanced Settings, and click Wireless.
  • Select the Professional tab.
  • Enable IGMP Snooping.
Userlevel 1

Okay. See if this sorts it then. Try changing the below in your router settings:

  • Under Advanced Settings, click LAN.
  • Select the IPTV tab.
  • Enable Multicast Routing (IGMP Proxy) and Efficient Multicast Forwarding (IGMP Snooping.)
  • Go back to Advanced Settings, and click Wireless.
  • Select the Professional tab.
  • Enable IGMP Snooping.

Wow, that seems to have solved it! You have my sincere thanks 😊

 

I'll keep an eye on it and see if the problem comes back but I can see my Roam in the app for the first time in a week. Thank you!!!

Userlevel 1

Okay. See if this sorts it then. Try changing the below in your router settings:

  • Under Advanced Settings, click LAN.
  • Select the IPTV tab.
  • Enable Multicast Routing (IGMP Proxy) and Efficient Multicast Forwarding (IGMP Snooping.)
  • Go back to Advanced Settings, and click Wireless.
  • Select the Professional tab.
  • Enable IGMP Snooping.

A transient fix, unfortunately. I'm right back to where I was 2 days ago with my Roam only appearing in the app when switched off.

 

Does anyone else have this problem? I love the concept of the Roam but at the moment it's no more than an expensive Bluetooth speaker. 

I am having the exact same issue.  It happens every few days and I can’t use the Sonos Roam with the rest of my Sonos system.  Please help!!