Move to new WiFi network

  • 5 October 2020
  • 7 replies


I have an Arc, 2x 1st gen One’s, all hardwired, plus a Move, all running 12.1 60381140. Until I setup the Move, I had never configured WiFi credentials to any of my Sonos equipment, and for some asinine reason I had to enable WiFi on a One before the setup would even acknowledge I had a Move to add. After configuration, WiFi has been disabled on all wired devices and everything has functioned as expected.

I now need to change the SSID the Move connects to, and the iOS App again refuses to begin searching for WiFi until at least one of my hard wired devices has WiFi enabled. This is mostly venting of the stupid precursor steps required to get to the real problem I’m posting.

I have the new SSID setup, every other device has been updated with the new credentials and is functioning as expected. The Move connects to the old SSID just fine, but searching for the new SSID using the iOS App (S2, 12.1, 6038140) fails to authenticate. I don’t even see an attempt on the AP, it’s just silently failing.

The AP is a UAP-AC-Pro, the existing and new SSIDs are configured identically except for their names.

If I have both SSIDs active, searching in the App presents a list of networks visible, I’m not sure if it’s from the perspective of the phone or the Sonos device. If I disable the existing SSID, the search returns a manual prompt to enter the SSID to connect to.

I have power cycled all the Sonos devices and AP, force quit the app and force restarted the phone.

Why do I need to include non-relevant devices in the process when I only need to update the WiFi credentials on the Move?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Badge +17

Not a solution but a work around. You could also use the SSID and password of you old wifi for the new wifi. If the new wifi is 2.4Ghz b/g/n Sonos won’t notice anything has changed.


The entire point of this exercise is to change the SSID at this location to differentiate it from the previous one, there are requirements beyond the scope of my Sonos configuration driving this decision.

It’s beyond baffling why a common, benign task such as changing the configured WiFi SSID on a device has been contorted into an opaque and error-prone Rube Goldberg obstacle course.

This may not be relevant, but there are some confusing comments in your post.

You say you have ‘Disabled WiFi’ on all wired components.  This is generally a bad idea - it is a poorly described setting, and actually turns off the wireless radio on the device.

Also, Sonos HT systems are designed to communicate internally wirelessly using direct routing over 5GHz,  By disabling the radios and wiring the surrounds you are preventing this.

I would try the following:

1 Re-enable wifi in the settings for the Arc and Ones

2 Disconnect the Ethernet cables from the Ones, leave the Arc wired

3 Give the system a few minutes to reconfigure and make sure your HT setup is working OK

4 Power off the Move

5 Remove any existing network credentials from the system (Settings, System, Network)

6 Power up the Move and hopefully it will find the SSID you want it to connect to.


It makes zero sense to require radios to be lit up when a much more reliable and consistent communication channel is present. I want as few devices injecting RF energy to this environment as possible, especially from those which are physically static. Compounding this is the fact the Arc and One’s have functioned exactly as expected as a group without the WiFi enabled. If they are truly designed to require a 5GHz communications channel, which is shut down when disabling WiFi, how is this possible? Further, the SonosNet channel options are 1, 6 and 11, the 3 20MHz non-overlapping 802.11 2.4GHz band channels, and are selectable when WiFi is disabled.

The Move is a completely separate device, and has no interaction with my surround system beyond sharing a configuration application. I suspect this is a corner case born from the fact it’s the first (modern?) Sonos device to not have the option to physically connect via ethernet to work around unexpected scenarios. Why is Bluetooth not an option to configure it in a direct manner?

Good luck.


I’ve tried the following configuration:

  • Move powered off.
  • Arc connected to ethernet and WiFi enabled.
  • LS One disconnected from ethernet, WiFi enabled.
  • RS One connected to ethernet, WiFi disabled.
  • Everything powered off for 5 minutes, left to settle for 10 minutes after powering on. Arc and surrounds function as expected (eARC and AirPlay).

The RS One is problematic to physically reconfigure, but this should prove functionally equivalent to what was suggested above.

When searching for WiFi with this configuration, there is never a list of observed networks provided, only a field to manually enter the SSID. Attempts to ‘connect’ all fail, 

If the Move is powered on again, I receive a list of observed networks, which makes me wonder if the other devices are even performing a scan at all, or are unable to report their results properly.

I do have separate layer 3 subnets for Ethernet and WiFi domains, but there is no blocking of traffic between them, and a multicast UDP 1900 reflector is configured which has functioned as expected for daily control use. Is there something extra required to facilitate configuration?

Is there something extra required to facilitate configuration?

Yes, Sonos controllers and players need to be on the same subnet, as stipulated in the system requirements. 

You may be able to move back to multiple subnets after configuration, but I suggest you stop fighting the system.