Move 2 Charging issues

I bought a new Move 2, unboxed it, plugged in the charging base to a surge protector (known working outlet), placed the Move 2 on the charging base, and couldn’t turn it on. No lights appeared.

I contacted Sonos Technical Support. I tried plugging the charging base directly into an electical outlet but still no lights. I then connected my own USB-C to USB-C charging cable directly into the Move 2, using the supplied USB-C power adapter, and voila, a light came on. I was then able to turn the Move 2 on and add it my Sonos System. Sonos is sending me a “new” charging base to replace the out of box failure.

At 26% charged (from Sonos App), I moved the Move 2 to where I planned to use and charge it regularly, but plugged into a surge protector. The following morning I checked the Sonos App and the Move 2 was at 9% charged. I unplugged from the surge protector and plugged directly into an electrical outlet. The Sonos App displayed the Move 2 charged at 69%.

What crazy power requirement does the Move 2 have that it can’t charge plugged into a surge protector? Again, I successfully tested all the surge protector outlets with a TV that turns on without issue. It’s not a ground issue, as the supplied adapter doesn’t have a ground terminal.

Feeling sparky challenged here.


Best answer by Airgetlam 6 March 2024, 17:28

View original

12 replies

Userlevel 7
Badge +16


The battery behavior imo also doesn’t look like it should. I think replacing the whole unit instead of just the charger might be the  better option. 

Userlevel 1

I just received my Sonos Move 2 and appear to have a charging problem after just 4-days. Initially, it charged to 96% but now appears to not be charging at all. I’ve tried two different outlets, each tested with a polarity meter. Both are working properly. No surge protector being used. Charging: Yesterday, 83%, this morning 68%, now 67%. If this is a known problem with the Move 2, I will return it to Amazon for a replacement. I’m reluctant to do this because the initial setup required 90-minutes of Tech Support assistance and I’m worried about having to go through this inconvenience a second time. 

Sounds like you may have received a faulty charger. Have you called Sonos Support directly to discuss it?

Userlevel 1

I didn’t call Sonos because of Schlumpf’s post above. This sounds like a more serious/endemic Sonos Move 2 problem. However, in light of your comment, I will call Sonos Tech Support and give them an opportunity before returning the speaker. Thanks for your post.

It’s unfortunate, but manufacturing processes are never perfect, no matter what industry is involved. Better to get good advice and possibly a replacement than to make hasty decisions. 

Userlevel 1

You are correct on all accounts, and I appreciate your sober advice. Thanks.

Userlevel 1

Okay, as we surmised, the problem is a faulty charging ring. Sonos is sending me a replacement, which should arrive in 3-5 business days. Although I could receive a replacement unit from Amazon in less time, I opted for replacing the charging ring.

Airgetlam, I appreciate your prompt responses and thoughtful suggestions. Thanks again.

Userlevel 7
Badge +16


Of course first getting in contact with Sonos support is a good decision. 
My advice to replace the whole unit instead of just the charging base was for @CujoJones because he told that he already has been in contact with support team before. 

Thanks for sharing , same experience for me, hope I can get a response from my seller 

My Move 2 worked fine and charged fine for the first few months. Now it won’t charge at all. The strange thing is that the lights turn on and when I place the Move2 on its ring, a red light comes on and the app shows that the unit is charging, but it isn't. Yes, I have rebooted the Move2 by taking it off the ring and holding the power button down for 30 seconds. I have also used another USB cord and it shows that the unit is charging, but it isn’t.  I have contacted Sonos and waiting for some kind of resolution.

Make sure that your USB charger has enough output.

I used an 85 watt charger, same result, no charge