Airplay skip stopped working over Voice AND touch. Any thoughts?

  • 20 June 2022
  • 5 replies

Userlevel 1
Badge +1

So I have a Beam, stereo pair One SLs with sub, Five, and a Roam.  All in separate rooms. I have always used Airplay 2 via my Macbook using Apple music to send to my speakers.  By swiping all the buttons on most of the speakers I can control the Airplay skipping tracks.  I can also use the new Sonos Voice control to say “Hey Sonos, Skip”  I also can pause or restart the music from the buttons.  Airplay still works just fine.  Sending to all the speakers.  I can group and everything. 

Suddenly, I cannot control skip at all from my speakers.  When I slide over all three buttons it gives the prompt sounds as though it skips, but it does not change tracks. When I say “Hey Sonos, skip” it gives me the sound effect prompt as though it skipped, but does NOT skip.  The odd thing is that everything else works.  I can ask “What song is playing?”  And it will correctly tell me.  The album art pops up on the app and everything works to lower volume.  But I cannot skip.  It does not allow me to skip tracks at all. And now when I pause it and start it does not play again.  My Apple music track IS playing, but it is not coming through the speakers.  The only way to truely play or skip is fromApple music.  I cannot skip at all using the Sonos app, Sonos Voice control, or the buttons.


I have unplugged all my speakers and router and macbook.  I restarted everything in order waiting for it to boot up properly.  Everything is up to date. No luck.  It worked fine one day, the next it just didn’t.  Odd.


Any thoughts? Thanks.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 1
Badge +1

So I fixed it.  After realizing I also could not hold down the main button to add speakers to new rooms, I decided to try a reset again.  Now it’s fixed.  Not exactly sure how, but here is what I found.  I restarted everything again.  I also let my Roam drain to 0%, as I recall the whole issue starting with my Roam. but then transitioning everywhere.  Upon restarting everything I also noticed that my ethernet was unplugged from the Beam.  Not that I think that would cause a major issue like the buttons everywhere, but I plugged it back in.  Also upon restarting my macbook, I noticed Bluetooth was on.  But I rarely use Bluetooth, so I turned it off.  I do recall thinking I may have accidentally turned Bluetooth on my Roam at one point, but the light was no longer blue, so I assumed it was off.  Anyway, after powering everything back on and the router,  they all showed up and it didn’t work. I still couldn’t swipe or skip via airplay  My Roam was still charging on the base at 0%.   So I called Sonos tech support. But while waiting I decided to try swiping again and sure enough it worked! It has been working flawlessly since.  Was it Bluetooth?  The Roam?  The Router?  A ghost in the machine?  Who knows.  But it skips and works perfectly now.  FYI for those who have similar problems.

Userlevel 1
Badge +1

Ok, this is insane.  It STOPPED WORKING.  It worked perfectly for two days and now it’s back to the same thing.  I can’t skip using touch controls or voice again.  In fact, I can’t use ANY Sonos controller to skip or play using Airplay.  How can this suddenly change after two days? What could stop working?  touch controls don’t work to swipe on any speaker.  Nor does voice 




Hard to tell, but I’d start with a network reset, and see if that helps. Unplug all Sonos devices from power, as well as powering down the Roam, then reboot your router. Once the router comes back up, plug the Sonos devices back in, and wait a couple of minutes before you test. 

Check the cable running to your Beam, and make sure it’s working properly. All devices except the Roam should be showing up as WM:0 in the report in the controller under settings> System>About my System. Use the Sonos controller to test, not AirPlay or Bluetooth. What is it that you’re trying to play as a source?

Bluetooth would only connect to the Roam, you’d have to group the rest of speakers in the Sonos controller. 

Currently, you have way too many variables to be sure about anything. If we can hone in and get one system to work, then we can extend our testing to the next, in case there is more than one issue involved. 

My advice would be to stop using Airplay and use the.Sonos system instead. 

Userlevel 1
Badge +1

So here’s the best part.  When I skip using touch, it does nothing.  But then whenever I decide to pause the music with touch it pauses it….but restarts without me touching it at all around 10-20 seconds later and suddenly skips whatever song I am on. It’s as if it remembers my skip touch ONLY when I pause.