Trying to config Gen 2 Beam to work together with existing Sonos Gen 1 system

  • 12 November 2023
  • 3 replies

Userlevel 1

I have an existing Sonos Gen 1 system (Play 5, Play 3, Play 1) working with the Gen 1 app.  All’s well with that.  Yesterday I bought a Sonos Beam Gen 2 which I found out won’t work with the Gen 1 speakers I already have.  It doesn’t want to connect at all - I get a message that says:
“This system includes products that aren’t compatible with Sonos S2.  You have options: (1) Open Sonos S1 Controller to control or update the system, (2) Set up a new system using the Sonos S2 app.  All products must be S2 compatible.”

I would think that I could still use my existing S1 system with the S1 app and use the S2 app to control the Beam Gen 2.  That doesn’t seem to be the case.  There’s another message I get while trying to set up the Beam Gen 2 telling me I could set it up in the S1 app and lose functionality.  

Is it possible to have Gen 1 in the S1 app and also Gen 2 in the S2 app simultaneously on the same WiFi network?  How can I deal with problems getting the Beam Gen 2 set up?  Do I have to upgrade the S1 speakers to make this all work, or is there a solution to make what I have work together?  Thanks in advance.


Best answer by jgatie 12 November 2023, 22:53

View original

3 replies

Turn off all of your old units by unplugging from the wall.  Download the S2 app from your app store.  Launch the S2 app and choose to setup a new system.  After the Beam is setup in the S2 app, restart your older devices, which will still be under the old S1 app.

Userlevel 1

That worked perfectly.  I’m all set now.  Thank you very much.


Userlevel 1

Unfortunately the success was short lived because while this approach worked for a while the Beam Gen 2 stopped working.  The S2 app then couldn’t see it.  All the while the S1 app and its speakers kept working just fine.  Request help to figure this out.  Thanks in advance.