Answered

WXPN Stopped Working on Sonos

  • 27 November 2021
  • 27 replies
  • 684 views

Badge

This is an odd one.  I have listened to WXPN (U of Penn, Philadelphia) on Sonos for years.  Last week it stopped working on Sonos.  I am running S1with a variety of legacy and new gear.  

  • When I start WXPN through TuneIn on a zone, the stream immediately flips from PLAYING back to STOPPED - every time I click PLAY it immediately flips to STOP
  • Other stations work fine through TuneIn - WXPN is the only one with an issue (that I have found)
  • Even sister stream XPN2 still plays on Sonos through TuneIn
  • I went to a friend and saw the same behavior (also running S1)
  • WXPN plays perfectly through the TuneIn iPhone app (not is Sonos)

I spent an hour on the phone with Sonos support (before our connection dropped)

  • Running diagnostics (even run while trying to start WXPN repeatedly) the rep saw nothing odd that indicated an issue
  • We tested WXPN through (Sonos) TuneIn, Sonos Radio and (Sonos Radio.Net) - all had the same behavior - clicking PLAY immediately flipped to STOP; all other radio stations through all 3 Sonos portals worked fine
  • Rebooted FiOS Modem and all Sonos Zones, same behavior persisted across (Sonos) TuneIn, Sonos Radio, Radio.net
  • When my phone connection dropped, the rep suggested I create an S2 network with  one piece of gear (Play:3) to see if the problem is an S1 issue - when the call dropped I gave up for the night (and didn’t create an S2 network)
  • Before he dropped the rep said he would submit a ticket to the tech team listing a problem with WXPN, I need to call back and follow up

Anyone have any insights or advice?  Could someone running S2 try to play WXPN and see if it works?

Big thanks.

Jeff

icon

Best answer by jtc456 29 November 2021, 19:51

View original

27 replies

WPN is playing for me on TuneIn and SONOS Radio. In the last week or so there was another complaint about WXPN.

Stations often provide multiple feeds to services and the user. It is possible that the stream accessed by your Internet Service provider is defective. If you contact WXPN they might give you direct access to a stream or they may be able to fix the stream sent to your ISP. Another issue is that stations can change their streaming setup and the stream that you normally access will be terminated. If you have stored this stream in as a SONOS Favorite, the best solution is to delete that Favorite, play the station, and store the new stream as a Favorite.

I am having the same trouble!  Will try and delete WXPN out of my favorites and reload.  

No luck with deleting out of favorites and reloading, and also no luck trying to add the link to the WXPN livestream as a Sonos station.

Found a solution! If you download the WXPN 88.5 app on your phone and begin streaming, there should be a button in top right corner for Airplay, if you click it there should be at least one of your Sonos devices there. Even if it’s not the device you want to be streaming on, click it to begin playing there as well. While the WXPN app is still streaming, switch to the Sonos app. The Sonos app should now show the current song playing on WXPN stream but label the source as “Airplay”, and you should be able to edit the Group of devices streaming from there. A bit round-about but I’ll take it, I hope this solution works for you as well! 

Badge

Buzz - thanks!  I also deleted my stored station in TuneIn and re-added, still no luck (same with Sonos Radio and Radio.Net).  I am curious about your note on radio station feeds to my ISP (FiOS).  If I can listen to WXPN on the iPhone TuneIn app, wouldn’t that be the same ISP stream that Sonos gets?  I’m not sure how to point Sonos to a direct stream (if I can get one from the radio station).  

 

Badge

cindymcd - I’m glad I'm not alone!  I tried your Airplay workaround - it works well, just a number of steps to get it playing.  I’m curious if (to Buzz’ point) this is ISP related.  I’m FiOS in Northern Virginia (as was my friend who had the same problem).  Are you FiOS as well?  Again - big thanks for the workaround!

 

Badge

Another oddity.  I found the direct stream for WXPN (https://wxpnhi.xpn.org/xpnhi) - this plays in my browse directly, not using the WXPN online player.  When I try to add the URL to Sonos (desktop controller, MANAGE>ADD RADIO STATION, then play the new station from TuneIn in Sonos), I get the same issue: the stream appears to start and immediately stops.  

FWIW, I’m using COMCAST. I’ll check with a friend who lives in Arlington, using FIOS.

This happened to me too. Only XPN (not XPN2). Cindy’s workarounds a no go bc components not recognized by Airplay. Station Delete & reinstall did not work either. We’re on FiOS.

My Arlington friend is not experiencing any WXPN issues.

I am glad I found you guys.  I was super annoyed that WXPN streaming stopped working.  I emailed the station to see if they had any idea why this happened.  Haven’t heard back.  I guess I will use the work around as well….

Userlevel 1

I just heard from WXPN member services - they suggested the MyTuner service - found WXPN there and am able to stream station to all Sonos speakers again.  Station would not start on TuneIn or Sonos Radio.

Oh thank you THANK YOU I’m not crazy!!  Tried TuneIn and NOT working.  Mirroring from my phone just not realistic.  Also contacting member services... 

Badge

I just heard from WXPN member services - they suggested the MyTuner service - found WXPN there and am able to stream station to all Sonos speakers again.  Station would not start on TuneIn or Sonos Radio.

Thanks for the answer!  It works well.  I’m curious, did WXPN member services mention why the station no longer works through Sonos Radio, TuneIn or Radio.Net? 

The only downside I’ve found to MyTuner: Alexa integration.  I have my Echos grouped to Sonos zones.  When I ask Alexa to play WXPN through MyTuner, I get multiple radio stations to choose from.  This is apparently an ongoing issue.  It would be great to get back to TuneIn.

I really appreciate your reply jtc456!

 

Userlevel 1

When WXPN replied they gave this issue to their engineers to investigate.  I also heard back from a Sonos engineer.  They were able to duplicate the problem and are investigating.  I think these people are in touch with Tunein.  All I know is I have the station back - life is good!

I just heard from WXPN member services - they suggested the MyTuner service - found WXPN there and am able to stream station to all Sonos speakers again.  Station would not start on TuneIn or Sonos Radio.

Right that did work - to clarify for me at least, I had to add MyTuner to my Sonos (I am V1.0 btw) as a Service, just like TuneIn.  For a second I thought you all meant to stream to the phone and through Sonos that way, but this is really just a TuneIn replacement!

Userlevel 2

I have the same issue with playing WXPN. It stopped working on Sonos in the first or second week of November. It still is not playing. I discovered I can play WXPN directly on my iPhone, Android and Windows devices via the TuneIn app and on the xpn.org and TuneIn websites, but it doesn’t work on the TuneIn service through Sonos.  I’ve been emailing with TuneIn technical support and was on the phone with Sonos technical support for an hour, but still no resolution. WXPN also does not play through the Sonos radio app either.  TuneIn technical support told me they will reach out to Sonos.

I added the MyTuner service to my Sonos system and am able to play WXPN as some one suggested earlier in this thread.

TuneIn updates their database once every 24 hours. If they fix a station link, the best information that I have is the updates go live at about 10pm EST.

Thanks, everyone. I also thought it was my problem that WXPN wasn’t playing anymore. Added MyTuner service to the sonos lineup and now entering the station that way. Hope they fix the problem, though.

I have contacted Sonos customer support 3 times about WXPN not working on a S1 system, and they haven’t been able to help me.  I saw the post about using My Tuner service, and it’s working perfectly.

That certainly suggest that either WXPN turned off their server connection with TuneIn, or the server is having issues. Sonos has no control here. 

Userlevel 7
Badge +17

@marcaputo Have you contacted TuneIn about this?

Userlevel 2

Guys; 

Have been experiencing the same issue for weeks. I’m on Comcast in Maryland with S1 and WXPN via TuneIn Radio abruptly stopped working.  I just tried the fix noted above of adding the MyTuner music service, added XPN as a favorite station and it is working again!!! Christmas Magic??

Thank you.

No, most likely the radio station changed which streaming service it was associated with. Most of them have exclusivity contracts. 

Badge

So glad to know that I am not the only one. Been in touch with Sonos, Tune in, and XpN.  My Tuner worked until today Jan 2, 2022.    Here is the response I got from Tune in

 

“Thank you for the follow-up. According to Sonos, the station does not meet the minimum requirements for S1 speakers to support this station's stream. Due to the age of the S1 devices, Sonos is unable to implement new features and updates that the S2 speakers can support. For this reason, the station will not play on any S1 speaker. We are still working with the broadcaster to see if there is anything they do with the stream.

We apologize for any inconvenience caused and thank you for your understanding.”

Reply