Answered

Spotify randomly stops?


So it seems when I play Spotify through both Spotify Connect and the Sonos app on both my iPad and iPhone, Spotify randomly stops playing. This seems really to only seems to happen at night. I can press play and the audio will resume right where it left off. This is with a SYMFONISK hardwired with an Ethernet cable.

 

I submitted diagnostics: 1031354842

icon

Best answer by Corry P 2 September 2021, 10:00

Hi @Humancaptcha 

Powerline is not supported for this very reason. I suspect there’s something in your home that a) only gets turned on at night and b) produces a lot of noise on your mains electricity circuits, disrupting the signal between Powerline adaptors.

We’d much prefer you to not use Powerline at all, but I understand that you probably have it in the first place as it’s the best available option. Finding the source of the noise on the mains circuits might be your only recourse. Typically, LED dimmer switches can cause such noise.

A nice, long ethernet cable from router to switch would be preferable (assuming the switch lives at the powerline adaptor and not the router).

I hope this helps.

View original

10 replies

Userlevel 7
Badge +17

Hi @Humancaptcha 

Welcome to the Sonos Community!

Given that the issue clearly isn’t happening due to interference, I recommend you reboot your router by removing power for at least 30 seconds.

As I’m seeing some authorisation issues in the logs, if rebooting the router doesn’t help, please remove Spotify from your Sonos system and add it again:

Remove a music service account from Sonos

Add a music service to Sonos

I recommend rebooting your router several times a year.

I hope this helps.

I restarted my router. Removed and re-added spotify multiple times. I STILL have the same issue.

 

Submitted new diagnostics: 1675976480

 

i am beginning to regret my purchase.

Userlevel 7
Badge +17

Hi @Humancaptcha 

Your speaker is reporting that it’s ethernet-wired, but it’s not reporting that it’s wired to a router - please connect the speaker to your router directly and test. If this isn’t possible, please select Settings » System » Network » Manage Networks » Update Networks and connect the speaker to WiFi. Thanks.

Keep us posted on your progress.  I am waiting to purchase Spotify premium.  I hesitated because of all the reported problems with my Sonos.  I am very inve$ted in Sonos, like it or not.  If you find a more compatible streaming service, please let us know.  

The problem was also presenting in the exact same circumstances using wifi.

 

More diagnostics: 930757295

 

It’s my understanding that when Spotify is playing through a Sonos speaker, the initiating device (iPhone, iPad etc) being turned off/ locked shouldn’t cause an interruption in the playback correct? 
 

I literally only have this issue at night. I can start Spotify on the Sonos from my desktop and turn off the computer and Spotify will still continue playing Spotify. There doesn’t seem to be any reason the same shouldn’t be true for an iPad.

Userlevel 7
Badge +17

Hi @Humancaptcha 

Your latest diagnostic shows the same as the last - ethernet wired, but not to the router - and no saved WiFi credentials.

You are correct. When either playing from the Sonos app or from the Spotify app, said app does not need to be kept open, nor does the device need to stay on, for your speaker to play. If you were using AirPlay, this would not be the case - the host device would need to stay on.

The issue being reported is a lack of bandwidth - even after asking for a lower bitrate from Spotify, your speaker still struggles to maintain the stream at a fast enough speed. This shouldn’t happen with ethernet, unless your internet connection is either slow, or being used up by something else - do you have anything on your network that uses bandwidth at night, like a computer backing up to the cloud? There must be some explanation of why this only happens at night.

What is your speaker ethernet-wired to?

 

So this is an Ethernet connection using a power line adapter and a 5 port switch. 
 

I’ll have to double check if there’s extra stuff taking up bandwidth overnight. Also, I’ll check WiFi again.

 

It’s helpful to know it’s a bandwidth issue. Thanks!

Userlevel 7
Badge +17

Hi @Humancaptcha 

Powerline is not supported for this very reason. I suspect there’s something in your home that a) only gets turned on at night and b) produces a lot of noise on your mains electricity circuits, disrupting the signal between Powerline adaptors.

We’d much prefer you to not use Powerline at all, but I understand that you probably have it in the first place as it’s the best available option. Finding the source of the noise on the mains circuits might be your only recourse. Typically, LED dimmer switches can cause such noise.

A nice, long ethernet cable from router to switch would be preferable (assuming the switch lives at the powerline adaptor and not the router).

I hope this helps.

So I was routing my internet traffic through a VPN. I created firewall rule that excludes Sonos, instead routing it through my ISP connection directly. That seemed to help for a bit. I was able to play Spotify uninterrupted for a good few hours the other night. 
 

However, I’m still experiencing this issue. I can play Spotify through my phone, IPad, and computer without any issue while this Sonos speaker cannot play without freezing on the exact same WiFi network at the exact same time of day. 
 

I can only conclude that this speaker wasn’t worth the money spent.

Userlevel 7
Badge +17

Hi @Humancaptcha 

Sonos don’t support the use of Powerline or VPNs. I suspect the real problem is the Powerline, however - how do the transfer rates on a separate device connected to Powerline compare between the times Sonos works, and when it doesn’t?

 

Reply