Sonos Suddenly Cannot Find Music Library - Buffalo LS2010 D Series

  • 24 November 2021
  • 10 replies
  • 146 views

I currently store my music on a Buffalos LinkStation 210 2TB NAS drive. For over one year, this has worked great with no issues. However, recently (and I think immediately after I ran the last Sonos update), my Sonos system can no longer locate the directory. It tells me that the NAS (a) might be disconnected or (b) that the login credentials are possibly not up to date. I know both of those suggestions are incorrect because: (a) I can access it via my computer without any issues whatsoever; and (b) the username/password have never changed.

All the same, I have tried removing the directory and putting the path back into Sonos. I have reset the username and password and put those into Sonos. Nothing I do though works. I have tried variations on the path, to no avail. Although I have tried variations, typically the path is this: //LS210DAED/share/Music/Music

For a little more context: About two weeks ago I added new music to the NAS and updated the library without issue. Then, at some point, I ran an update on the Sonos controller. Then, last week, I tried to add new music to the library (and successfully put it on the NAS), but when I clicked “update library” it said it couldn’t find the path. Interestingly, all of my music library prior to that update was still showing and functioning, but I could not get it to update. Eventually, I removed the directory totally from Sonos in hopes that I could get the updated version to connect. I failed. 

I am open to any thoughts/suggestions on this. Thank you.


10 replies

Have you checked the Buffalo’s setting for SMB to make sure that a firmware update didn’t turn off SMB v1 and NTML1?  Since the Sonos speakers use a different method to reach the NAS, the fact that a desktop machine can ‘see’ the music doesn’t really impact whether Sonos can. 
 

Its been a semi-frequent issue when a firmware update alters the settings on an NAS, at least on my Western Digital, without notification. Certainly worth double checking, as it completely fits your situation. 

Thank you for your reply and suggestion. I just double-checked the settings and the SMB setting is still on. (It says, under protocol: “Switch between SMB2 and SMB1 automatically.” I am, admittedly, only vaguely aware of these types of things, so I will be honest: I don’t see any mention of NTML anywhere, but AFP is listed as on/active as well. 

I too have had the exact same problem with media files stored on the Buffalo NAS. SMB settings remain unchanged - switch between SMB2 and SMB1 automatically and this issue only occurred after recently applying the update to the Sonos controller. 

Note that if I add smaller subfolders containing music media these will occasionally add successfully but will eventually revert to the error message stated above. The same behavior is seen from Sonos controllers on IOS and Windows hosts. 

What did Sonos say when you submitted a diagnostic and called in?

Yet to get through here - will attempt to get hold of a real person tomorrow. Have you managed to log anything yourself?  

hi @skilletP in analogy with a Synology NAS, Sonos requires SMBv1 enabled and needs the NTLMv1 protocol to authenticate

 

Update: After spending over an hour on the phone with Sonos (they were very helpful and courteous -- I have only good things to say about the customer support), ultimately, it turned out that some settings related to shared access had somehow gotten turned off. It was unclear whether that was due to the update itself or possibly due to a MacOS update that was run a week or two earlier. The error message (discussed above) didn’t indicate anything like that, so it took quite a lot of trial and error to get to the source of the issue. But, ultimately, it was resolved and I have music back. 

thanks for sharing the good news @skilletP  - enjoy

 

Hi @skilletP , I seem to have the same problem as you - happened about a week ago.

Do you have any more information as to how it was fixed! I am pulling my hair out here! 

Thanks!

Exact same problem. Same NAS. Tried all weekend to get it to work. This evening, I switched the SMB to SMBv1, not automatic. Everything appears to work now.

Reply