Answered

Sonos Radio Reauthorize

  • 11 December 2020
  • 38 replies
  • 563 views

Userlevel 1
Badge

Hi,

 

My Sonos system comprises round 10 Play:1, several Play:3. All works brilliantly and I love it. Moved over to Sonos Radio and very pleased … apart from one thing.

Every 10-14 days alarms stop working first thing - I get the infernal chime instead of Radio 4 at 630am! When I check the app it says radio needs reauthorised. When I click to authorise it all works fine again and stays that way for another period of time before the whole saga starts again. This has now happened maybe 5 or 6 times.

Is there any way to make the authorisation permanent? I don’t have this authorise problem with Apple Music or Spotify. It is rather annoying as always appears on a 630am alarm then I need to fiddle around to get Radio 4 for wakeup!

If anyone can offer any assistance I would be very grateful. Thanks in advance!

Kind regards

Andrew

icon

Best answer by Ken_Griffiths 29 December 2020, 00:27

Happened again. Playing fine on two groups. Tried to change station. App reports unable to change to BBC world service. Close and open app. No change. BBC radio 2 playing and 6 music on another group. Same issue. Can’t change station on other groups. go to settings. Click reauthrorize and all fine again. No other change needed.

 

 Before trying reauthorize I tried tune in. No issues at all despite not being used for weeks. No authrorize problem there or on Apple or Spotify. 
 

alarms moved to tune in away from Sonos radio for bow. Contemplating moving all favourites to tune in. It worked for years without a glitch.

can anyone shed any light before I make move back to TuneIn?

I would suggest that when you encounter the issues mentioned, you perhaps submit a system diagnostic report and post any references back to this thread. Then when you have gathered some data, to contact Sonos Customer Care via this LINK and ask them to take a closer look at your setup and issues.
 

I’m currently subscribed to Sonos Radio HD and so cannot assist, but have not had anything similar and had some stations playing for many hours some days without a problem, but this might be system, or even region related. The diagnostics will hopefully help to get the issue resolved.

View original

38 replies

Userlevel 1
Badge

My Sonos system comprises round 10 Play:1, several Play:3. All works brilliantly and I love it. Moved over to Sonos Radio and very pleased … apart from one thing.

Every 10-14 days alarms stop working first thing - I get the infernal chime instead of Radio 4 at 630am! When I check the app it says radio needs reauthorised. When I click to authorise it all works fine again and stays that way for another period of time before the whole saga starts again. This has now happened maybe 5 or 6 times.

Is there any way to make the authorisation permanent? I don’t have this authorise problem with Apple Music or Spotify. It is rather annoying as always appears on a 630am alarm then I need to fiddle around to get Radio 4 for wakeup!

If anyone can offer any assistance I would be very grateful. Thanks in advance!

Kind regards

Andrew

Userlevel 5
Badge +16

Hi @TuckerJ

Thank you for reaching out to the Sonos community and for letting us know about your concern. Reauthorizing an account in the Sonos App only happens if there’s a change in the account.

Let me suggest the next troubleshooting and see if it works for you.

  1. Are both of your Sonos app and system up-to-date?
    • On Sonos app: Go to App Store/Google Play Store to check for software update
    • Sonos System: On the Sonos app > go to Settings > System > Check for updates
  2. Sequential reboot to refresh your network and Sonos devices connection
    • Unplug your network devices (modem, router, any wireless access points on the network) from the power and wait for 60 full seconds before you plug it back in.
    • Once the router is back online, unplug all your Sonos devices from the power. Please wait 15 seconds before you plug back them back in.
    • Force close the Sonos app from your iOS or Android device.
    • When the status light on your Sonos speakers are solid white, get back on the Sonos app and check if you're connected.
  3. Remove and re-add Sonos Radio on the Sonos app

You mentioned that you need to re-authorize your Sonos Radio account when your alarm stops working every 10 to 14 days, after performing the steps above, please observe your Sonos system and let us know if you will still encounter the same, and when that happens, please run a diagnostic report from your Sonos system. Please don't forget to include the confirmation number in your response to look into it and find out the cause. 

If you have any questions about this, feel free to reach out. We and the community are always here to help.

Userlevel 1
Badge

It has happened again. Same symptom. Chime instead of radio at 645. Checked app and needed to authorise Sonos Radio. I did that and all worked fine again. For another however many days.

Since the last issue and the one I reported on 13/12 a lot has changed. Summary of what I have done.

Changed ISP. I am now with BT 1000mbps full fibre. Using Smart Hub and Complete WiFi. One Sonos is cabled into Smart Hub and all other Sonos are wireless. All IPs have changed. I restarted every Sonos speaker to get new connections. I removed Sonos Radio from service and added back. 

So I have completed a full reset of the Sonos and network. Everything should have refreshed.

I use Sonos App on three iOS devices and one macOS device. I have closed and opened the app numerous times  with a proper terminate.

I am not sure what else I can do. After I checked all was working again I have generated the diagnostic. The number is 249111750.

I have to admit I am getting a little annoyed by this. I have around £1500 of Sonos kit. I have done everything I can and yet I feel out of control and unable to resolve this. The endless suggestions to reboot the devices then the router and network do not strike me as an informed solution just an attempt to grab at a solution. I really want Sonos to work and continue to use it. Lately I am drawn to idea I need to take back control and go with DAB+ and Bluetooth - at least then I can resolve it. I am ever hopeful you can restore my faith and confidence in what is and should be a great sound system. 

Thanks for any assistance. I look forward to your updates.

Andrew

Tucker J

I would perhaps try a different ‘fixed’ non-overlapping 2.4ghz WiFi channel within your router setup, most routers default to channel 6, so perhaps try either channel 1 or 11. 
 

If you also have one or more Sonos devices wired to the LAN, then goto "Settings/System/Network” in the Sonos App and set your SonosNet channel at least 5 channels away from your chosen router channel and keep any ‘wired’ Sonos devices at least three feet away from other ‘wireless devices’, particularly away from the router, or other WiFi access points, then see if that fixes your ‘alarm’ issue.

Userlevel 1
Badge

Thanks for comments.

I have already implemented much of what you say.

Home network is channel 1 and Sonos was forced to 11. When left to select the optimal Sonos chose 1! How does that work?

All Sonos units are well away from any other wireless units including phones.

I am at the end of my line trying to diagnose and repair. I am not sure what else I can do.

Thanks for comments.

I have already implemented much of what you say.

Home network is channel 1 and Sonos was forced to 11. When left to select the optimal Sonos chose 1! How does that work?

All Sonos units are well away from any other wireless units including phones.

I am at the end of my line trying to diagnose and repair. I am not sure what else I can do.

Just change the WiFi channels manually, perhaps try your router on 1, 6 or 11 (fix the channel) use a 20MHz channel width for the 2.4ghz band and set the SonosNet channel so it’s on a different channel to the router - give each setting half and hour to see which combination works best, or you can begin the process by scanning your environment with a free software scanner like WiFiInfoView (as an example) just to see which are the least-used WiFi channels at your location. A bit of experimenting should soon sort the issue.. even changing the channel width to the recommended 20MHz will greatly help.

Userlevel 1
Badge

Thanks for the pointers. I don’t have any neighbours close enough to overlap. When I scan WiFi 11 has no traffic visible if I switch Sonos off. My home WiFi is on 1 but all devices connect on 5ghz. Router shows no devices on 2.4.

I’m a bit baffled and I suppose a bit frustrated by the whole thing. Unsure what to do. I also hate feeling out of control!

Userlevel 1
Badge

I’m going to remove and add Sonos radio. Will also prune other unused services.

Network has been checked and configured as advised. 
 

is there any recommended method? Should I also remove app from my devices and reinstall? Just keen to follow the recommended method to remove and reinstall Sonos radio for best chance of success. 
 

Thanks in advance for any assistance.

As long as the channels on the router are fixed and not auto-selected and set 5 (or more) channels away from the SonosNet channel, then you should be fine - if not, try different ‘non-overlapping’ channels.
 

Set the 2.4ghz channel-width to 20MHz and the 5ghz channel-width to 40MHz.

 

Keep any wired Sonos devices away from the router or other wireless devices (at least 3 feet away) to reduce interference.

 

You may find also this video helpful:

Wireless Interference and Sonos

 

Userlevel 1
Badge

I have completed all steps everyone suggested. Many thanks for suggestions.

WiFi checked and channels configured. Moved the Sonos with Ethernet connection to a higher position well away from any other WiFi or other RF. 

reset all units and left off for period of time. 

Removed some audio sources I don’t use much. Can’t remove and add Sonos radio as it seems fixed service now.

all working fine but will see if the authorise issue arises again. 

I am very keen to subscribe to Sonos radio HD. The issue with authorise is making me reluctant. If it resolves or can be resolved I would love to subscribe. 

Userlevel 1
Badge

Happened again. Playing fine on two groups. Tried to change station. App reports unable to change to BBC world service. Close and open app. No change. BBC radio 2 playing and 6 music on another group. Same issue. Can’t change station on other groups. go to settings. Click reauthrorize and all fine again. No other change needed.

 

 Before trying reauthorize I tried tune in. No issues at all despite not being used for weeks. No authrorize problem there or on Apple or Spotify. 
 

alarms moved to tune in away from Sonos radio for bow. Contemplating moving all favourites to tune in. It worked for years without a glitch.

can anyone shed any light before I make move back to TuneIn?

Happened again. Playing fine on two groups. Tried to change station. App reports unable to change to BBC world service. Close and open app. No change. BBC radio 2 playing and 6 music on another group. Same issue. Can’t change station on other groups. go to settings. Click reauthrorize and all fine again. No other change needed.

 

 Before trying reauthorize I tried tune in. No issues at all despite not being used for weeks. No authrorize problem there or on Apple or Spotify. 
 

alarms moved to tune in away from Sonos radio for bow. Contemplating moving all favourites to tune in. It worked for years without a glitch.

can anyone shed any light before I make move back to TuneIn?

I would suggest that when you encounter the issues mentioned, you perhaps submit a system diagnostic report and post any references back to this thread. Then when you have gathered some data, to contact Sonos Customer Care via this LINK and ask them to take a closer look at your setup and issues.
 

I’m currently subscribed to Sonos Radio HD and so cannot assist, but have not had anything similar and had some stations playing for many hours some days without a problem, but this might be system, or even region related. The diagnostics will hopefully help to get the issue resolved.

Userlevel 1
Badge

Will do. Next time the authorise issue shows up I will not do anything until I have generated a debug.

Odd thing is there is absolutely no other issues. All other services work fine - Audible, Apple, Spotify, TuneIn and myTuner. I am not an intense user and Sonos is mostly a multi-room radio for me and even then mostly for BBC 2,4 and 6 with some WS. I have often wondered if I should add a basic radio to a whole home FM transmitter and go for dumb radios and smart plugs to switch on!

Sonos Radio will play for days. When the authorise issue shows up all playing stations continue playing. I just cannot select a new station or any alarm that would start a new stream will not work. This is corrected with a simple re-authorise. No playing streams stop working. One stream (Radio 2 on a stereo pair) has been playing for over 14-days with no glitch and has gone through three re-auth!

I am very keen to add Sonos HD but not willing to do so while this issue happens.

I will leave things as they are and continue to use Sonos Radio until the issue pops up again. When it does I will dump the diagnostics and post a message here.

Thanks for all the assistance. It is much appreciated.

TuckerJ,

I forgot to mention to also check the Sonos Status Page when you next encounter an issue:

https://status.sonos.com

Just in case there is a temporary outage of the Sonos Radio Service… which may ‘perhaps’ occasionally happen too, from time to time, just to save you the time and trouble of reporting.

Userlevel 1

Exact the same problem here. I also use my Sonos system as an alarm clock and every x days I need to authorize the account again. Nothing of the above helps. It’s the only service that has that behavior.

Exact the same problem here. I also use my Sonos system as an alarm clock and every x days I need to authorize the account again. Nothing of the above helps. It’s the only service that has that behavior.

I would also suggest that when you encounter the issues, you perhaps submit a system diagnostic report and post any references back to this thread. Then when you have gathered some data, to contact Sonos Customer Care via this LINK and ask them to take a closer look at your setup and issues.

Userlevel 1
Badge

As expected it has happened again. Around 5 days since last time. Alarm was chime instead of radio.

I did nothing and generated a support diagnostic while chime playing! The id is 1674647213. Do I need to do something else to ask Sonos support to look at this?

I am guessing if I go to services and reauthorise now it would resolve. However I will leave it as is in case anyone has other info to suggest or another diagnostic is required. I can use tunein and it will Play fine. Sonos radio will remain locked until I reauthorise.

Thanks in advance for any assistance.

Userlevel 1
Badge

I have not reauthorised Sonos radio. Still cannot select a station. TuneIn and myTuner play without issue. Spotify fine. Audible fine.

It is Always and only Sonos radio. No other issues. No other action needed other than reauthorise.

I cannot find any other reason or solution. I am quite happy to forget about Sonos radio if only I could delete it from services but cannot. 
 

I have heard nothing after submitting and linking the diagnostic. I am not used to this and wonder if I need to advise anyone the diagnostic has been submitted.

Thanks in advance for any assistance. 

TuckerJ,

Perhaps see my earlier post above about contacting Sonos Customer Care after submitting your diagnostic report. The link in that post provides options to contact their support team, email, phone etc. 

Userlevel 2
Badge +1

Ditto.

Have given up on Sonos Radio and gone back to TuneIn. Struggled to see an advantage of SR if I’m honest...

Why do I have do reauthorize my account in the system settings every few days to keep Sonos Radio functioning? This is boaring.

Why do I have do reauthorize my account in the system settings every few days to keep Sonos Radio functioning? This is boaring.

You should not need to do that, see my earlier post above about contacting Sonos Customer Care after submitting a system diagnostic report when it next happens again. The link in that post provides options to contact their support team by email, phone etc. 

And another me too, and yesterday it was even worse as it refused to reauthorize. What was even more annoying was that I was in the middle of playing playlist and it just stopped.

There seems to be a fundamental problem with the SONOS Radio app as this is happening to so many of us, all with different configurations.

My system and applications are all up-to-date.

There seems to be a fundamental problem with the SONOS Radio app as this is happening to so many of us, all with different configurations.

My system and applications are all up-to-date.

Agreed.

I have had the exact same issue as you describe.
This morning, I faced the dreaded Sonos Chime instead of radio, and I am now unable to reauthorize the account.
All my systems are up to date as well.

 

Badge

I have exactly the same problem, which happens just as others have described it. As has been said, it doesn’t happen with any other streaming service, therefore I doubt it’s to do with channel selection or placement of the equipment (I’ve addressed all that anyway). Clicking reauthorise solves it immediately, but as TuckerJ pointed out, it’s especially frustrating when it happens on the morning alarm. It also should be completely unnecessary. This is happening to enough people for it to be fairly clear it’s a problem with Sonos Radio and not with individual systems and set ups. Sonos ought to be able to correct this. I subcribe to Sonos Radio HD but plan to cancel unless this matter can be resolved.

Reply