Missing Imported Playlists in Sonos S2 Controller Music Library

  • 10 December 2021
  • 13 replies
  • 205 views

Userlevel 1

As stated, my Imported Playlists do not include my iMusic library playlists. I do not subscribe to iMusic streaming service. My music library resides in the customary location on my Mac HD. I am running Mac OS 12.0.1. Any suggestions?


13 replies

Userlevel 7

Take a look at this article, particularly this section:

If your playlists are still missing after adding your music folder, it’s possible that your playlist files are stored in another folder on your computer. Find out where your playlist files are stored, then add that music folder to your library so Sonos can index the right files.

https://support.sonos.com/s/article/153?language=en_US

Userlevel 1

Thanks for the reply. I spoke with Apple Support today. There is no unique folder where playlist information is stored. There is a file called Music Library. The file type is *.musiclibrary. Mac also has an iTunes Music folder that contains the iTunes Music Library. This file is in *.xml format. Is it possible that the S2 Controller cannot read the Music Library.musiclibrary file? Maybe this is where the metadata is located for the playlists.

The Sonos system reads the iTunes Music Library.xml file to import playlists.  That file must be in the path you share to Sonos.

If memory serves, that file is only now created by the Apple Music software when you select the ‘export to .xml’ function in the save menu. It’s no longer created by default, as it used to be. 

Userlevel 1

Thanks for the information. I will check out the option to “export to .xml” in Music 1.2.0.273. Be great if that was the answer!

Userlevel 1

Turns out, it is easy to create a XML file of your music library. In the Music App, to File>Library>Export Library. You just have to choose the location to store it!

The path to my music library in Sonos is: /Users/dhassell/Music/Music/Media (default location for Mac OS). The new XML file has to be in the folder where your music library is stored. I have put this file in several locations in this path followed by re-indexing with no success. The playlists still do not show up. I am including a screenshot of the path. Any suggestions?

 

@MauiAloha 

It looks like you have the .xml file stored in your ‘Media’ folder - try putting it in the ‘Music’ folder instead

Userlevel 1

The Media folder is the last folder in the path: /Users/dhassell/Music/Music/Media. I put the XML file in the /Users/dhassell/Music/Music/Media/Music folder, where it is listed along with the Artist folders. That did not work either. You think the S2 Controller is looking for a specific XML file name, not just any XML file in the Music folder?

I would have imagined it was the default name when you exported the .xml file. Are you renaming it?

 

The Media folder is the last folder in the path: /Users/dhassell/Music/Music/Media. I put the XML file in the /Users/dhassell/Music/Music/Media/Music folder, where it is listed along with the Artist folders. That did not work either. You think the S2 Controller is looking for a specific XML file name, not just any XML file in the Music folder?

Yes maybe… perhaps try ‘iTunes Music Library.xml’.

I don’t use the .xml file for my own library tracks, instead I use an iOS playlist generator (MusicStreamer App) to create separate .m3u playlists. In fact that App can read .xml files aswell and export the playlists over to the .m3u format too.

Userlevel 1

I did change the default export name, Library.xml, to Music Library.xml. I was trying to imitate the iTunes music library naming convention. I will change it back to the default and see what happens. I appreciate the suggestion to use MusicStreamer App, I just am not ready to give up on the Apple Music application. I also checked the Media folder permissions and SonosDMS has read & write permissions.

 

Userlevel 1

An update. Problem solved! I called Sonos support.

In the Music app, the path to the music library is: /Macintosh HD/Users/dhassell/Music/Music/Media

The path used by Sonos support was: //dhassell/music

You have to set permissions for the //dhassell/music folder, which includes SonosDMS with read/write permissions.

In the above example, the Music Library is in the default location for the Music app. The user name would be the user name you created at the time you set up your Mac or added a user later.

While not discussed, I had previously exported the Music Library as Library.xml. I put this file in the Media folder. I am not certain if this is the best location or not; however, it works.

Lastly, I added a new CD to my Music app and put this CD in one of my playlists. Just to be sure, I exported the Music Library again and let it overwrite the existing folder. I re-indexed my music library and the updated playlist was present.

Thanks to Sonos Support. I hope this post helps others with the same problem,

hi @MauiAloha happy to read your library updates work now - I am using the macOS Monterey Apple Music App version and observed that Apple changed the ‘behaviour’ of the App with regards to the Music Library export function - previously you could select in the preferences to share the library with external programmes which would automatically update the xml file - this option has been removed since version macOS Big Sur

 
 

Reply