Deleting WDMyCloud from Sonos

I want to delete my Western Digital storage unit from Sonos but cannot find how to do this.

12 replies

Userlevel 7

Go to Settings > System > Music Library > Music Library Setup and remove the shared folder from the list.

Thanks for the quick reply.  Problem is, I cannot see the WDMyCloud folder in the Music Library setup.  I only see my //iMac/Music folders.

Userlevel 7

Are you still seeing music from the WDMyCloud in your music library? Have you updated the Music Index in the Sonos app?

I still see music from the WDMyCloud.  And I have updated the Music Index.  It is as if the WDMyCloud is cemented in place.


Userlevel 7

Have you checked if it happens to be listed under Settings > Services & Voice > Music & Content?

Yes, I have.  WD is not there.  I might have to delete Sonos and start all over again.  The source is there and the music is listed but no music will play, just an error (701).  This all started when Sonos indexed my music by artist, album, etc.

Userlevel 7

Try deleting and reinstalling the Sonos app and rebooting your router.

Thanks GuitarSuperstar, I’ll give it a try and see what happens.  By the way, my son is the best acoustic and electric guitar repairman in Wisconsin.

You should be able to go to Settings → Service & Voice and delete the MyCloud service.

Deleting and reinstalling Sonos does not work.  And there is no WDMyCloud in Service and Voice.  I believe I am going to have to set up a brand new account and go through the whole process adding my speakers and iTunes and Amazon music.  WDmyCloud is visible but not there to delete.

Userlevel 7

If you have a desktop computer, you might try downloading the Sonos app on the computer and removing the music library:

Userlevel 7
Badge +17

Hi @jackthorn 

Welcome to the Sonos Community!

If you’re still having this problem I recommend you get in touch with our technical support team, who have tools at their disposal that will allow them to give you advice specific to your Sonos system.

@buzz’s answer should have worked - the only reason I can think of as to why WDMyCloud wouldn’t appear in your services list is if you have an incorrect/unsupported location set in your Sonos profile (log in at then select Profile and then Edit Profile if you need to change anything). I would have thought, however, that as it’s a private server it should be available everywhere, though I could be wrong as the service does utilise Western Digital’s cloud service which could, conceivably, have geo-restrictions.

I hope this helps.

Edit: By the way, this is not related to the Music Library. That’s a separate entry (if active) in the Sources list that you posted a screenshot of.