Answered

Can't play to Sonos via Spotify Connect anymore?

  • 11 January 2021
  • 4 replies
  • 72 views

I’ve had Sonos Play:5 (Gen 2) for a few months now and it worked perfectly via Spotify Connect. 

A couple of days ago I purchased a second Play:5 to create a stereo pair and since then I am unable to play via the Spotify app?

I’ve deleted and reconnected Spotify, reset my router etc and it still won’t connect - any ideas?

icon

Best answer by Corry P 23 February 2021, 12:55

Hi @thepowerison 

Are you still having this problem? If so, please switch your router off for 30 seconds, then switch back on and test a couple of minutes after you get your WiFi back. If that doesn’t help, please get in touch with our technical support team directly.

View original

4 replies

Userlevel 6
Badge +16

Hello there @thepowerison, Thanks for reaching out, and welcome to the community. Sorry to hear about this issue with Spotify on your Sonos speakers. I’ll ask some questions to check further, Are you getting any error message when playing on the Spotify App? 

Kindly check these steps to see If it will work.

  1. Verify if you're using the current version of the Spotify app and Sonos app. Kindly check for updates before testing playback again.
  2. Ungroup rooms in the Sonos app.
  3. Start playing a track from the Spotify app and confirm audio is playing from the device before targeting a Sonos speaker.

Keep me in the know with the advice above. We’re always here to help.

 

Yep I’m using the current versions of the sonos and Spotify apps.

I only have one room operating, previously with one play:5 (which worked fine), but now with a stereo pair of play:5’s

Music plays fine from the Spotify app through my Mac’s speakers, it just gets stuck when I try to connect to my sonos room via Spotify connect.

Userlevel 6
Badge +16

Hi @thepowerison, thanks for the update. So we can have a better view of the status of your Sonos system,  please submit a diagnostic and respond with the confirmation number. This way we can identify the cause of the issue. Does it also happen on another device controller where you have the Spotify and the Sonos App if it’s doing the same thing? 

Keep me in the know with the advice above. We’re always here to help.

Userlevel 3
Badge +10

Hi @thepowerison 

Are you still having this problem? If so, please switch your router off for 30 seconds, then switch back on and test a couple of minutes after you get your WiFi back. If that doesn’t help, please get in touch with our technical support team directly.

Reply